Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 146305 - Rename of action handler method does not work.
Rename of action handler method does not work.
Status: RESOLVED DUPLICATE of bug 106831
Product: guibuilder
Classification: Unclassified
Component: Code
5.x
All All
: P3 (vote)
: TBD
Assigned To: issues@guibuilder
issues@guibuilder
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-05 11:44 UTC by Jan Jancura
Modified: 2008-09-08 13:48 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Jancura 2008-09-05 11:44:16 UTC
1) Create some form (JFrame).
2) add JButton there
3) Generate actionPerformed (...) handler (popup menu on JButton > Events > Actions > ...)
4) switch to text editor put cursor on xxxactionPerformed method name
5) try to rename method (Ctrl+R)
>
It looks like that rename feature is supported, but new name is not used. We should fix rename action, or it should be
disabled in this case, or some message should inform user, that rename is not supported in this case.
Comment 1 Jan Stola 2008-09-08 13:48:16 UTC
This is one of known limitations of refactoring support in GUI builder. See issue 106831 and section 'Rename event 
handler method in the form class' in http://wiki.netbeans.org/GUIBuilderRefactoring

*** This issue has been marked as a duplicate of 106831 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo