Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 146275 - Representation of non-printing characters
Representation of non-printing characters
Status: RESOLVED DUPLICATE of bug 4619
Product: editor
Classification: Unclassified
Component: Painting & Printing
6.x
All All
: P3 (vote)
: 6.x
Assigned To: issues@editor
issues@editor
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-05 05:15 UTC by pmaciver
Modified: 2009-05-11 12:38 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pmaciver 2008-09-05 05:15:42 UTC
I think that you should also look at the way that non-printing characters are displayed within netbeans. At the moment
it only (as far as I know) allows you to color a while space block by using a color like which I think looks very ugly.
And seeing as I am a user of HAML a lot and tracking down bugs with how many spaces something is indented is an issue
that I have time to time, having non-printing characters look nice on screen is important to me.

I think you should allow the user to select the character and color of character that will be used for this. E.g. use a
dot, the whole character block, a tilde, a comma, whatever. But the user should have the choice over how the various
non-printing characters (White space, end of line, tabs) are displayed.
Comment 1 Vitezslav Stejskal 2008-09-05 12:42:15 UTC
It could be useful. Thanks
Comment 2 Vitezslav Stejskal 2009-05-11 12:38:59 UTC

*** This issue has been marked as a duplicate of 4619 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo