Bug 146153 - API providing programmatic way to display Plugin Manager dialog
API providing programmatic way to display Plugin Manager dialog
Status: RESOLVED DUPLICATE of bug 194518
Product: platform
Classification: Unclassified
Component: Plugin Manager
6.x
All All
: P2 (vote)
: 7.0
Assigned To: Jaroslav Tulach
au-issues
: API, API_REVIEW_FAST
Depends on:
Blocks: 146152 194518
  Show dependency treegraph
 
Reported: 2008-09-04 10:41 UTC by Petr Hejl
Modified: 2011-02-07 14:15 UTC (History)
5 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Hejl 2008-09-04 10:41:55 UTC
It would be useful for various dialogs to invoke the dialog via API in similar way implemented for options.
Comment 1 Jiri Rechtacek 2008-11-01 12:14:18 UTC
Added friend contract in rev/3f2fe7a4fa33. It should be reviewed and make as official API soon.
Comment 2 Quality Engineering 2008-11-04 16:23:17 UTC
Integrated into 'main-golden', will be available in build *200811041401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/3f2fe7a4fa33
User: Jiri Rechtacek <jrechtacek@netbeans.org>
Log: #146153: API providing programmatic way to display Plugin Manager dialog
Comment 3 Antonin Nebuzelsky 2008-11-14 15:33:18 UTC
Reassigning to the new "autoupdate/*" owner dlipin.
Comment 4 Jaroslav Tulach 2010-11-25 09:58:31 UTC
I guess I will expose a context sensitive action (sensitive to OperationSupport object) that one will be allowed to invoke with proper context.

I plan to remove the existing friend API.
Comment 5 Jesse Glick 2010-11-28 17:14:41 UTC
(In reply to comment #4)
> a context sensitive action (sensitive to OperationSupport object)

Seems odd; is there any use case for this being a context-sensitive action? This would only make sense in case there were e.g. several nodes, each with its own OperationSupport instance, and you wanted to add a context menu to them.

I would rather think that the factory would simply take a OperationSupport parameter (assuming one is needed at all), and return a non-context-sensitive action... or just return void and actually open the dialog, which is what the API currently seems to do (the caller can create an Action wrapper for this if appropriate but might call it some other way too).
Comment 6 Jaroslav Tulach 2010-12-07 11:49:31 UTC
Is there anybody who needs such API anyway?
Comment 7 Jesse Glick 2010-12-07 15:32:37 UTC
(In reply to comment #6)
> Is there anybody who needs such API anyway?

                <friend>org.netbeans.modules.autoupdate.pluginimporter</friend>
                <friend>org.netbeans.modules.cnd.toolchain</friend>

These definitely use PluginManager today.

                <friend>com.sun.tools.dlight.tools.customizer</friend>

Does not seem to exist anymore (and no such dep from dlight.* in current sources).

                <friend>com.microchip.mplab.nbide.embedded</friend>

They may still be using it.
Comment 8 Jaroslav Tulach 2010-12-07 16:35:53 UTC
OK, thanks. I don't want to encourage usage of cross cluster friend APIs.
Comment 9 Vladimir Voskresensky 2010-12-23 20:10:02 UTC
(In reply to comment #7)
> (In reply to comment #6)
> > Is there anybody who needs such API anyway?
> 
>                 <friend>com.sun.tools.dlight.tools.customizer</friend>
> 
> Does not seem to exist anymore (and no such dep from dlight.* in current
> sources).
Exists in close source part of Solaris Studio IDE group products, part of DLight product

> 
>                 <friend>com.microchip.mplab.nbide.embedded</friend>
> 
> They may still be using it.
They do use it.
http://netbeans.dzone.com/nb-microchip
Comment 10 Jaroslav Tulach 2011-02-07 14:15:58 UTC
OK, I've contacted com.microchip.mplab representative and started change of the PluginManager into stable API in bug 194518.

*** This bug has been marked as a duplicate of bug 194518 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo