Bug 146119 - Netbeans won't launch from finder
Netbeans won't launch from finder
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: -- Other --
6.x
Macintosh Mac OS X
: P4 (vote)
: 6.x
Assigned To: t_h
issues@platform
:
: 145027 146385 147542 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-04 04:15 UTC by garynunes
Modified: 2011-10-10 10:22 UTC (History)
7 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description garynunes 2008-09-04 04:15:44 UTC
I just downloaded NetBeans 6.1 to try it out. I'm running Leopard 10.5.4 with latest updates on an Intel based MacBookPro. The default Java for applications 
is 1.5.0_13.

When I double-click on the NetBeans 6.1 icon in the Finder NetBeans briefly appears in the dock, then disappears. NetBeans does not launch.

However, if I start a terminal window (bash) and execute the following command:
    open "/Applications/NetBeans/NetBeans 6.1.app"

NetBeans starts and, as far as I can tell, behaves normally (I'm running in an administrator account but it is not root).

A small log file is created during the attempted double-click launch. Here are its contents:

Process:         java [333]
Path:            /System/Library/Frameworks/JavaVM.framework/Versions/1.5/Home/bin/java
Identifier:      java
Version:         ??? (???)
Code Type:       X86-64 (Native)
Parent Process:  bash [235]

Date/Time:       2008-09-03 19:57:15.274 -0700
OS Version:      Mac OS X 10.5.4 (9E17)
Report Version:  6

Exception Type:  EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: KERN_INVALID_ADDRESS at 0x00006176616a2f6e
Crashed Thread:  0

Thread 0 Crashed:
0   ???                           	0x00000001000111c1 0 + 4295037377
1   ???                           	0x000000010001276f 0 + 4295042927
2   ???                           	0x0000000100012a1c 0 + 4295043612
3   ???                           	0x000000010001104d 0 + 4295037005

Thread 0 crashed with X86 Thread State (64-bit):
  rax: 0x0000000000000041  rbx: 0x00007fff5fbfe268  rcx: 0x0000000000000000  rdx: 0x0000000000000014
  rdi: 0x0000000100014708  rsi: 0x00006176616a2f6e  rbp: 0x00007fff5fbfe020  rsp: 0x00007fff5fbfe020
   r8: 0x000000009078a3d2   r9: 0x0000000000000000  r10: 0x0000000000000000  r11: 0x0000000000000000
  r12: 0x0000000000000014  r13: 0x0000000100014708  r14: 0x0000000000000015  r15: 0x0000000000000000
  rip: 0x00000001000111c1  rfl: 0x0000000000010293  cr2: 0x00006176616a2f6e

Binary Images:
    0x7fff5fc00000 -     0x7fff5fc2e593  dyld 96.2 (???) <f8badea89d68688d53ebe823a5f32cf1> /usr/lib/dyld

 
P.S. I am forced by the issue delivery system to choose a subcomponent. None seem to fit so I arbitrarily chose "ui".
Comment 1 Petr Chytil 2008-09-04 08:03:19 UTC
reassigning to core for evaluation
Comment 2 Lukas Hasik 2008-09-04 17:24:34 UTC
reassigning to launcher owner. CC'ing guys on Mac - could you please try reproduce?
Comment 3 garynunes 2008-09-04 18:04:30 UTC
Thought I'd mention that this problem may not be widespread but has affected a few others (as noted on the website http://getsatisfaction.com/netbeans/topics/netbeans_wont_start_on_os_x).
Comment 4 t_h 2008-09-05 08:38:30 UTC
It seems like apple JVM issue. I do not think anything can be done in launcher if JVM crashes. I guess this issue is not
related only to NB (see http://discussions.apple.com/thread.jspa?messageID=7915010)
Comment 5 t_h 2008-09-06 17:40:17 UTC
*** Issue 145027 has been marked as a duplicate of this issue. ***
Comment 6 garynunes 2008-09-06 18:11:01 UTC
Just to let everyone know: I also submitted a report on this issue to Apple (https://bugreport.apple.com/cgi-bin/WebObjects/RadarWeb.woa/wa/signIn).

Apple Developer Connection (ADC) membership is required to report bugs but the lowest level of membership is free (there's a link at the site referenced 
above to sign up for ADC membership).

Anyone else who wants to should also report this bug to Apple. The more reports they get about the same issue the more likely they are to address it (if 
indeed it is an Apple problem).
Comment 8 Lukas Hasik 2008-09-07 19:50:48 UTC
*** Issue 146385 has been marked as a duplicate of this issue. ***
Comment 9 t_h 2008-09-16 13:20:29 UTC
Mac issue
Comment 10 dlipin 2008-09-16 13:51:05 UTC
garynunes and jarome,

Is there any evaluation from Apple team? Unfortunately it is not possible to anyone (except yourself) access the bugs 
that you filed.

Thanks,
Dmitry
Comment 11 jarome 2008-09-16 14:00:05 UTC
They said it is a known bug. But it is not fixed in 10.5.5.
But a friend of mine with a Mac also has no trouble launching NetBeans. So what is different?
Comment 12 garynunes 2008-09-16 20:06:39 UTC
They haven't responded to my report yet, perhaps because it's a bit different from jarome's. I reported two such similar crashes:

One was this one (the NetBeans won't launch crash from Finder bug).

The second was an IDEA (another IDE) crash. However that crash doesn't happen when IDEA launches. Rather, it occurs when one attempts to compile 
(make, rebuild) an IDEA project using the built-in menu commands (if you generate an Ant build using IDEA the Ant build will compile the project 
successfully).

These and other reports strongly suggests a problem with Mac's Java environment but possibly not on all machines (though, maybe not enough machines 
are running Java applications for lots of people to notice).

Anyway, if/when apple responds I'll let you know what they say.
Comment 13 t_h 2008-09-18 09:33:57 UTC
*** Issue 147542 has been marked as a duplicate of this issue. ***
Comment 14 jarome 2008-09-18 13:51:21 UTC
Apple said "no change in bug status"
Comment 15 dnedrow 2008-09-23 18:49:18 UTC
So, no reasonable workaround and won't fix. Is that correct?

Attempting to launch NetBeans via the command line yields that same error and non-start. The only way to start the IDE is to sudo, but then everything ends 
up being owned by root, which really horks a shared development environment.

None of my other Java apps are failing, so I don't understand what's happening with this.
Comment 16 jarome 2008-09-23 20:10:27 UTC
It launches from the command line for me without sudo. But for others, double-clicking the app works. So it seems that
something that is dependent on the user profile is occurring. 

We need someone high up in the NetBeans/Sun organization to beat on Apple about this. Or NetBeans should give us some
debugging tools to see what is failing during the startup.
Comment 17 Milos Kleint 2008-09-25 08:02:06 UTC
please note that there's a new java update on the apple software update site since today.

additionally does your user account you run java apps with have the administrator access set?
Comment 18 Milos Kleint 2008-09-25 12:09:34 UTC
I cannot reproduce on my computer.

Product Version: NetBeans IDE Dev (Build 200809250201)
Java: 1.5.0_16; Java HotSpot(TM) Client VM 1.5.0_16-133
System: Mac OS X version 10.5.5 running on i386; MacRoman; en_US (nb)
Userdir: /Users/mkleint/.netbeans/dev

I don't know Jonathan, nor Steve.
 The issue is in the Apple codebase and is limited to a few user setups that I have no access to. The start up script
inside Netbeans.app is a .sh script, you can try debugging it, but I'm not sure if that will help. A VM crash is
something Apple has to investigate and fix.

->closing as invalid.
Comment 19 jarome 2008-09-25 15:17:32 UTC
The Java update changes nothing. And yes, my account has administrative access (but I would need to type in my password).
Comment 20 jarome 2008-09-25 17:20:39 UTC
Double-clicking the netbeans script in the bin directory launches a shell, and things work properly. The problem is not
in this shell script.

So the problem seems to be in packaging the app to allow something that can be put onto the dock and clicked.
Comment 21 jarome 2008-09-25 17:26:30 UTC
sorry. I did not change the version
Comment 22 dlipin 2008-09-25 17:27:19 UTC
Does it help if remove platform9/modules/org-netbeans-modules-applemenu.jar from netbeans directory?
Comment 23 jarome 2008-09-25 17:50:29 UTC
Nope
Comment 24 garynunes 2008-09-25 18:44:06 UTC
Finally got a response from Apple. It's under non-disclosure but I will paraphrase:

- We can't duplicate it so we're closing the report
- Try the new update
- If that doesn't work tell us how you messed up your Java installation so badly

Well, I did update (both to 10.5.5 and the new Java update) but no change.

I'm willing to believe that my Java is screwed up but h*ll if I know how it happened (I wouldn't keep it a secret). If anyone can generate more detail for Apple 
(or just give them more data points so they know the problem is not uniquely mine) please do so.

 I do have one more system log that might contain more info. It's copied below (maybe I'll send it to Apple too ... not sure whether it's worth it). Here it is:

Sep 25 09:34:51 FlyingMonkeys ReportCrash[840]: Formulating crash report for process java[839]
Sep 25 09:34:51 FlyingMonkeys ReportCrash[840]: Saved crashreport to /Users/gnunes/Library/Logs/CrashReporter/java_2008-09-25-
093451_FlyingMonkeys.crash using uid: 501 gid: 20, euid: 501 egid: 20
Sep 25 09:34:51 FlyingMonkeys [0x0-0x50050].NetBeans 6.1[741]: /Applications/NetBeans/NetBeans 
6.1.app/Contents/MacOS/../Resources/NetBeans/bin/../platform8/lib/nbexec: line 466:   839 Segmentation fault      
"/System/Library/Frameworks/JavaVM.framework/Versions/1.5/Home/bin/java" -
Djdk.home="/System/Library/Frameworks/JavaVM.framework/Versions/1.5/Home" -classpath "/Applications/NetBeans/NetBeans 
6.1.app/Contents/Resources/NetBeans/platform8/lib/boot.jar:/Applications/NetBeans/NetBeans 
6.1.app/Contents/Resources/NetBeans/platform8/lib/org-openide-modules.jar:/Applications/NetBeans/NetBeans 
6.1.app/Contents/Resources/NetBeans/platform8/lib/org-openide-util.jar:/Applications/NetBeans/NetBeans 
6.1.app/Contents/Resources/NetBeans/platform8/lib/locale/boot_ja.jar:/Applications/NetBeans/NetBeans 
6.1.app/Contents/Resources/NetBeans/platform8/lib/locale/boot_pt_BR.jar:/Applications/NetBeans/NetBeans 
6.1.app/Contents/Resources/NetBeans/platform8/lib/locale/boot_zh_CN.jar:/Applications/NetBeans/NetBeans 
6.1.app/Contents/Resources/NetBeans/platform8/lib/locale/org-openide-modules_ja.jar:/Applications/NetBeans/NetBeans 
6.1.app/Contents/Resources/NetBeans/platform8/lib/locale/org-openide-modules_pt_BR.jar:/Applications/NetBeans/NetBeans 
6.1.app/Contents/Resources/NetBeans/platform8/lib/locale/org-openide-modules_zh_CN.jar:/Applications/NetBeans/NetBeans 
6.1.app/Contents/Resources/NetBeans/platform8/lib/locale/org-openide-util_ja.jar:/Applications/NetBeans/NetBeans 
6.1.app/Contents/Resources/NetBeans/platform8/lib/locale/org-openide-util_pt_BR.jar:/Applications/NetBeans/NetBeans 
6.1.app/Contents/Resources/NetBeans/platform8/lib/locale/org-openide-
util_zh_CN.jar:/System/Library/Frameworks/JavaVM.framework/Versions/1.5/Home/lib/dt.jar" -Dnetbeans.system_http_proxy="DIRECT" -
Dnetbeans.system_http_non_proxy_hosts="" -Dnetbeans.dirs="/Applications/NetBeans/NetBeans 
6.1.app/Contents/Resources/NetBeans/nb6.1:/Applications/NetBeans/NetBeans 
6.1.app/Contents/Resources/NetBeans/ide9:/Applications/NetBeans/NetBeans 
6.1.app/Contents/Resources/NetBeans/java2:/Applications/NetBeans/NetBeans 
6.1.app/Contents/Resources/NetBeans/xml2:/Applications/NetBeans/NetBeans 
6.1.app/Contents/Resources/NetBeans/apisupport1:/Applications/NetBeans/NetBeans 
6.1.app/Contents/Resources/NetBeans/enterprise5:/Applications/NetBeans/NetBeans 
6.1.app/Contents/Resources/NetBeans/profiler3:/Applications/NetBeans/NetBeans 
6.1.app/Contents/Resources/NetBeans/gsf1:/Applications/NetBeans/NetBeans 
6.1.app/Contents/Resources/NetBeans/ruby2:/Applications/NetBeans/NetBeans 
6.1.app/Contents/Resources/NetBeans/visualweb2:/Applications/NetBeans/NetBeans 
6.1.app/Contents/Resources/NetBeans/identity2:/Applications/NetBeans/NetBeans 
6.1.app/Contents/Resources/NetBeans/harness:/Applications/NetBeans/NetBeans 6.1.app/Contents/Resources/NetBeans/cnd2:" -
Dnetbeans.home="/Applications/NetBeans/NetBeans 6.1.app/Contents/Resources/NetBeans/platform8" '-
Dcom.apple.mrj.application.apple.menu.about.name=NetBeans' '-Xdock:name=NetBeans' '-Xdock:icon=/Applications/NetBeans/NetBeans 
6.1.app/Contents/MacOS/../Resources/NetBeans/bin/../nb6.1/netbeans.icns' '-Dnetbeans.importclass=org.netbeans.upgrade.AutoUpgrade' '-
Dnetbeans.accept_license_class=org.netbeans.license.AcceptLicense' '-Xmx512m' '-client' '-Xss2m' '-Xms32m' '-XX:PermSize=32m' '-
XX:MaxPermSize=200m' '-Xverify:none' '-Dapple.laf.useScreenMenuBar=true' '-Dsun.java2d.noddraw=true' org.netbeans.Main --userdir 
"/Users/gnunes/.netbeans/6.1" "--branding" "nb"
Sep 25 09:34:51 FlyingMonkeys com.apple.launchd[172] ([0x0-0x50050].NetBeans 6.1[741]): Exited with exit code: 139
 
Comment 25 garynunes 2008-09-25 19:21:58 UTC
P.S.

For what it's worth, I did, in fact, add the additional information (message log in previous comment) to my Apple bug report.
Comment 26 jarome 2008-09-25 19:52:05 UTC
Its not uniquely yours. It bit me too. Perchance, did you install the Java 1.6 betas?
Comment 27 garynunes 2008-09-26 00:26:54 UTC
No, I didn't get the Java 1.6 stuff until it came with an official OS upgrade. Some version of 10.4 I think (maybe 10.4.4.?). Also, I haven't been using 1.6 for 
anything yet ... 1.5 is set as my default and I run all my Java apps under it.

As I mentioned in an earlier comment, I'm seeing what I think is a related problem with IntelliJ IDEA (i.e., same crash, but under different circumstances ... 
see an earlier comment for details).

Earlier today I pointed out to Apple (and I'll repeat it here) that both crashes (NetBean's Finder launch refusal and IDEA's compile/build refusal) are accompanied by the same Error Code, namely 139. JetBrains (the IDEA people) couldn't make anything of it. Maybe the NetBeans or Apple people will have 
an better luck.

One can dream.
Comment 28 garynunes 2008-09-26 23:32:30 UTC
This may be of little import but I noticed in previous comment (Thu Sep 25 17:44:06 +0000 2008) that the console message log I left contains the 
following at the beginning:

Sep 25 09:34:51 FlyingMonkeys [0x0-0x50050].NetBeans 6.1[741]: /Applications/NetBeans/NetBeans 
6.1.app/Contents/MacOS/../Resources/NetBeans/bin/../platform8/lib/nbexec: line 466:   839 Segmentation fault

A similar log (ran later) has:

9/26/08 2:46:45 PM [0x0-0xa60a6].NetBeans 6.1[2528] /Applications/NetBeans/NetBeans 
6.1.app/Contents/MacOS/../Resources/NetBeans/bin/../platform8/lib/nbexec: line 466:  2626 Segmentation fault


Both have the same line number (466). Probably not that useful but thought I'd point it out anyway.


Grasping at straws,
    Gary Nunes
Comment 29 garynunes 2008-09-27 04:02:54 UTC
A discussion has started in the Apple JavaDev list about this (and the possibly related IDEA) issue.

Someone there (Greg Guerin) pointed out that the crash logs associated with the NetBeans Finder launch failure (and IDEA compile failure) seem to indicate 
that the Java code was running in 64-bit mode when it crashed.

At least on my machine, Java is set to run in 1.5 32-bit mode. Also, the NetBeans app doesn't seem to be set up to run in 64-bit mode (in fact, when 
launched from the Terminal it runs in 32-bit mode).

So I guess some possible questions are:
- Would NetBeans crash if it tried to run in 64-bit mode?
- If so, why is it happening on some few machines (such as mine) but not others?
- And why only with Finder launch but not with Terminal launch (put another way, what has to be broken for that to happen)?

At least this might be a testable hypothesis, especially by someone who is familiar with the NetBeans launch process.
Comment 30 jarome 2008-09-27 15:00:41 UTC
This is old, but it discusses the launch process:
http://java.sun.com/developer/technicalArticles/JavaLP/JavaToMac3/
Comment 31 Milos Kleint 2008-09-29 07:24:53 UTC
As far as I can tell, there's nothing that can be done on our side.

please don't reopen the issue unless you have proof the netbeans startup script is causing the crash or have steps to
reproduce on any mac.

I'd also suggest looking into the claims made in this email
http://lists.apple.com/archives/java-dev/2008/Sep/msg00452.html

Comment 32 garynunes 2008-09-29 22:56:27 UTC
An interesting experiment. Greg Guerin suggested, on the JavaDev list, to try modifying the nbexec launch script (in the NetBeans.app package) as follows:

The 'arch' command can be used to specify execution of a particular  
architecture in a Universal Binary executable.  So in this command- 
line from the shell script:

eval ${_NB_PROFILE_CMD} "\"${jdkhome}/bin/java\""
-Djdk.home="\"${jdkhome}\"" -classpath "\"$cp\"" \
         $jargs org.netbeans.Main "$args" '&'

change it to:

ARCH_CMD="/usr/bin/arch -i386";
eval ${ARCH_CMD} ${_NB_PROFILE_CMD} "\"${jdkhome}/bin/java\""
-Djdk.home="\"${jdkhome}\"" -classpath "\"$cp\"" \
         $jargs org.netbeans.Main "$args" '&'


After doing so, NetBeans will successfully Finder launch (and continue to successfully Terminal launch since both mechanism share the common launch 
script).

Suggests that the problematic Java environments (like mine and jarome's) are having some kind of trouble with 32 vs. 64-bit mode, though how and why 
are the questions.
Comment 33 jarome 2008-10-22 18:52:13 UTC
This still will not launch in 6.5 RC1. It launches from the file in the bin directory
Comment 34 loudambiance 2008-11-06 05:26:46 UTC
I was able to get this work around to work with 6.5 rc2, with one exception. After changing the exec file I had to run
the Netbeans.app/Content/MacOS/netbeans with sudo to get it to generate the ~/.netbeans/6.5rc2 folder, one this was done
I did a recursive chown on the settings folder, and all launched well.
Comment 35 jarome 2008-11-06 13:54:04 UTC
Yes! The Glen Guerin patch fixed it for me. Please get this put into the final release! It is critical for Mac users.
Comment 36 Milos Kleint 2008-11-06 14:07:54 UTC
my comment from Mon Sep 29 06:24:53 +0000 2008  still applies. Forcing arch to be 386 for everyone is not a fix, but a
workaround for your usecase. It's a medication for a decease we don't know the cause of.

closing as wontfix again
Comment 37 jarome 2008-11-06 14:27:25 UTC
At the very least, you need to have this in the README file for other unfortunate users who have this problem. And what
does this work-around hurt? Of course it needs to only be for Intel Macs.
Comment 38 Milos Kleint 2008-11-06 14:43:08 UTC
reopening
Comment 39 Milos Kleint 2008-11-06 14:43:45 UTC
patrick, can we have this added in readme file or some kind of FAQ?
Comment 40 Patrick Keegan 2008-11-07 13:35:38 UTC
Ken will be adding a note on this to a wiki page with other Mac-specific info
Comment 41 dlipin 2008-11-08 09:32:22 UTC
*** Issue 152752 has been marked as a duplicate of this issue. ***
Comment 42 Kenneth Ganfield 2008-11-14 20:21:15 UTC
link to issue added to Netbeans 6.5 for Mac OS X wiki page
http://wiki.netbeans.org/NetBeans65MacOSX

Additional input/work needed to clarify the scenario and workaround, at which point we can add another wiki page or faq
which captures the details for users
Comment 43 jarome 2008-11-21 19:05:57 UTC
The file to edit is in
Applications/NetBeans/NetBeans 6.5.app/Contents/Resources/NetBeans/platform9/lib/nbexec

Not very easy to find....
Comment 44 jarome 2008-12-15 17:59:32 UTC
This may be related to another woe I have. The IDE (6.5) refuses to update.
I am in an infinite loop. I get the message that one update is found Auto Update Services [1.5.1 -> 1.5.2].
I accept the agreement and restart, and get it still. This has happened 3 times now.

I modified the startup script a la the instructions here to get this to work. Is there another way to install updates?
Comment 45 paintrick 2008-12-18 09:38:52 UTC
I have the same issue,

but changing the lines in the nbexec doesn't do the trick for me.

and launching the netbeans file directly from the package doesn't work either.

The following solution doesn't seem right to me, but people reported it worked, i'm not going to use it.:
Open Terminal.app, become root (sudo -s) and run the following commands.
(The '#' is the shell prompt showing that we're running as root)
# cp -p /System/Library/Frameworks/JavaVM.framework/Versions/1.5.0/Home/bin/java /tmp/java_original_binary
# lipo /System/Library/Frameworks/JavaVM.framework/Versions/1.5.0/Home/bin/java -remove x86_64 -output /tmp/java
# cat /tmp/java > /System/Library/Frameworks/JavaVM.framework/Versions/1.5.0/Home/bin/java 

Maybe you guys can try it...

Paintrick.
Comment 46 jarome 2008-12-21 13:59:12 UTC
Apple suggested I look at
jarmac:~ jar$ echo $DYLD_LIBRARY_PATH
/Users/jar/GraphiC2/GraphiC2dll/dist/Debug/GNU-MacOSX
jarmac:~ jar$ echo and $DYLD_FRAMEWORK_PATH
and
jarmac:~ jar$ 

These look wrong. What should they be?
Comment 47 jarome 2008-12-21 14:53:18 UTC
oops.
jarmac:~ jar$ echo $DYLD_FRAMEWORK_PATH

jarmac:~ jar$ 
Comment 48 pstehlik 2009-01-01 23:26:26 UTC
How I was able to overcome the issue:
---
cd /System/Library/Frameworks/JavaVM.framework/Versions/1.5.0/Home/bin
cp -p ./java /tmp/java_original_binary
lipo ./java -remove x86_64 -output /tmp/java

(then as root! -> careful)
cat /tmp/java > ./java
---

I just did that and netbeans starts up OK now but I have no idea if this has side effects!!! So keep the backup java
binary, just in case!

found at http://samcogan.com/blog/?p=23
Comment 49 jarome 2009-02-13 14:56:25 UTC
Yesterday's Java update fixed this for me!
Comment 50 garynunes 2009-02-24 00:21:03 UTC
Recall that this launching problem was similar to a compiler problem I also had with IDEA. Recently IDEA published a solution to their problem. It worked 
(IDEA's compiler now compiles without error) and, with the solution applied, both NetBeans 6.1 (where I originally encountered the problem) and NetBeans 
6.5 (the latest version) launch successfully. The full discussion of the problem and solution is at
    http://www.jetbrains.net/devnet/docs/DOC-1114;jsessionid=2199A70EBD48A57A843799CFD0394825

but, to synopsis, certain Rogue Amoeba (rogueamoeba.com) programs, Audio Hijack Pro in my case, install a background process called Instant Hijack 
which interfered with IDEA. The above referenced URL discusses how to disable the background process but I found that installing the latest version of 
Instant Hijack (2.2.1), via installing the latest Audio Hijack Pro, also fixed the problem (both for IDEA and NetBeans).

Regards,
    Gary Nunes
Comment 51 ujeezy 2009-04-03 19:38:34 UTC
Gary,

Thank you - Audio Hijack was exactly my problem, and disabling the bg process allowed me to launch Net Beans 6.5.1!
Comment 52 avenicio 2009-08-17 21:14:23 UTC
Had the same issue tried all solutions below without success. Updated Netbeans to 6.7.1 and latest Java update from
software update.

The issue, when launching netbeans from finder it was failing to write the .netbeans folder correctly in my user folder.
I created a new account and Netbeans launched correctly. After launching Netbeans in my new account I logged  back into
my original account and copied my .netbeans folder file (remember the file is hidden) from my old account and pasted it
into my original user account. Netbeans now launches correctly from the finder.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo