Bug 14605 - InvocationTargetException
InvocationTargetException
Status: CLOSED FIXED
Product: projects
Classification: Unclassified
Component: Generic Projects UI
3.x
PC Windows ME/2000
: P1 (vote)
: 3.x
Assigned To: issues@projects
issues@projects
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-21 05:20 UTC by aaronk
Modified: 2003-07-01 14:19 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
The IDE log file (75.89 KB, text/plain)
2001-08-21 05:22 UTC, aaronk
Details

Note You need to log in before you can comment on or make changes to this bug.
Description aaronk 2001-08-21 05:20:55 UTC
I have just installed Q-Build 200108170100.  I have set up a new project and 
mounted a CVS filesystem using the CVS built-in client.  When I try to create a 
second new project I get an InvocationTargetException.

Note: I have installed the mousewheel module (which loads, but does not work) 
and the XML support module (which I have not yet tested).

The following exception occurs every time I try to create a new project, or 
exit the IDE.  




Tue Aug 21 16:17:15 NZST 2001: java.lang.reflect.InvocationTargetException: null
java.lang.IllegalArgumentException
        at org.openide.util.SharedClassObject.findObject
(SharedClassObject.java:402)
        at org.netbeans.core.projects.XMLSettingsHandler.searchFolder
(XMLSettingsHandler.java:480)
        at org.netbeans.core.projects.XMLSettingsHandler.saveOptions
(XMLSettingsHandler.java:457)
        at org.netbeans.core.NbProjectOperation.storeLastProject
(NbProjectOperation.java:61)
        at org.netbeans.core.NbTopManager.exit(NbTopManager.java:673)
        at org.netbeans.core.actions.SystemExit.performAction
(SystemExit.java:45)
        at org.netbeans.core.windows.MainWindow$3.windowClosing
(MainWindow.java:148)
        at java.awt.AWTEventMulticaster.windowClosing
(AWTEventMulticaster.java:291)
        at java.awt.AWTEventMulticaster.windowClosing
(AWTEventMulticaster.java:290)
        at java.awt.Window.processWindowEvent(Window.java:800)
        at javax.swing.JFrame.processWindowEvent(JFrame.java:237)
        at org.netbeans.core.windows.MainWindow.processWindowEvent
(MainWindow.java:326)
        at java.awt.Window.processEvent(Window.java:776)
        at java.awt.Component.dispatchEventImpl(Component.java:2593)
[catch] at java.awt.Container.dispatchEventImpl(Container.java:1213)
        at java.awt.Window.dispatchEventImpl(Window.java:914)
        at java.awt.Component.dispatchEvent(Component.java:2497)
        at java.awt.EventQueue.dispatchEvent(EventQueue.java:339)
        at java.awt.EventDispatchThread.pumpOneEventForHierarchy
(EventDispatchThread.java:131)
        at java.awt.EventDispatchThread.pumpEventsForHierarchy
(EventDispatchThread.java:98)
        at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
        at java.awt.EventDispatchThread.run(EventDispatchThread.java:85)
 
Tue Aug 21 16:17:15 NZST 2001: java.lang.reflect.InvocationTargetException: null
java.lang.reflect.InvocationTargetException: java.lang.IllegalStateException: 
org.netbeans.xmlsupport.module.XMLSupportSettings@305236
        at org.openide.util.SharedClassObject$DataEntry.ensureValid
(SharedClassObject.java:668)
        at org.openide.util.SharedClassObject$DataEntry.getMap
(SharedClassObject.java:600)
        at org.openide.util.SharedClassObject.<init>(SharedClassObject.java:160)
        at org.openide.options.SystemOption.<init>(SystemOption.java:70)
        at org.netbeans.xmlsupport.module.XMLSupportSettings.<init>
(XMLSupportSettings.java:25)
        at java.lang.reflect.Constructor.newInstance(Native Method)
        at org.openide.util.SharedClassObject.createInstancePrivileged
(SharedClassObject.java:448)
        at org.openide.util.SharedClassObject$SetAccessibleAction.run
(SharedClassObject.java:742)
        at java.security.AccessController.doPrivileged(Native Method)
        at org.openide.util.SharedClassObject.findObject
(SharedClassObject.java:399)
        at org.netbeans.core.projects.XMLSettingsHandler.searchFolder
(XMLSettingsHandler.java:480)
        at org.netbeans.core.projects.XMLSettingsHandler.saveOptions
(XMLSettingsHandler.java:457)
        at org.netbeans.core.NbProjectOperation.storeLastProject
(NbProjectOperation.java:61)
        at org.netbeans.core.NbTopManager.exit(NbTopManager.java:673)
        at org.netbeans.core.actions.SystemExit.performAction
(SystemExit.java:45)
        at org.netbeans.core.windows.MainWindow$3.windowClosing
(MainWindow.java:148)
        at java.awt.AWTEventMulticaster.windowClosing
(AWTEventMulticaster.java:291)
        at java.awt.AWTEventMulticaster.windowClosing
(AWTEventMulticaster.java:290)
        at java.awt.Window.processWindowEvent(Window.java:800)
        at javax.swing.JFrame.processWindowEvent(JFrame.java:237)
        at org.netbeans.core.windows.MainWindow.processWindowEvent
(MainWindow.java:326)
        at java.awt.Window.processEvent(Window.java:776)
        at java.awt.Component.dispatchEventImpl(Component.java:2593)
[catch] at java.awt.Container.dispatchEventImpl(Container.java:1213)
        at java.awt.Window.dispatchEventImpl(Window.java:914)
        at java.awt.Component.dispatchEvent(Component.java:2497)
        at java.awt.EventQueue.dispatchEvent(EventQueue.java:339)
        at java.awt.EventDispatchThread.pumpOneEventForHierarchy
(EventDispatchThread.java:131)
        at java.awt.EventDispatchThread.pumpEventsForHierarchy
(EventDispatchThread.java:98)
        at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
        at java.awt.EventDispatchThread.run(EventDispatchThread.java:85)
Comment 1 aaronk 2001-08-21 05:22:04 UTC
Created attachment 2235 [details]
The IDE log file
Comment 2 aaronk 2001-08-21 05:27:11 UTC
Correction: This now happens every time I do anything.  The whole 
thing has gone pear-shaped.  Back to 3.2.1rc2!
Comment 3 Vitezslav Stejskal 2001-08-21 09:32:43 UTC
I suspect there is a compatibility problem, which we definitelly must 
solve, but it will need some time for investiogation. I am going to 
try to install and use 3.2 modules in 3.3 IDE. If it's possible for 
you avoid using 3.2 modules in 3.3 builds in the meantime.
Comment 4 aaronk 2001-08-22 22:43:50 UTC
Ok, a bit more info:

I'm not sure if I did it right, (I would guess not,) but I deleted 
the jar file and xml file for the mousewheel module from my netbeans 
dir - didn't make a lick of difference.

Then I deleted and re-installed the Q-Build and refrained from 
installing the 3.2 modules and hey, what do you know!  Everything 
seems to work!
Comment 5 Vitezslav Stejskal 2001-08-23 12:03:12 UTC
This issue is similar to 14468 (comparing stack traces), it was caused 
by changes in settings subsystem which weren't 100% backward 
compatible. I changed settings handling to work properly with 3.2 
modules, which have their settings written incorrectly, but fine for 
3.2 IDE.

Not sure what's the relation to mousewheel support module you have 
mentioned. Please, reopen the bug or file another one in case of 
having similar problems with another 3.2 module.
Comment 6 Jaromir Uhrik 2001-10-10 16:29:21 UTC
I tried to reproduce in dev33 build #200110100100 but was not 
successful. Marking as VERIFIED.
Comment 7 Quality Engineering 2003-07-01 14:19:08 UTC
Resolved for 3.4.x or earlier, no new info since then -> closing.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo