Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 145929 - [65cat] string fields squished in database explorer
[65cat] string fields squished in database explorer
Status: VERIFIED FIXED
Product: db
Classification: Unclassified
Component: Show Data
6.x
PC Linux
: P3 (vote)
: 6.x
Assigned To: Shansi 11
issues@db
:
Depends on:
Blocks: 152437
  Show dependency treegraph
 
Reported: 2008-09-02 14:47 UTC by gholmer
Modified: 2009-04-08 14:06 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
screenshot (23.84 KB, image/png)
2008-09-02 14:48 UTC, gholmer
Details
DDL to create database (19.90 KB, text/plain)
2008-09-04 17:22 UTC, gholmer
Details
Postgres dump of database (1.02 MB, application/octet-stream)
2008-09-04 17:23 UTC, gholmer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description gholmer 2008-09-02 14:47:04 UTC
[ BUILD # : 200809020201 ]
[ JDK VERSION : 1.6.0_06 ]

When doing a query, string fields are displayed so narrow they are
unreadable. User has to go to each one in turn and expand the column
to see anything (see attached screenshot).
Comment 1 gholmer 2008-09-02 14:48:42 UTC
Created attachment 68875 [details]
screenshot
Comment 2 _ ahimanikya 2008-09-04 10:27:27 UTC
Which database are you using, also can send me the create table script as well as some data, so that I can try that out
locally?
Comment 3 gholmer 2008-09-04 17:22:26 UTC
Created attachment 69079 [details]
DDL to create database
Comment 4 gholmer 2008-09-04 17:23:58 UTC
Created attachment 69080 [details]
Postgres dump of database
Comment 5 gholmer 2008-09-04 17:26:17 UTC
1) psql template1
2) create database phoenix owner weyco;
3) \i phoenix.i
4) (from command line) pg_restore -d phoenix phoenix-145929.tar
Comment 6 Andrei Badea 2008-09-08 11:20:13 UTC
I would like to kindly ask you to reconsider the decision not to fix this issue for 6.5:

- it was filed by a NetCAT participant. These are volunteers which dedicate a lot of their time to improve NetBeans, and
their feedback should not be taken lightly.

- the reporter has given a lot of detail trying to help you reproduce the issue.

If you have reproduced the problem using the reporter's script, but determined that the issue is hard to fix, it would
be nice to document your findings here, so that the community knows that he issue is being addressed property, but it is
not fixable for 6.5. Thanks.
Comment 7 _ ahimanikya 2008-09-08 11:29:13 UTC
OK, I will give it a try.
Comment 8 Roman Mostyka 2008-11-19 14:20:14 UTC
jawed, can You take a look at this issue? This issue is P3, but it is reported by NetCAT participant and therefore this
issue is going to be included into NetBeans 6.5 Patch 1.
Please fix it till 27 November (this is code freeze date for Patch 1) or update this issue with justification why the
fix isn't possible till this date.
Thanks.
Comment 9 pgebauer 2008-11-24 09:31:07 UTC
The issue didn't pass the nomination process by nomination cut-off date. It has been marked as 65fixes2-candidate.
Comment 10 _ ahimanikya 2008-11-25 08:54:48 UTC
*** Issue 150275 has been marked as a duplicate of this issue. ***
Comment 11 Shansi 11 2008-12-04 11:18:10 UTC
Needs Verification
http://hg.netbeans.org/main/rev/a17b8f8cf78c
Comment 12 Roman Mostyka 2008-12-04 16:17:15 UTC
Verified with build 081204.
Comment 13 pgebauer 2008-12-16 14:00:27 UTC
sivashankari, have you provided the correct changeset?  There is following commit message "Issue # 154170 Error message should appear instead of 
Information" in the changeset a17b8f8cf78c which you provided. But this issue has #145929 and the subject is "[65cat] string fields squished in database 
explorer". Unfortunately, I haven't found any commit message containing "145929" in the main repository.

Could you please confirm that the changeset 17b8f8cf78c is the correct one?

Comment 14 Roman Mostyka 2008-12-16 17:13:45 UTC
Actually I tried to reproduce this issue with my steps, which are described in duplicate issue #150275 and wasn't able
to reproduce.
Probably we should ask also reporter if this fix is OK. gholmer, can You verify that this issue was really fixed?
But anyway, sivashankari, can you provide the correct changeset? Or we should test this issue one more time?
Comment 15 Shansi 11 2008-12-17 06:42:40 UTC
It is the correct changeset which includes several other fixes apart from the CR mentioned.
Comment 16 gholmer 2008-12-17 14:35:29 UTC
Can I just grab a nightly to test this (http://bits.netbeans.org/download/trunk/nightly/latest/)?
Comment 17 pgebauer 2008-12-17 14:52:17 UTC
> changeset which includes several other fixes apart from the CR mentioned.

In this case all several issues except duplicates should be marked as patch candidates.
Comment 18 Roman Mostyka 2008-12-17 16:15:05 UTC
gholmer, yes You can.
Comment 19 gholmer 2008-12-17 22:30:23 UTC
Yes, that fixes it. The fields are no longer squished, thanks very much.
Comment 20 pgebauer 2009-01-12 11:50:06 UTC
Please, provide a changeset with changes related to this issue only. As was mentioned, the provided changeset a17b8f8cf78c includes several other fixes 
apart from the CR mentioned so it cannot be integrated into the high resistance release65_fixes branch.

Comment 21 Roman Mostyka 2009-01-12 12:24:00 UTC
Sivashankari, are you able to provide the changeset with changes related to this issue only? We really need it. But it
seems to me that this issue should be excluded from Patch 2 since we can't port available changeset.
Petr, by the way, can we port this changeset if I mark the rest of the issues, which were fixed with this changeset, as
candidates for Patch 2? Or it will be redundant work?
If we can, then Sivashankari, please provide all issues, which were fixed with the changeset a17b8f8cf78c, tomorrow COB.
Comment 22 pgebauer 2009-01-12 12:59:02 UTC
I prefer the option with the exact changeset but marking issues, which were fixed by mentioned changeset could work as well.  OTOH added issues could 
lead to huge number of additional changes. In that case, it isn't acceptable.
Comment 23 pgebauer 2009-01-15 10:14:17 UTC
No solution for the release65_fixes branch was provided by 65patch2 code freeze. The issues has been moved to 65patch3.
Comment 24 gholmer 2009-01-15 13:59:36 UTC
This is disappointing.  It is time-consuming to have to resize every column every time this happens in order to view the
data.
Comment 25 Roman Mostyka 2009-01-15 14:31:05 UTC
gholmer, don't worry. We just don't have enough time to port necessary fix, but we definitely will work on this issue
for Patch 3.
Comment 26 pgebauer 2009-04-08 14:06:56 UTC
The status whiteboard "65fixes4-candidate" has been removed.
At this time our proactive patches for the NetBeans 6.5.x IDE have concluded.

If you own a Sun service plan contract for NetBeans, you may wish to contact
Sun Service http://www.sun.com/contact/support.jsp to request a fix via the
product defect escalation process.

For more information on purchasing a Sun service plan contract for NetBeans,
refer to the service plan item "Sun Software Service Plans (S3P) for Developers"
in the Sun Service table found on our NetBeans Support Resources
page http://www.netbeans.org/kb/support.html


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo