Bug 145764 - [65cat]cvc-complex-type.2.4.b: The content of element 'file' is not complete. One of '{"http://www.netbeans.org/ns/editor-bookmarks/1":line}' is expected.
[65cat]cvc-complex-type.2.4.b: The content of element 'file' is not complete....
Status: RESOLVED DUPLICATE of bug 145629
Product: ide
Classification: Unclassified
Component: Code
6.x
All Windows XP
: P3 (vote)
: TBD
Assigned To: issues@ide
issues@ide
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-01 07:59 UTC by alcmontejo
Modified: 2008-09-01 09:02 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
message log (132.68 KB, text/plain)
2008-09-01 08:02 UTC, alcmontejo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description alcmontejo 2008-09-01 07:59:49 UTC
this in on build 200808311401.

this occurs when I closed the IDE. this happens randomly..


SEVERE: cvc-complex-type.2.4.b: The content of element 'file' is not complete. One of
'{"http://www.netbeans.org/ns/editor-bookmarks/1":line}' is expected.
Saving nbproject/private/private.xml in C:\NetBeansProjects\WebApplication8
Saving nbproject/private/private.xml in C:\NetBeansProjects\WebApplication8
Caused: org.xml.sax.SAXParseException: cvc-complex-type.2.4.b: The content of element 'file' is not complete. One of
'{"http://www.netbeans.org/ns/editor-bookmarks/1":line}' is expected.
	at com.sun.org.apache.xerces.internal.util.ErrorHandlerWrapper.createSAXParseException(ErrorHandlerWrapper.java:195)
	at com.sun.org.apache.xerces.internal.util.ErrorHandlerWrapper.error(ErrorHandlerWrapper.java:131)
	at com.sun.org.apache.xerces.internal.impl.XMLErrorReporter.reportError(XMLErrorReporter.java:384)
	at com.sun.org.apache.xerces.internal.impl.XMLErrorReporter.reportError(XMLErrorReporter.java:318)
	at com.sun.org.apache.xerces.internal.impl.xs.XMLSchemaValidator$XSIErrorReporter.reportError(XMLSchemaValidator.java:410)
	at com.sun.org.apache.xerces.internal.impl.xs.XMLSchemaValidator.reportSchemaError(XMLSchemaValidator.java:3165)
	at
com.sun.org.apache.xerces.internal.impl.xs.XMLSchemaValidator.elementLocallyValidComplexType(XMLSchemaValidator.java:3129)
	at com.sun.org.apache.xerces.internal.impl.xs.XMLSchemaValidator.elementLocallyValidType(XMLSchemaValidator.java:3076)
	at com.sun.org.apache.xerces.internal.impl.xs.XMLSchemaValidator.processElementContent(XMLSchemaValidator.java:2978)
	at com.sun.org.apache.xerces.internal.impl.xs.XMLSchemaValidator.handleEndElement(XMLSchemaValidator.java:2121)
	at com.sun.org.apache.xerces.internal.impl.xs.XMLSchemaValidator.endElement(XMLSchemaValidator.java:791)
	at com.sun.org.apache.xerces.internal.jaxp.validation.DOMValidatorHelper.finishNode(DOMValidatorHelper.java:338)
	at com.sun.org.apache.xerces.internal.jaxp.validation.DOMValidatorHelper.validate(DOMValidatorHelper.java:243)
	at com.sun.org.apache.xerces.internal.jaxp.validation.DOMValidatorHelper.validate(DOMValidatorHelper.java:186)
	at com.sun.org.apache.xerces.internal.jaxp.validation.ValidatorImpl.validate(ValidatorImpl.java:100)
	at javax.xml.validation.Validator.validate(Validator.java:127)
	at org.openide.xml.XMLUtil.validate(XMLUtil.java:500)
	at org.netbeans.modules.project.ant.ProjectXMLCatalogReader.validate(ProjectXMLCatalogReader.java:152)
	at org.netbeans.spi.project.support.ant.AntProjectHelper.saveXml(AntProjectHelper.java:319)
Caused: java.io.IOException: cvc-complex-type.2.4.b: The content of element 'file' is not complete. One of
'{"http://www.netbeans.org/ns/editor-bookmarks/1":line}' is expected.
	at org.netbeans.spi.project.support.ant.AntProjectHelper.saveXml(AntProjectHelper.java:322)
	at org.netbeans.spi.project.support.ant.AntProjectHelper.save(AntProjectHelper.java:584)
	at org.netbeans.spi.project.support.ant.AntProjectHelper.access$100(AntProjectHelper.java:100)
	at org.netbeans.spi.project.support.ant.AntProjectHelper$1.save(AntProjectHelper.java:138)
	at org.netbeans.modules.project.ant.AntBasedProjectFactorySingleton.saveProject(AntBasedProjectFactorySingleton.java:243)
	at org.netbeans.api.project.ProjectManager$8.run(ProjectManager.java:642)
	at org.netbeans.api.project.ProjectManager$8.run(ProjectManager.java:636)
	at org.openide.util.Mutex.writeAccess(Mutex.java:433)
	at org.openide.util.Mutex$1R.run(Mutex.java:1305)
	at org.netbeans.api.project.ProjectManager$2$1.run(ProjectManager.java:120)
	at org.openide.filesystems.EventControl.runAtomicAction(EventControl.java:120)
	at org.openide.filesystems.FileSystem.runAtomicAction(FileSystem.java:499)
	at org.openide.filesystems.FileUtil.runAtomicAction(FileUtil.java:216)
	at org.netbeans.api.project.ProjectManager$2.execute(ProjectManager.java:118)
	at org.openide.util.Mutex.doWrapperAccess(Mutex.java:1320)
	at org.openide.util.Mutex.writeAccess(Mutex.java:426)
	at org.netbeans.api.project.ProjectManager.saveAllProjects(ProjectManager.java:635)
[catch] at org.netbeans.modules.project.ui.ProjectUiModule.close(ProjectUiModule.java:63)
	at org.netbeans.core.startup.NbInstaller.close(NbInstaller.java:678)
	at org.netbeans.ModuleManager.shutDown(ModuleManager.java:1556)
	at org.netbeans.core.startup.ModuleSystem.shutDown(ModuleSystem.java:291)
	at org.netbeans.core.NbTopManager.doExit(NbTopManager.java:389)
	at org.netbeans.core.NbTopManager.access$200(NbTopManager.java:91)
	at org.netbeans.core.NbTopManager$1.run(NbTopManager.java:349)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:597)
	at org.netbeans.core.TimableEventQueue.dispatchEvent(TimableEventQueue.java:104)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:273)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:183)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:173)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:168)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:160)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:121)
ALL [null]: Saving nbproject/private/private.xml in C:\NetBeansProjects\WebApplication8
INFO [org.netbeans.core.NbProxySelector]: Incomplete SOCKS Server [/] found in ProxySelector[Type: 2] for uri
socket://localhost:8081. 
INFO [org.netbeans.core.NbProxySelector]: Incomplete SOCKS Server [/] found in ProxySelector[Type: 2] for uri
socket://localhost:8081. 
INFO [org.netbeans.core.NbProxySelector]: Incomplete SOCKS Server [/] found in ProxySelector[Type: 2] for uri
socket://localhost:8081. 
INFO [org.netbeans.core.NbProxySelector]: Incomplete SOCKS Server [/] found in ProxySelector[Type: 2] for uri
socket://localhost:8081. 
INFO [org.netbeans.core.NbProxySelector]: Incomplete SOCKS Server [/] found in ProxySelector[Type: 2] for uri
socket://localhost:8081. 
INFO [org.netbeans.core.NbProxySelector]: Incomplete SOCKS Server [/] found in ProxySelector[Type: 2] for uri
socket://localhost:8081. 
INFO [org.netbeans.core.NbProxySelector]: Incomplete SOCKS Server [/] found in ProxySelector[Type: 2] for uri
socket://localhost:8081. 
INFO [org.netbeans.core.NbProxySelector]: Incomplete SOCKS Server [/] found in ProxySelector[Type: 2] for uri
socket://localhost:8081. 
INFO [org.netbeans.core.NbProxySelector]: Incomplete SOCKS Server [/] found in ProxySelector[Type: 2] for uri
socket://localhost:8081. 
INFO [org.netbeans.core.NbProxySelector]: Incomplete SOCKS Server [/] found in ProxySelector[Type: 2] for uri
socket://localhost:8081. 
INFO [org.netbeans.core.NbProxySelector]: Incomplete SOCKS Server [/] found in ProxySelector[Type: 2] for uri
socket://localhost:8081. 
INFO [org.netbeans.core.NbProxySelector]: Incomplete SOCKS Server [/] found in ProxySelector[Type: 2] for uri
socket://localhost:8081. 
INFO [org.netbeans.core.NbProxySelector]: Incomplete SOCKS Server [/] found in ProxySelector[Type: 2] for uri
socket://localhost:8081. 
INFO [org.netbeans.core.NbProxySelector]: Incomplete SOCKS Server [/] found in ProxySelector[Type: 2] for uri
socket://localhost:8081. 
INFO [org.netbeans.core.NbProxySelector]: Incomplete SOCKS Server [/] found in ProxySelector[Type: 2] for uri
socket://localhost:8081. 
INFO [org.netbeans.core.NbProxySelector]: Incomplete SOCKS Server [/] found in ProxySelector[Type: 2] for uri
socket://localhost:8081. 
INFO [org.netbeans.core.NbProxySelector]: Incomplete SOCKS Server [/] found in ProxySelector[Type: 2] for uri
socket://localhost:8081. 
INFO [org.netbeans.core.NbProxySelector]: Incomplete SOCKS Server [/] found in ProxySelector[Type: 2] for uri
socket://localhost:8081. 
INFO [org.netbeans.core.NbProxySelector]: Incomplete SOCKS Server [/] found in ProxySelector[Type: 2] for uri
socket://localhost:8081. 
INFO [org.netbeans.core.NbProxySelector]: Incomplete SOCKS Server [/] found in ProxySelector[Type: 2] for uri
socket://localhost:8081. 
INFO [org.netbeans.core.NbProxySelector]: Incomplete SOCKS Server [/] found in ProxySelector[Type: 2] for uri
socket://localhost:8081. 
INFO [org.netbeans.core.NbProxySelector]: Incomplete SOCKS Server [/] found in ProxySelector[Type: 2] for uri
socket://localhost:8081.
Comment 1 alcmontejo 2008-09-01 08:02:01 UTC
Created attachment 68769 [details]
message log
Comment 2 Peter Pis 2008-09-01 09:02:13 UTC

*** This issue has been marked as a duplicate of 145629 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo