Bug 145666 - [65cat] Source root's non-class files not included on Auto deploy
[65cat] Source root's non-class files not included on Auto deploy
Status: RESOLVED INCOMPLETE
Product: serverplugins
Classification: Unclassified
Component: Infrastructure
6.x
All Windows XP
: P2 with 5 votes (vote)
: 6.x
Assigned To: Petr Hejl
issues@serverplugins
:
: 153773 171193 (view as bug list)
Depends on: 167170
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-30 05:10 UTC by alcmontejo
Modified: 2009-12-04 23:33 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description alcmontejo 2008-08-30 05:10:47 UTC
hi!

I notice that properties type files is not included on auto deploy feature. Changes on this type of file
is not then deploy upon saving.

Thanks, 
Allen Montejo
Comment 1 _ jyothivasa 2008-11-21 01:10:00 UTC
Not planned for 7.0
Comment 2 alcmontejo 2008-11-21 01:17:19 UTC
i think this should be fixed or included as soon as new nb release. When enabling Deploy on Save 
users expecting to have automatic and incrementally deploy any changing made by the web project.

Comment 3 alcmontejo 2008-11-21 01:17:32 UTC
i think this should be fixed or included as soon as new nb release. When enabling Deploy on Save 
users expecting to have automatic and incrementally deploy any changing made on the web project.

Comment 4 Petr Jiricka 2009-06-07 21:45:38 UTC
Still reproducible with NB 6.7 RC2 and GlassFish v3 Prelude. After changes to the bundle files, these are not
auto-copied to the build directory. This is also true for Java projects, not only Web projects - reassigning to Java.


Product Version: NetBeans IDE 6.7 RC2 (Build 200906042131)
Java: 1.6.0_07; Java HotSpot(TM) 64-Bit Server VM 1.6.0_07-b06-57
System: Mac OS X version 10.5.7 running on x86_64; MacRoman; en_US (nb)
Comment 5 Petr Jiricka 2009-06-16 12:52:00 UTC
Sorry, Hanzi, you just changed the target milestone to 6.8, but this isssue is NOT evaluated. See also:
http://wiki.netbeans.org/IssueLifeCycle#section-IssueLifeCycle-EvaluatingIssues
I see NO comment from the evaluator, and it's not clear whether you tried to reproduce, so this is not evaluated. Please
evaluate properly.

Also, this is a P2 ("Critical usability problem") per the priority guidelines:
http://wiki.netbeans.org/BugPriorityGuidelines. It would be great to see this problem fixed for NB 6.7 patch 1. Thanks.
Comment 6 Jan Jancura 2009-06-16 13:57:07 UTC
Not reproducible with Java project => reassigning back to Web projects.
Sorry, Petre, but if you are able to reproduce it on Java Application project type, write some steps how to reproduce it
here, please.
See http://wiki.netbeans.org/IssuezillaRules.

I have tried to reproduce this issue on:
Product Version: NetBeans IDE Dev (Build 090610)
Java: 1.6.0_07; Java HotSpot(TM) Client VM 10.0-b23
System: Linux version 2.6.24-24-generic running on i386; UTF-8; en_US (nb)

Java Application project, and it works!
Comment 7 Petr Jiricka 2009-06-17 09:37:18 UTC
Not a stopper for NB 6.7, TM -> 6.8.
Comment 8 Petr Hejl 2009-07-07 12:32:08 UTC
*** Issue 153773 has been marked as a duplicate of this issue. ***
Comment 9 jskovzoftcorpdk 2009-07-17 20:09:14 UTC
Not commented on this issue (but on some of the duplicates):

This problem prevents development of Wicket applications, which make use of .html files placed next to the .java files.
Automatic deployment only includes changes to the classes, not the associated web files.

If I do a manual deployment on the project, it does redeploy all files. So that is usable as a workaround...
Comment 10 Petr Hejl 2009-09-01 10:14:28 UTC
*** Issue 171193 has been marked as a duplicate of this issue. ***
Comment 11 Petr Hejl 2009-09-25 09:35:28 UTC
Fixed by fix for issue 167170.
Comment 12 Geertjan Wielenga 2009-10-29 07:04:49 UTC
I tried the following scenarios in 6.8 Beta, both of which failed:
1. I have a CSS file in my 'src' folder. I change the CSS file, but the application is not redeployed.
2. Same as the above, but with an HTML file. However, when the HTML file is in the 'web' folder, redeploy does occur
correctly, on save.

So, I am reopening this issue.
Comment 13 bht 2009-10-29 09:13:19 UTC
Had you saved the changed files when they were not deployed as expected? The feature is "deploy on save" not "deploy on
change".
Comment 14 Petr Hejl 2009-10-29 11:11:56 UTC
Please describe the steps to reproduce.

Here is what I've tried:
1) created web project
2) created package org.my.resources in src folder
3) created newcss.css in this package
4) run app
5) changed newcss.css content and saved it - app was redeployed (verified in log and content of build/web).
Comment 15 bht 2009-12-04 23:30:54 UTC
Hi Geertjan,

There is another issue that has the same behavior as you describe:

"Deploy on Save does not work"
https://netbeans.org/bugzilla/show_bug.cgi?id=178050

So when yo have the time you could download the testcase from it and assess it.

That other issue is limited to debugging mode. Please start fresh in debugging mode only. If you run and debug at the same time then you don't get that error.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo