Bug 14565 - Deadlock when opening project
Deadlock when opening project
Status: CLOSED FIXED
Product: projects
Classification: Unclassified
Component: Generic Infrastructure
3.x
PC Linux
: P1 (vote)
: 3.x
Assigned To: Jaroslav Tulach
issues@projects
:
: 14586 14607 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-19 13:06 UTC by Jesse Glick
Modified: 2003-07-01 14:17 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Deadlock thread dump (4.72 KB, text/plain)
2001-08-19 13:07 UTC, Jesse Glick
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2001-08-19 13:06:54 UTC
[dev aug 19] I get a deadlock during the first user start (attached). After
commenting out the line from PSupport.java:

org.netbeans.core.AutomountSupport.initialize().waitFinished();

(which is an illegal use of core anyway BTW) the deadlock disappears (presumably
something else is broken). This line was added by you in rev. 1.81 of
PSupport.java on Aug 16 to fix #14493.
Comment 1 Jesse Glick 2001-08-19 13:07:47 UTC
Created attachment 2229 [details]
Deadlock thread dump
Comment 2 Jan Pokorsky 2001-08-20 09:48:37 UTC
Why illegal? Module projects depends on core now. It was decided some 
time ago. Code has to wait for updated Registery after adding 
project layer to be able to deserialize winsys correctly (mainly 
opened files in editor).

Is there a way how to reproduce the deadlock? Jarda promised to 
improve initialization of core.AutomountSupport.
Comment 3 Vitezslav Stejskal 2001-08-21 09:18:12 UTC
*** Issue 14586 has been marked as a duplicate of this issue. ***
Comment 4 Vitezslav Stejskal 2001-08-21 09:36:06 UTC
*** Issue 14607 has been marked as a duplicate of this issue. ***
Comment 5 Jan Pokorsky 2001-08-21 10:19:05 UTC
Jarda, can you take a look at it? According to code in 
AutomountSupport.initialize returned task should be always started 
or scheduled but it seems that not. At least on some unix platforms.
Comment 6 Jaroslav Tulach 2001-08-21 15:12:29 UTC
Rewritten. Created one task that delegates to both the folder instance
& the store task. 
Comment 7 Milan Kubec 2002-01-18 08:21:17 UTC
Verified.
Comment 8 Quality Engineering 2003-07-01 14:17:42 UTC
Resolved for 3.4.x or earlier, no new info since then -> closing.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo