Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 145569 - OK disabled forever
OK disabled forever
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Options&Settings
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Jiri Skrivanek
issues@platform
65fixes1-verified
:
: 156363 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-29 13:17 UTC by Lukas Hasik
Modified: 2009-02-19 22:53 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lukas Hasik 2008-08-29 13:17:18 UTC
Product Version: NetBeans IDE Dev (Build 200808281401)
Java: 1.5.0_15; Java HotSpot(TM) 64-Bit Server VM 1.5.0_15-b04
System: Linux version 2.6.24-19-generic running on amd64; UTF-8; en_US (nb)
Userdir: /home/lukas/.netbeans/dev

-open Tools > Options
-add new file extension on Miscellaneous > Files tab, close the new extension dialog with OK
-press the New... button again -> the OK on the Options is disabled for ever. 
->restart fixes it
Comment 1 Jiri Skrivanek 2008-09-29 08:55:37 UTC
I cannot reproduce it.
Comment 2 Lukas Hasik 2008-10-22 15:14:52 UTC
the trick to reproduce is to open Miscellaneous > Groovy before these steps

########## OptionsPanelController=org.netbeans.modules.groovy.support.options.SupportOptionsPanelController@1772e1  
org.netbeans.modules.groovy.support.options.SupportOptionsPanelController
########## OptionsPanelController.isValid=false
Comment 3 Jiri Skrivanek 2008-10-23 10:32:15 UTC
Fixed. Must call controller.isValid only if something changed. Some sub panels (Groovy in this case) can be invalid
right after initialization.
Comment 4 Quality Engineering 2008-10-24 04:16:34 UTC
Integrated into 'main-golden', will be available in build *200810240201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/69d3b7765828
User: Jiri Skrivanek <jskrivanek@netbeans.org>
Log: #145569 - Call controller.isValid only if something changed. Some sub panels can be invalid right after initialization.
Comment 5 Lukas Hasik 2008-11-06 15:06:54 UTC
marking as 65fixes1-candidate because when user fell into this situation it isn't obvious what happened and how s/he can
recover. Sometimes even restart didn't help.
Comment 6 Lukas Hasik 2008-11-20 15:31:50 UTC
verified (081118)
Comment 7 pslechta 2008-11-21 11:57:59 UTC
The fix was ported into release65_fixes repository.

http://hg.netbeans.org/release65_fixes/rev/04685af2cce1
Comment 8 Jiri Skrivanek 2009-01-08 07:32:00 UTC
*** Issue 156363 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo