Bug 145453 - I18N - Several dialogs from BeanInfo properties editor don't resize to show their title
I18N - Several dialogs from BeanInfo properties editor don't resize to show t...
Status: RESOLVED DUPLICATE of bug 146343
Product: java
Classification: Unclassified
Component: Beans
6.x
All All
: P2 (vote)
: TBD
Assigned To: issues@java
issues@java
: I18N
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-28 16:16 UTC by kaa
Modified: 2008-09-12 14:54 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
image (93.94 KB, image/jpeg)
2008-08-28 16:17 UTC, kaa
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kaa 2008-08-28 16:16:22 UTC
Product Version: NetBeans IDE Dev (Build 200808240201)
Java: 1.6.0_06; Java HotSpot(TM) Client VM 10.0-b22
I'm running in Japanese locale, using a pseudo localized Netbeans with font size 16 option. 

1. Create a new Java Beans Component
2. Select the component and create BeanInfo using pop-up menu
3. Switch to the designer of BeanInfo editor
4. Make properties dlg visible and select the bean
5. Press ellipsis button for 'Display Name Code' property.

New dialog appears with null value. It doesn't resize to show its title properly.
The same behavior is for 'Short Description Code' and Customizer Name Code' properties.

Assumption is that user does not need to manually resize most windows or dialogs to see all of the UI objects and
information in them. I'm running in pseudo localized locale in which each message/label is sometimes longer than in
English. To account for that in some locales, translations from English (and some other euro languages) could be shown
with longer strings.

Also I'm running at font size 16, which is viewed as a valid font size that might be used. Resizing issues are not just
related to i18n; they might show to user in English locale if they run at larger font size.

Often, these issues happen because the length of some label or message or size of entire window is hardcoded vs using
layout managers or other techniques or api to have the windows or the objects in them, dynamically resize.
Comment 1 kaa 2008-08-28 16:17:15 UTC
Created attachment 68544 [details]
image
Comment 2 Jan Pokorsky 2008-08-28 17:07:43 UTC
The window is opened by openide/explorer (property sheet implementation) for Node.Property of String type. The beans has
no control over the window and its title. I am not sure if it is bug of PropertyDialogManager or NbPresenter.
Reassigning to openide/explorer for evaluation.
Comment 3 Jiri Rechtacek 2008-09-11 19:30:55 UTC
It belongs to beans/src/org/netbeans/modules/beans/beaninfo/CustomCodeEditor.java
Comment 4 Stanislav Aubrecht 2008-09-12 14:54:12 UTC

*** This issue has been marked as a duplicate of 146343 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo