Bug 145376 - [65cat] IllegalArgumentException: A node selection cannot contain nodes (08 28, 08 11:44:53 AM) not underneath the root (Version).
[65cat] IllegalArgumentException: A node selection cannot contain nodes (08 2...
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Nodes
6.x
All All
: P2 (vote)
: 6.x
Assigned To: t_h
issues@platform
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT fix-in-65
: API_REVIEW_FAST, THREAD
: 145087 152864 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-28 05:15 UTC by alcmontejo
Modified: 2008-12-22 14:36 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (3.17 KB, text/plain)
2008-08-28 05:15 UTC, alcmontejo
Details
API change patch. (11.82 KB, text/plain)
2008-09-16 09:24 UTC, t_h
Details

Note You need to log in before you can comment on or make changes to this bug.
Description alcmontejo 2008-08-28 05:15:26 UTC
Build: NetBeans IDE Dev (Build 200808261401)
VM: Java HotSpot(TM) Client VM, 1.6.0_02-b06, Java(TM) SE Runtime Environment, 1.6.0_02-b06
OS: Windows XP, 5.1, x86

User Comments: 


Stacktrace: 
java.lang.IllegalArgumentException: A node selection cannot contain nodes (08 28, 08 11:44:53 AM) not underneath the root (Version).
Comment 1 alcmontejo 2008-08-28 05:15:34 UTC
Created attachment 68502 [details]
stacktrace
Comment 2 alcmontejo 2008-08-28 05:18:48 UTC
hi! got this when i try to expand node on local history
Comment 3 Marian Mirilovic 2008-08-28 13:43:04 UTC
85 duplicates so far ...
Comment 4 Stanislav Aubrecht 2008-09-05 16:29:37 UTC
exceptions reporter shows 280 duplicates -> P2

this problem happens all over the ide, maybe there's something broken in Nodes implementation or ExplorerManager,
reassigning for evaluation
Comment 5 t_h 2008-09-15 16:39:04 UTC
*** Issue 145087 has been marked as a duplicate of this issue. ***
Comment 6 t_h 2008-09-16 09:24:15 UTC
Created attachment 69926 [details]
API change patch.
Comment 7 Jesse Glick 2008-09-16 11:59:25 UTC
Since we have no coherent threading model for Nodes, I guess this change makes sense.
Comment 8 t_h 2008-09-22 13:53:34 UTC
c6f3b6a7a339
Comment 9 Quality Engineering 2008-09-23 17:57:13 UTC
Integrated into 'main-golden', will be available in build *200809231435* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/c6f3b6a7a339
User: Tomas Holy <t_h@netbeans.org>
Log: #145376: IllegalArgumentException: A node selection cannot contain nodes not underneath the root
Comment 10 t_h 2008-11-10 12:07:41 UTC
*** Issue 152864 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo