Bug 145207 - [65cat] Quick search wastes space in toolbar
[65cat] Quick search wastes space in toolbar
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Quick Search
6.x
PC Windows XP
: P3 with 1 vote (vote)
: 6.x
Assigned To: Stanislav Aubrecht
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-26 20:06 UTC by ulfzibis
Modified: 2009-11-01 10:55 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Double height toolbar (83.75 KB, image/jpeg)
2008-08-26 20:07 UTC, ulfzibis
Details
Quicksearch located bad (25.05 KB, image/jpeg)
2009-02-28 22:50 UTC, ulfzibis
Details
Quicksearch located in additional line (45.45 KB, image/png)
2009-05-20 10:17 UTC, ulfzibis
Details
toolbars export (2.07 KB, application/x-compressed)
2009-10-23 18:36 UTC, ulfzibis
Details
.netbeans\dev091023\config\... (3.67 KB, application/x-compressed)
2009-10-26 16:12 UTC, ulfzibis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ulfzibis 2008-08-26 20:06:44 UTC
[ BUILD # : Beta ]
[ JDK VERSION : 1.6.0_07 ]

See attachment.

If debugger is running, Quick search needs it's own line, and isn't
movable.
Comment 1 ulfzibis 2008-08-26 20:07:56 UTC
Created attachment 68370 [details]
Double height toolbar
Comment 2 Peter Pis 2008-08-26 21:22:41 UTC
Reassigning to "core".
Comment 3 Stanislav Aubrecht 2008-11-28 11:32:02 UTC
reporter, pls review the new toolbar implementation and reopen if you're still not happy with quicksearch behavior

4f828389f2be
Comment 4 ulfzibis 2008-12-05 12:01:07 UTC
Hi,

I'm still waiting to see changeset 4f828389f2be published as main-golden for download.
All I can say is, that I still see this problem in 6.5 FCS on JDK 1.6.0_10.
Comment 5 David Simonek 2008-12-05 13:02:16 UTC
huh?
Comment 6 Stanislav Aubrecht 2008-12-05 13:09:29 UTC
toolbars rewrite happened AFTER nb6.5, get the latest daily build pls
Comment 7 ulfzibis 2008-12-16 10:39:23 UTC
I have tried to check this, but had issue:
Issue 155535
Comment 8 Stanislav Aubrecht 2008-12-16 10:51:40 UTC
how is Issue 155535 related to toolbar layout??
Comment 9 ulfzibis 2008-12-16 11:11:53 UTC
... oops, there is new behaviour in 7.0:
If I had error badges in 6.5, and tried to Run/Debug anyway, then I was used to see some message like "Some classes have
errors, run anyway ?" which end up in nothing, if the "main" class is the one with the errors.
So I didn't really try to start a debug session here.
Now I did, but wondering, that there is no message about "Some classes have errors, run anyway ?" any more.

Result:
On first run, Quick Search was located in extra toolbar line, but I could move it manually, which is not possible in
current 6.5.
On 2nd run, Quick Search position was remained ... located properly in 1st toolbar line. Well done.
Comment 10 ulfzibis 2008-12-16 11:19:07 UTC
... it would be nice, if Quick Search is located in 1st toolbar line by default, if there is enough space.
Comment 11 Stanislav Aubrecht 2008-12-16 12:38:01 UTC
> ... it would be nice, if Quick Search is located in 1st toolbar line by default, if there is enough space.
that is the default. it's not working for you, try 'reset toolbars' action or file a bug, thanks
Comment 12 ulfzibis 2008-12-16 13:25:44 UTC
> ... that is the default.

Maybe it was old wrong setting from previous version which forced Quick Search to be located in 2nd toolbar line at
first run.
... As I said: On 2nd run, Quick Search position was remembered/located properly in 1st toolbar line.
Comment 13 ulfzibis 2009-02-28 22:49:21 UTC
I again have bad located Quicksearch in toolbar since last Hotfix. See attachment ...
Maybe there is relation to Issue 159375.
Comment 14 ulfzibis 2009-02-28 22:50:34 UTC
Created attachment 77511 [details]
Quicksearch located bad
Comment 15 ulfzibis 2009-05-19 23:54:05 UTC
Again I see this in NB 6.7 Build 200905160201. :-(

Comment 16 Stanislav Aubrecht 2009-05-20 08:15:45 UTC
can you attach a new screen shot pls? thanks
Comment 17 ulfzibis 2009-05-20 10:17:42 UTC
Created attachment 82454 [details]
Quicksearch located in additional line
Comment 18 Stanislav Aubrecht 2009-05-20 10:33:16 UTC
hm, did you import settings from previous version?
does it happen with a clean user dir?
Comment 19 ulfzibis 2009-05-20 12:06:07 UTC
Yes, I imported settings from previous version.
Comment 20 Stanislav Aubrecht 2009-10-22 14:07:37 UTC
i found two possible ways for quicksearch to appear on second toolbar row:
- settings were imported from previous netbeans version where quicksearch has been placed on second toolbar row for some
reason. i can't do about this much, 'reset toolbars' action helps
- if there's non-standard toolbar configuration, e.g. added by a third-party plugin, which doesn't list the quicksearch
toolbar then quicksearch will appear on the last toolbar row - that is fixed in core-main b246b9ee0f81
Comment 21 Quality Engineering 2009-10-23 10:07:31 UTC
Integrated into 'main-golden', will be available in build *200910230201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/b246b9ee0f81
User: S. Aubrecht <saubrecht@netbeans.org>
Log: #145207 - default position for quicksearch toolbar is the right-hand edge of first toolbar row
Comment 22 ulfzibis 2009-10-23 13:51:28 UTC
> - settings were imported from previous netbeans version where quicksearch has been placed on second toolbar row for some
> reason. i can't do about this much, 'reset toolbars' action helps

How to place quicksearch to whatever row?
If I open toolbar customizer, I can't drag quicksearch icon?
Comment 23 ulfzibis 2009-10-23 17:58:06 UTC
I tried Build 200910230201.
Your fix doesn't help.
I don't think there's non-standard toolbar configuration, e.g. added by a third-party plugin.
I can send you the imported setting zip for evaluation. Please give me a private location to upload, because of the
possible passwords.
Comment 24 ulfzibis 2009-10-23 18:34:10 UTC
For reproduction:
- reset toolbars
- enable clipboard and debugger toolbars
- add "Find" to last position of clipboard toolbar (see Issue 172704)
- add "Debug File" to first position of debugger toolbar
- start debug session --> ok, it works
- export Miscellaneous -> Toolbars to "6.8 toolbars.zip"
- import "6.8 toolbars.zip"
- start debug session --> quicksearch is again in 2nd row


Comment 25 ulfzibis 2009-10-23 18:36:18 UTC
Created attachment 90003 [details]
toolbars export
Comment 26 Stanislav Aubrecht 2009-10-26 15:38:28 UTC
i can't reproduce this issue using the step you provided.
please attach the content of <nb user dir>/config/Toolbars when you have quicksearch toolbar showing on second row, thanks
Comment 27 ulfzibis 2009-10-26 16:12:43 UTC
Created attachment 90089 [details]
.netbeans\dev091023\config\...
Comment 28 ulfzibis 2009-10-26 16:19:38 UTC
Note: The content of <nb user dir>/config/Toolbars doesn't change (see files timestamps), when quicksearch toolbar
actually is showing on second row while debugging.
* Please answer my question from Fri Oct 23 12:51:28 +0000 2009.
Comment 29 Stanislav Aubrecht 2009-10-26 18:23:02 UTC
> How to place quicksearch to whatever row?
you can't unless you manually edit xml files in <nb user dir>/config/Toolbars

> If I open toolbar customizer, I can't drag quicksearch icon?
you can, but you have to drag the edit field's border, not the icon. or you can drag and drop quicksearch from
customizer's tree

the attached toolbar configuration shows that quicksearch is placed on second toolbar row when debugging toolbar config
is active (is when debugging). i still can't reproduce your use case with a clean user dir
Comment 30 ulfzibis 2009-10-27 14:43:04 UTC
Wouldn'd it be better, to make quicksearch toolbar moveable, consistently to all other toolbars ?
And don't forget, 'reset toolbars' action didn't help until I deleted config/Toolbars folder manually, and after, as
cause not working right-click on toolbar free area, I had to customize via Menu -> View -> Toolbars, to make Toolbar
behavior "normal" again.
Comment 31 Stanislav Aubrecht 2009-10-29 15:15:01 UTC
that's a good point. the only reason quicksearch toolbar isn't movable is that in older netbeans versions the toolbars
implementation didn't support 'align-to-the-right' very well. the toolbars now behave better so after offline discussion
with hie team we decided to make quicksearch toolbar movable again. it's default position will still be the right edge
of the main window.
Comment 32 Stanislav Aubrecht 2009-10-29 15:27:28 UTC
fixed

core-main f4792bcd3000
Comment 33 Quality Engineering 2009-11-01 10:55:14 UTC
Integrated into 'main-golden', will be available in build *200910310201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/f4792bcd3000
User: S. Aubrecht <saubrecht@netbeans.org>
Log: #145207 - make quicksearch toolbar draggable


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo