Bug 145080 - NullPointerException at org.netbeans.modules.subversion.Subversion.getClient
NullPointerException at org.netbeans.modules.subversion.Subversion.getClient
Status: RESOLVED INVALID
Product: versioncontrol
Classification: Unclassified
Component: Subversion
6.x
All All
: P3 (vote)
: TBD
Assigned To: issues@versioncontrol
issues@versioncontrol
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-26 02:17 UTC by lewisbloch
Modified: 2008-11-11 10:55 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (875 bytes, text/plain)
2008-08-26 02:17 UTC, lewisbloch
Details
log showing Subversion-related NPE - 2nd try to attach (63.83 KB, text/plain)
2008-09-09 02:50 UTC, lewisbloch
Details

Note You need to log in before you can comment on or make changes to this bug.
Description lewisbloch 2008-08-26 02:17:03 UTC
Build: NetBeans IDE Dev (Build 200808241401)
VM: Java HotSpot(TM) 64-Bit Server VM, 11.0-b15, Java(TM) SE Runtime Environment, 1.6.0_10-rc-b28
OS: Linux, 2.6.24-19-generic, amd64

User Comments: 
Checked out two projects from svn:// location. 
Made into "Project with existing sources", thus creating nbbuild.xml files for both. 
Clicked on first project, selected menu "Versioning / Update with Dependencies".
Right-clicked on second project, picked "Clean and Build", got immediate return.

"Build" and "Clean" options were greyed out.  WTF?

Left-clicked on second project, selected menu "Versioning / Subversion / Update with Dependencies".
Got NullPointerException.


Stacktrace: 
java.lang.NullPointerException
        at org.netbeans.modules.subversion.Subversion.getClient(Subversion.java:210)
        at org.netbeans.modules.subversion.Subversion.getClient(Subversion.java:247)
        at org.netbeans.modules.subversion.ui.update.UpdateAction.update(UpdateAction.java:149)
        at org.netbeans.modules.subversion.ui.update.UpdateAction.access$000(UpdateAction.java:75)
        at org.netbeans.modules.subversion.ui.update.UpdateAction$4.perform(UpdateAction.java:272)
        at org.netbeans.modules.subversion.client.SvnProgressSupport.performIntern(SvnProgressSupport.java:101)
Comment 1 lewisbloch 2008-08-26 02:17:09 UTC
Created attachment 68298 [details]
stacktrace
Comment 2 Tomas Stupka 2008-09-05 14:02:47 UTC
> "Build" and "Clean" options were greyed out.  WTF?
maybe this helps - http://blogs.sun.com/coreqa/entry/why_is_build_action_grey
however, shouldn't be related to the exception...

looks like you got the problem with a couple of times - the build 200808241401 from this issue, and 200808300201 as
mentioned in #122411.

any chance to reproduce? 
could you please attach your whole log file if it should appear again?

thanks

Comment 3 lewisbloch 2008-09-09 02:50:20 UTC
Created attachment 69368 [details]
log showing Subversion-related NPE - 2nd try to attach
Comment 4 Tomas Stupka 2008-09-09 08:02:35 UTC
does this happen randomly or do you get it always after a particular action?

there seems to be something with:
/home/lewie/projects/syncleus/dann/java_dann_examples

- what exactly did you select and what action caused the exception?
- is the mentioned file/folder part of the selection? 

at some point, netbeans thinks it isn't managed by svn, on the other hand, it was possible to invoke update on it:

- what is it's svn status - is it just svn versioned, or maybe ignored, external, new ... ?
- could you please run svn info for the given path from the commandline and attach the output to this issue?
- in case it is a folder, does it contain svn metadata (a .svn folder)? 
- does any of its parent folders contain svn metadata? which one
- could it be some of its parent folder are versioned by some another system? e.g cvs
- anything else you think could be of interest

- in case you can easily reproduce the issue - please start nb with the following switches, reproduce, and attach you
log file again.
-J-Dorg.netbeans.modules.versioning.level=100 
-J-Dorg.netbeans.modules.subversion.level=100




 
Comment 5 Tomas Stupka 2008-09-09 08:18:54 UTC
i've added some changes to the update action. There is a chance they fix your problem.

However, i'd still like to see the output given by the switches. 

thanks a lot

changeset:   100803:097a8f1407a6
tag:         tip
user:        Tomas Stupka <tstupka@netbeans.org>
date:        Tue Sep 09 09:14:16 2008 +0200
summary:     #145080 - NullPointerException at org.netbeans.modules.subversion.Subversion.getClient
Comment 6 Quality Engineering 2008-09-10 06:05:38 UTC
Integrated into 'main-golden', will be available in build *200809100201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/097a8f1407a6
User: Tomas Stupka <tstupka@netbeans.org>
Log: #145080 - NullPointerException at org.netbeans.modules.subversion.Subversion.getClient
Comment 7 Tomas Stupka 2008-09-22 09:58:55 UTC
any update on this?
Comment 8 Peter Pis 2008-11-11 10:55:05 UTC
Without requested information for long time - INVALID. We can't do anything in this case. Reporter, please add requested
information and reopen issue. Thanks in advance.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo