Bug 144981 - Assertion `c->xlib.lock' failed.
Assertion `c->xlib.lock' failed.
Status: RESOLVED DUPLICATE of bug 123300
Product: installer
Classification: Unclassified
Component: RPM
All All
: P1 (vote)
Assigned To: issues@installer
Depends on:
  Show dependency treegraph
Reported: 2008-08-25 10:09 UTC by vinaykukreja
Modified: 2009-09-24 14:29 UTC (History)
0 users

See Also:
Issue Type: DEFECT


Note You need to log in before you can comment on or make changes to this bug.
Description vinaykukreja 2008-08-25 10:09:02 UTC

I installed netbeans 6.1 version for my linux machine distrubuted by fedora (version I also installed JdK 1.5.
The installation went on fine. However when I tried running netbeans, I got the error below:

 [kvinay@kvinay-lnx bin]$ ./netbeans 
java: xcb_xlib.c:50: xcb_xlib_unlock: Assertion `c->xlib.lock' failed.
./../platform7/lib/nbexec: line 440:  4198 Aborted               

Could anyone tell me what is the issue and how can I resolve it.

Comment 1 vinaykukreja 2008-08-25 12:49:01 UTC
I wanted to add that the linux version is:

Linux kvinay-lnx

Java Version:




Comment 2 Vojtech Sigler 2009-09-24 09:18:58 UTC
Could you try installing a newer version of netbeans? I'm not sure what version of fedora is (is it the correct
version number?). If you really installed 6.1m1 (Milestone 1), it is most probably an ustable development version.

In the meantime, reassigning to platform for evaluation. However, this may probably be closed since it is more than a
year old.

Comment 3 Antonin Nebuzelsky 2009-09-24 09:59:50 UTC
Reassigning to Fedora packaging.
Comment 4 dlipin 2009-09-24 11:45:13 UTC
That is the JDK issue fixed in JDK 5u17 and 6u6.
Comment 5 dlipin 2009-09-24 14:29:40 UTC

*** This issue has been marked as a duplicate of 123300 ***

By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo