Bug 144938 - [65cat] IllegalStateException: FacesModel was not loaded for DataObject, dataObject=org.netbeans.modules.visualweb.project.jsfloader.JsfJspDataObject@1716e12[C:\Documents and Settings\Administrator\My Documen
[65cat] IllegalStateException: FacesModel was not loaded for DataObject, data...
Status: RESOLVED DUPLICATE of bug 135607
Product: third-party
Classification: Unclassified
Component: -- Other --
6.x
All All
: P1 (vote)
: TBD
Assigned To: issues@third-party
issues@third-party
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT
:
: 138878 144940 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-24 05:01 UTC by thompsonwd40
Modified: 2009-09-08 21:47 UTC (History)
31 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (3.02 KB, text/plain)
2008-08-24 05:02 UTC, thompsonwd40
Details
stacktrace (3.02 KB, text/plain)
2008-08-24 19:22 UTC, thompsonwd40
Details
stacktrace (2.41 KB, text/plain)
2009-08-07 16:04 UTC, rdelaplante
Details

Note You need to log in before you can comment on or make changes to this bug.
Description thompsonwd40 2008-08-24 05:01:56 UTC
Build: NetBeans IDE Dev (Build 200808221401)
VM: Java HotSpot(TM) Client VM, 1.6.0_03-b05, Java(TM) SE Runtime Environment, 1.6.0_03-b05
OS: Windows XP, 5.1, x86

User Comments: 
[65cat] Double-click a page from Projects Window, using Visual JSF.

Stacktrace: 
java.lang.IllegalStateException: FacesModel was not loaded for DataObject, dataObject=org.netbeans.modules.visualweb.project.jsfloader.JsfJspDataObject@1716e12[C:\Documents and Settings\Administrator\My Documents\NetBeansProjects\WorkloadWebApp\web\Login.jsp]
        at org.netbeans.modules.visualweb.designer.jsf.JsfForm.loadFacesModel(JsfForm.java:3020)
        at org.netbeans.modules.visualweb.designer.jsf.JsfForm.access$000(JsfForm.java:131)
        at org.netbeans.modules.visualweb.designer.jsf.JsfForm$1.modelSetAdded(JsfForm.java:369)
        at org.netbeans.modules.visualweb.insync.ModelSet.fireModelSetAdded(ModelSet.java:179)
        at org.netbeans.modules.visualweb.insync.ModelSet.getInstance(ModelSet.java:255)
        at org.netbeans.modules.visualweb.insync.ModelSet$1.run(ModelSet.java:217)
Comment 1 thompsonwd40 2008-08-24 05:02:03 UTC
Created attachment 68176 [details]
stacktrace
Comment 2 thompsonwd40 2008-08-24 19:22:13 UTC
Build: NetBeans IDE Dev (Build 200808221401)
VM: Java HotSpot(TM) Client VM, 1.6.0_03-b05, Java(TM) SE Runtime Environment, 1.6.0_03-b05
OS: Windows XP, 5.1, x86

User Comments: 
[65cat] Opening VWP page, by clicking an available tab.  Using latest build, after encountering this problem yesterday to see if the problem still persists.  It does.

Stacktrace: 
java.lang.IllegalStateException: FacesModel was not loaded for DataObject, dataObject=org.netbeans.modules.visualweb.project.jsfloader.JsfJspDataObject@84433d[C:\Documents and Settings\Administrator\My Documents\NetBeansProjects\WorkloadWebApp\web\ClassView.jsp]
        at org.netbeans.modules.visualweb.designer.jsf.JsfForm.loadFacesModel(JsfForm.java:3020)
        at org.netbeans.modules.visualweb.designer.jsf.JsfForm.access$000(JsfForm.java:131)
        at org.netbeans.modules.visualweb.designer.jsf.JsfForm$1.modelSetAdded(JsfForm.java:369)
        at org.netbeans.modules.visualweb.insync.ModelSet.fireModelSetAdded(ModelSet.java:179)
        at org.netbeans.modules.visualweb.insync.ModelSet.getInstance(ModelSet.java:255)
        at org.netbeans.modules.visualweb.insync.ModelSet$1.run(ModelSet.java:217)
Comment 3 thompsonwd40 2008-08-24 19:22:18 UTC
Created attachment 68198 [details]
stacktrace
Comment 4 Peter Zavadsky 2008-08-25 17:10:47 UTC
*** Issue 144940 has been marked as a duplicate of this issue. ***
Comment 5 John Baker 2008-08-26 02:57:44 UTC
I get this error if I don't install NetBeans using the Installer
Comment 6 thompsonwd40 2008-08-26 13:30:50 UTC
Note that I only use the installer, on my WinXP system.  Also note that I have installed many versions of the daily
builds for participation in the NetCat 65 team.  Possibly something cumulative have occurred because of the builds?  I
have not deleted my userdir (yet).
Comment 7 _ deva 2008-08-26 19:36:18 UTC
Insync is not handling the faces configuration file, it is just using the results from web/jsf module. This could be a
problem in web JSF implementation. Re-assigning to Po-Ting for more investigation. 

Note that insync has not changed for quite sometime.
Comment 8 _ deva 2008-08-26 19:38:07 UTC
Re-assigned the wrong bug
Comment 9 _ deva 2008-08-26 19:49:36 UTC
I am not able to reproduce with the following steps
1)Create a visual JSF project
2)Add another page
3)Close the pages
4)Close the project
5)Open the project
6)Open the pages and switch between tabs.

Please provide steps to reproduce
Comment 10 _ potingwu 2008-08-26 19:51:28 UTC
From the stack, insync has trouble get the model and issue the exception. Please first investigate insync at where it
had the trouble and got the exception. Web/jsf didn't change any model since 6.0. However the IDE dataloader has changed
a lot and that looks like the cause because insync has its own classloader that may not sync with.

Please first check where inside insync reports this exception.
Comment 11 _ potingwu 2008-08-26 19:53:21 UTC
fix cross edit
Comment 12 thompsonwd40 2008-08-27 03:24:31 UTC
The error occurs immediately upon attempts to open the Visual editor.  I open a VW project from the projects window, and
IDE attempts to open the Visual editor - I get an error.  I click a tab with a previously opened file (with Visual
editor in focus) - I get an error.  Tonight, I created a new VW project from scratch, using build 0824, after the final
wizard entry and the VW editor fires up, error: http://statistics.netbeans.org/analytics/detail.do?id=9879 was thrown
(an entirely new error not encountered before, with this problem).
Comment 13 thompsonwd40 2008-08-27 03:34:14 UTC
This error occurs when I double-click a jsp file from the Projects window.  A delay as the VW editor appears (blank),
then the error message dialog, which brings me here.  I get different errors, when I try to open a file different ways.
 I will try some different iterations.
Comment 14 thompsonwd40 2008-08-27 13:08:07 UTC
Problem solved.  I removed the iReports plugin, restarted my IDE and all functions correctly.  Please feel free to
complete this issue.
Comment 15 _ deva 2008-08-27 15:48:44 UTC
As per user comment, closing the bug as non reproducible
Comment 16 John Baker 2008-08-27 18:38:26 UTC
This problem still occurs for me.

I don't know if it's a build issue or Java
Comment 17 _ deva 2008-08-27 18:41:02 UTC
Please provide the steps, I am not able to reproduce with the steps I mentioned earlier in my comment. Or attach a
project and steps to reproduce.
Comment 18 John Baker 2008-08-27 18:43:07 UTC
This is how I reproduced this:

Java: 1.5.0_13; Java HotSpot(TM) Client VM 1.5.0_13-121
System: Mac OS X version 10.4.11 running on i386; MacRoman; en_US (nb)

1) Create a new clone of the repository
2) Build by typing 'ant' only (no options
3) Start NetBeans and register Glassfish v2
4) Create a new Visual Web project

Result:
Page 1 fails to load.
Comment 19 _ potingwu 2008-08-27 18:47:02 UTC
John, what exceptions do you see? Are they the same as reported?
Comment 20 John Baker 2008-08-27 22:44:41 UTC
My bad, I didn't have the stack trace in front of me.  It turns out to be a different problem.

java.lang.NullPointerException: Invalid FacesModel, it has null LiveUnit,
facesModel=org.netbeans.modules.visualweb.insync.models.FacesModel@8468ee[ file: Page1.jsp]
        at org.netbeans.modules.visualweb.designer.jsf.JsfForm.initDesignProjectListening(JsfForm.java:735)
        at org.netbeans.modules.visualweb.designer.jsf.JsfForm.initListening(JsfForm.java:270)
        at org.netbeans.modules.visualweb.designer.jsf.JsfForm.init(JsfForm.java:241)
        at org.netbeans.modules.visualweb.designer.jsf.JsfForm.access$200(JsfForm.java:131)
        at org.netbeans.modules.visualweb.designer.jsf.JsfForm$1$1.run(JsfForm.java:374)
Comment 21 David Konecny 2008-09-03 07:33:29 UTC
This is still valid issue. The problem with RaveDocumentBuilderFactory is that it swallows exceptions in several places
instead of properly rethrowing them or at least logging them, eg. RaveDocumentBuilderFactory() constuctor or
RaveDocumentBuilderFactory.createDocumentBuilder() method. That's the first thing which if corrected will give us next
time this problem happens the real exception. And that real exception IMO is related to iReports pluging perhaps
providing its own parser causing RaveDocumentBuilderFactory to fail to create DocumentBuilderFactory?
Comment 22 John Baker 2008-09-08 08:02:25 UTC
I believe the iReports plugin uses JNDI.  Any NetBeans module that uses JNDI cannot be used if Visual Web projects are
to be loaded during the same NetBeans session.  Visual Web requires an InitialContextFactory to be created at startup.

If this is what this issue is all about then there is another issue tracking this limitation, 125824
Comment 23 David Konecny 2008-09-08 22:42:34 UTC
An exception causing the problem is swallowed so it is hard to say. But it does not look like JNDI is the cause.
Comment 24 Peter Zavadsky 2008-09-19 22:58:01 UTC
*** Issue 138878 has been marked as a duplicate of this issue. ***
Comment 25 Peter Zavadsky 2008-09-25 21:14:00 UTC
I think there was an issue with iReport module. The problem was that the module was trying to load apache xml parser
impl, which clashed with NB library module, already providing those classes. In that case, warning is printed (look or
provide the log file -> <userdir>/var/log/messages.log).
In sum, the iReport module, shouldn't provide those apache classes, rather depend on the standard NB library module,
which already provides them.
Comment 26 Exceptions Reporter 2008-10-01 09:22:30 UTC
This issue has already 20 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=74378
Comment 27 Exceptions Reporter 2009-05-06 16:24:40 UTC
This issue already has 150 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=74378
Comment 28 Exceptions Reporter 2009-07-23 08:05:09 UTC
This issue already has 203 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=74378
Comment 29 rdelaplante 2009-08-07 16:04:27 UTC
Build: NetBeans IDE 6.7 (Build 200906241340)
VM: Java HotSpot(TM) Client VM, 14.0-b16, Java(TM) SE Runtime Environment, 1.6.0_14-b08
OS: Windows Vista, 6.0, x86

User Comments: 
Double clicked a visual web page from Web Pages tree node.  The page did not open, and I got this exception. 

Stacktrace: 
java.lang.NullPointerException
        at org.netbeans.modules.visualweb.designer.markup.RaveDocumentBuilderFactory.createDocumentBuilder(RaveDocumentBuilderFactory.java:146)
        at org.netbeans.modules.visualweb.designer.markup.RaveDocumentBuilderFactory.newDocumentBuilder(RaveDocumentBuilderFactory.java:127)
        at org.netbeans.modules.visualweb.designer.markup.MarkupServiceImpl.createRaveSourceDocumentBuilder(MarkupServiceImpl.java:338)
        at org.netbeans.modules.visualweb.api.designer.markup.MarkupService.createRaveSourceDocumentBuilder(MarkupService.java:235)
        at org.netbeans.modules.visualweb.insync.markup.MarkupUnit.parseDom(MarkupUnit.java:348)
        at org.netbeans.modules.visualweb.insync.markup.MarkupUnit.read(MarkupUnit.java:502)
Comment 30 rdelaplante 2009-08-07 16:04:36 UTC
Created attachment 85973 [details]
stacktrace
Comment 31 Marian Mirilovic 2009-09-08 21:47:59 UTC

*** This issue has been marked as a duplicate of 135607 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo