Bug 144898 - Plugins/Downloaded/Add Plugins... horrible response time
Plugins/Downloaded/Add Plugins... horrible response time
Status: CLOSED WONTFIX
Product: platform
Classification: Unclassified
Component: Directory Chooser
6.x
All All
: P3 (vote)
: 6.x
Assigned To: David Simonek
issues@platform
jdk_bug_6578753
: JDK_SPECIFIC
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-22 21:39 UTC by willfarnaby
Modified: 2011-06-09 09:54 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description willfarnaby 2008-08-22 21:39:28 UTC
August 21, 2008 nightly build:

Select Plugins/Downloaded/Add Plugins...

The File Browser dialog box opens and takes about 1.5 minutes to refresh content (can't remember whether delay is
initial, upon opening, or just after a directory path is input) and paint. During which time... completely unresponsive.

I have experienced this issue for some time now.
Comment 1 tomwheeler 2008-08-22 23:08:30 UTC
I have had the same problem with various dialogs as well since last year.  Although I initially thought NetBeans was at
fault, I did some diagnosis and found that it was actually a JDK bug introduced in JDK 1.6.0u2 (and not yet fixed even
in 1.6.0u7):

   http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6578753

Could this be your problem as well?  You could determine whether this is the case by running this command:

   regsvr32 /u %windir%\system32\zipfldr.dll

and then going to Plugins -> Downloaded -> Add Plugins again to see if you continue to experience the unresponsive
behavior you describe.  
Comment 2 tomwheeler 2008-08-22 23:18:37 UTC
I guess I should have mentioned that the command I listed will disable Windows support for ZIP files.  That's a good
thing in my experience because 7-zip or Winzip do a much better job, but if you like Windows support for ZIP files, you
could run that command to see if it fixes the problem and afterwards restore ZIP file support by running it again
without the /u option.
Comment 3 willfarnaby 2008-08-23 00:55:28 UTC
I ran, as administrator, "regsvr32 /u %windir%\system32\zipfldr.dll" and then tried "Select Plugins/Downloaded/Add
Plugins...". Response very snappy, so unless I see the problem again, I'd say you've provided the workaround for this
problem. My thanks to you.
Comment 4 Peter Pis 2008-08-25 08:39:46 UTC

*** This issue has been marked as a duplicate of 109703 ***
Comment 5 tomwheeler 2008-08-25 16:22:45 UTC
Glad to help.  I came across this issue via your post on nbusers about this subject, so you would be doing a service to
others if you could reply to your original post and reference this issue so others will know how to fix/workaround this
JDK bug if they encounter it.
Comment 6 Tomas Pavek 2008-08-25 18:44:26 UTC
Issue 109703 claims this was fixed (workarounded) for 6.0. But this issue is reported for current dev builds. So there 
must be still something not working. This should be perhaps evaluated more, reopening.
Comment 7 David Simonek 2008-08-27 12:27:48 UTC
tpavek: 109703 was fixed in our directory chooser, but this one has nothing to do with directory chooser, it is about
plain JFileChooser, where we can't workaround JDK bug like we did in our dir chooser.
Comment 8 Tomas Pavek 2008-08-27 15:38:26 UTC
Ok. I just did not know how the chooser was workarounded - and if the plugin manager was not using it as well.
Comment 9 Marian Mirilovic 2011-06-09 09:54:27 UTC
v/c


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo