Bug 144615 - [65cat] FNFE: modules/org-netbeans-modules-visualweb-dataconnectivity.jar
[65cat] FNFE: modules/org-netbeans-modules-visualweb-dataconnectivity.jar
Status: RESOLVED FIXED
Product: www
Classification: Unclassified
Component: Builds & Repositories
6.x
All All
: P1 (vote)
: 6.x
Assigned To: Michal Zlamal
nbbuild-issues@ide
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT
: ERGONOMICS
: 158644 159763 159984 160575 (view as bug list)
Depends on:
Blocks: 159001
  Show dependency treegraph
 
Reported: 2008-08-20 17:44 UTC by ranbato
Modified: 2009-06-15 18:55 UTC (History)
82 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (924 bytes, text/plain)
2008-08-20 17:44 UTC, ranbato
Details
stacktrace (941 bytes, text/plain)
2009-02-19 11:49 UTC, dynamite
Details
stacktrace (941 bytes, text/plain)
2009-02-25 06:22 UTC, adam_myatt
Details
stacktrace (941 bytes, text/plain)
2009-02-26 15:23 UTC, dkittle
Details
stacktrace (941 bytes, text/plain)
2009-02-26 15:25 UTC, dkittle
Details
stacktrace (941 bytes, text/plain)
2009-02-26 20:25 UTC, ranbato
Details
stacktrace (922 bytes, text/plain)
2009-03-02 20:13 UTC, big_al
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ranbato 2008-08-20 17:44:35 UTC
Build: NetBeans IDE Dev (Build 200808200201)
VM: Java HotSpot(TM) Client VM, 10.0-b23, Java(TM) SE Runtime Environment, 1.6.0_07-b06
OS: Windows XP, 5.1, x86

User Comments: 
I had to manually delete this plugin because the last few dailies lock up when it is installed. 

Stacktrace: 
java.io.FileNotFoundException: modules/org-netbeans-modules-breadcrumb.jar
        at org.netbeans.core.startup.ModuleList.findJarByName(ModuleList.java:335)
        at org.netbeans.core.startup.ModuleList.access$700(ModuleList.java:112)
        at org.netbeans.core.startup.ModuleList$Listener.stepCreate(ModuleList.java:1619)
        at org.netbeans.core.startup.ModuleList$Listener.access$2100(ModuleList.java:1305)
        at org.netbeans.core.startup.ModuleList$Listener$1.run(ModuleList.java:1534)
        at org.openide.filesystems.EventControl.runAtomicAction(EventControl.java:120)
Comment 1 ranbato 2008-08-20 17:44:47 UTC
Created attachment 67965 [details]
stacktrace
Comment 2 Lukas Hasik 2008-08-21 08:27:23 UTC
does it mean that you manually deleted the jar and after restart of IDE the exception appeared?
Comment 3 Lukas Hasik 2008-08-21 13:52:39 UTC
from ranbato's email:
Yes.
I manually deleted it because the UI was totally unresponsive.
I got this error after I restarted.
----------------

OK, then I'm closing as INVALID. User removed the jar but the IDE was still looking for it. When the jar was not found
the problem was reported with exception. Fair behaviour in IMO.

Anyway, thank you for the report and for cooperation. 
Please, report the problems with the plugin itself directly to the author.
Comment 4 Marian Mirilovic 2009-02-12 14:50:31 UTC
reproduced in NB Dev (20090212) ... 
- Download full IDE
- deactivate profiler
- uninstall profiler
- install profiler 
- restart IDE 
-> throws exception while starting

76 duplicates so far and still rising
Comment 5 Antonin Nebuzelsky 2009-02-17 10:09:12 UTC
Related to the cache our module system uses since 6.1?
Comment 6 Jesse Glick 2009-02-18 02:27:24 UTC
I cannot reproduce with the Java SE download (*) - you cannot even deactivate the profiler! It is still active after you
restart.

Note that the posted steps seem to omit restarting after deactivating and after uninstalling, which I was able to follow
in full for the case of Hibernate Web (all looked fine, no exception thrown).

Likely a problem in Plugin Manager, failing to delete config/Modules/*.xml when it deletes modules/*.jar? Or perhaps
config/Modules/*.xml is unpacked from NBM first, firing an event, then modules/*.jar is unpacked later? Or modules/*.jar
is not unpacked at all, perhaps not even present in the NBM?

In core-main #d20d2e696ac7 I am downgrading the error to a console warning line rather than a stack trace, but this will
not solve the root problem, whatever that is - i.e. there could still be modules which are supposed to be enabled but
which are not.

(*) I'm not about to get the mammoth full download unless QE says that this is actually necessary to reproduce the
exception.
Comment 7 Jesse Glick 2009-02-18 02:38:40 UTC
*** Issue 158644 has been marked as a duplicate of this issue. ***
Comment 8 dlipin 2009-02-18 07:20:41 UTC
Regarding
> I cannot reproduce with the Java SE download (*) - you cannot even deactivate the profiler! It is still active after 
you restart.

See Issue 158469.
Comment 9 dynamite 2009-02-19 11:48:56 UTC
Build: NetBeans IDE Dev (Build 200902181708)
VM: Java HotSpot(TM) Client VM, 11.0-b16, Java(TM) SE Runtime Environment, 1.6.0_11-b03
OS: Windows XP, 5.1, x86

User Comments: 
Installed dev build on my machine for the first time.  6.5 already installed.  Selected JetBrains PDF viewer to be imported alongside the pre-selcted list of modules.  Got this exception immediately upon pressing the "Import" button.

Stacktrace: 
java.io.FileNotFoundException: modules/org-netbeans-modules-visualweb-dataconnectivity.jar
        at org.netbeans.core.startup.ModuleList.findJarByName(ModuleList.java:337)
        at org.netbeans.core.startup.ModuleList.access$700(ModuleList.java:112)
        at org.netbeans.core.startup.ModuleList$Listener.stepCreate(ModuleList.java:1621)
        at org.netbeans.core.startup.ModuleList$Listener.access$2100(ModuleList.java:1307)
        at org.netbeans.core.startup.ModuleList$Listener$1.run(ModuleList.java:1536)
        at org.openide.filesystems.EventControl.runAtomicAction(EventControl.java:120)
Comment 10 dynamite 2009-02-19 11:49:01 UTC
Created attachment 77147 [details]
stacktrace
Comment 11 Quality Engineering 2009-02-22 08:03:21 UTC
Integrated into 'main-golden', will be available in build *200902220201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/d20d2e696ac7
User: Jesse Glick <jglick@netbeans.org>
Log: #144615: more graceful handling of FNFE. Not attempting to fix root problem.
Comment 12 adam_myatt 2009-02-25 06:22:41 UTC
Build: NetBeans IDE Dev (Build 200902231810)
VM: Java HotSpot(TM) Client VM, 11.2-b01, Java(TM) SE Runtime Environment, 1.6.0_12-b04
OS: Windows XP, 5.1, x86

User Comments: 
In the plugins window, installing the BUG LIST plugin. it ran through install and through exception since apparently it is expecting a different module to be present which wasn't (or actually may have been installed, but deactivated)

Stacktrace: 
java.io.FileNotFoundException: modules/org-netbeans-modules-visualweb-dataconnectivity.jar
        at org.netbeans.core.startup.ModuleList.findJarByName(ModuleList.java:337)
        at org.netbeans.core.startup.ModuleList.access$700(ModuleList.java:112)
        at org.netbeans.core.startup.ModuleList$Listener.stepCreate(ModuleList.java:1621)
        at org.netbeans.core.startup.ModuleList$Listener.access$2100(ModuleList.java:1307)
        at org.netbeans.core.startup.ModuleList$Listener$1.run(ModuleList.java:1536)
        at org.openide.filesystems.EventControl.runAtomicAction(EventControl.java:120)
Comment 13 adam_myatt 2009-02-25 06:22:54 UTC
Created attachment 77337 [details]
stacktrace
Comment 14 dlipin 2009-02-26 14:51:15 UTC
This exception occurs after the NPE:

java.lang.NullPointerException
	at org.netbeans.updater.UpdateTracking$Module.writeModulesConfig(UpdateTracking.java:833)
	at org.netbeans.updater.UpdateTracking$Module.writeConfigModuleXMLIfMissing(UpdateTracking.java:695)
	at org.netbeans.updater.ModuleUpdater.unpack(ModuleUpdater.java:434)
	at org.netbeans.updater.ModuleUpdater.run(ModuleUpdater.java:131)

I`m investigating.
Comment 15 dkittle 2009-02-26 15:23:05 UTC
Build: NetBeans IDE Dev (Build 200902231810)
VM: Java HotSpot(TM) 64-Bit Server VM, 11.0-b15, Java(TM) SE Runtime Environment, 1.6.0_10-b33
OS: Linux, 2.6.27-11-generic, amd64

User Comments: 
I was trying to import the JMX and Icefaces plugins from 6.5 to 6.7m2 and got his error.


Stacktrace: 
java.io.FileNotFoundException: modules/org-netbeans-modules-visualweb-dataconnectivity.jar
        at org.netbeans.core.startup.ModuleList.findJarByName(ModuleList.java:337)
        at org.netbeans.core.startup.ModuleList.access$700(ModuleList.java:112)
        at org.netbeans.core.startup.ModuleList$Listener.stepCreate(ModuleList.java:1621)
        at org.netbeans.core.startup.ModuleList$Listener.access$2100(ModuleList.java:1307)
        at org.netbeans.core.startup.ModuleList$Listener$1.run(ModuleList.java:1536)
        at org.openide.filesystems.EventControl.runAtomicAction(EventControl.java:120)
Comment 16 dkittle 2009-02-26 15:23:16 UTC
Created attachment 77412 [details]
stacktrace
Comment 17 dkittle 2009-02-26 15:24:59 UTC
Build: NetBeans IDE Dev (Build 200902231810)
VM: Java HotSpot(TM) 64-Bit Server VM, 11.0-b15, Java(TM) SE Runtime Environment, 1.6.0_10-b33
OS: Linux, 2.6.27-11-generic, amd64

User Comments: 
I got this error when NB 6.7m2 was trying to import the JMX plugin (1.0.0.2) from my NB6.5 install.  It happened after the plugin was 'downloaded', during the installation of the plugin.


Stacktrace: 
java.io.FileNotFoundException: modules/org-netbeans-modules-visualweb-dataconnectivity.jar
        at org.netbeans.core.startup.ModuleList.findJarByName(ModuleList.java:337)
        at org.netbeans.core.startup.ModuleList.access$700(ModuleList.java:112)
        at org.netbeans.core.startup.ModuleList$Listener.stepCreate(ModuleList.java:1621)
        at org.netbeans.core.startup.ModuleList$Listener.access$2100(ModuleList.java:1307)
        at org.netbeans.core.startup.ModuleList$Listener$1.run(ModuleList.java:1536)
        at org.openide.filesystems.EventControl.runAtomicAction(EventControl.java:120)
Comment 18 dkittle 2009-02-26 15:25:16 UTC
Created attachment 77413 [details]
stacktrace
Comment 19 Jesse Glick 2009-02-26 16:10:23 UTC
Earliest known version is 6.5, please do not move Version field forward.

Obviously happening to a lot of people, needs to be addressed quickly.

visualweb.dataconnectivity appears as the problem module in most of the reports; perhaps its published NBM is corrupt?
Comment 20 dlipin 2009-02-26 16:33:11 UTC
I too experince this issue after the following steps:
1) Install 6.7 M2 (full version)
2) Run IDE, open Tools->Plugins, click "Reload Catalog" button and then choose "Bug List" to install
3) During installation this exception happens.

Not that this exception refer to "org-netbeans-modules-visualweb-dataconnectivity.jar" which is not included in the 
distribution. It is available on the UC but it is not installed with the buglist at all. After I disable ergonomics 
cluster, the issue goes away.

I realize that this issue (with different modules) also happens in 6.5 where there was no ergonomics but at this moment 
the ergonomics has the definite influence on the issue occurance.
Comment 21 ranbato 2009-02-26 20:25:18 UTC
Build: NetBeans IDE Dev (Build 200902231810)
VM: OpenJDK Client VM, 14.0-b10, Java(TM) SE Runtime Environment, 1.6.0_14-ea-b01
OS: Windows XP, 5.1, x86

User Comments: 
Importing 6.5 plugins

Stacktrace: 
java.io.FileNotFoundException: modules/org-netbeans-modules-visualweb-dataconnectivity.jar
        at org.netbeans.core.startup.ModuleList.findJarByName(ModuleList.java:337)
        at org.netbeans.core.startup.ModuleList.access$700(ModuleList.java:112)
        at org.netbeans.core.startup.ModuleList$Listener.stepCreate(ModuleList.java:1621)
        at org.netbeans.core.startup.ModuleList$Listener.access$2100(ModuleList.java:1307)
        at org.netbeans.core.startup.ModuleList$Listener$1.run(ModuleList.java:1536)
        at org.openide.filesystems.EventControl.runAtomicAction(EventControl.java:120)
Comment 22 ranbato 2009-02-26 20:25:34 UTC
Created attachment 77426 [details]
stacktrace
Comment 23 Jesse Glick 2009-02-27 00:01:17 UTC
I suspect that ide.ergonomics/build.xml is creating nbbuild/netbeans/ergonomics1/config/Modules/*.xml entries for
visualweb.* modules which are not even present in the build to begin with. The numerous duplicates starting around the
time visualweb was moved to AU (Jan 28) would support this. (Earlier instances could be from corrupt IDE installations;
who knows.) If true, then my #d20d2e696ac7 should downgrade this to a warning in the log, but the real problem is that
ide.ergonomics is failing to confirm that it is disabling things which were really there.

The NPE from UpdateTracking$Module.writeModulesConfig should still be addressed.
Comment 24 Jaroslav Tulach 2009-03-02 19:04:22 UTC
For a while I thought Jesse's idea is crazy. ide.ergonomics build can in no way refer to visualweb.* modules unless 
they were build before. And as they are not part of the standard build, there shall be no way to build them.

However, to my horror, 6.7/m2/latest/zip/netbeans-6.7_m2-200902231810.zip does contain 
netbeans/ergonomics1/config/Modules/*visualweb*.xml! I am not sure what is the cause, but as simple:

ant clean build

on command line produces correct builds, there had to be something wild in the production builds scripts. Michal, 
please find out what.

Btw. the recent build is still broken:
~$ unzip -l /net/smetiste/space/builds/netbeans/trunk/daily/latest/zip/netbeans-trunk-nightly-200902271613.zip | grep 
visualweb | cut -f 5- -d "/"
org-netbeans-modules-visualweb-api-designer.xml
org-netbeans-modules-visualweb-api-j2ee.xml
org-netbeans-modules-visualweb-api-portlet-dd.xml
org-netbeans-modules-visualweb-classloaderprovider.xml
org-netbeans-modules-visualweb-complib-api.xml
org-netbeans-modules-visualweb-complib.xml
org-netbeans-modules-visualweb-dataconnectivity-designtime.xml
org-netbeans-modules-visualweb-dataconnectivity.xml
org-netbeans-modules-visualweb-dataprovider-designtime.xml
org-netbeans-modules-visualweb-designer-cssengine.xml
org-netbeans-modules-visualweb-designer-jsf.xml
org-netbeans-modules-visualweb-designer-markup.xml
org-netbeans-modules-visualweb-designer.xml
org-netbeans-modules-visualweb-designtime-idebridge.xml
org-netbeans-modules-visualweb-designtime.xml
org-netbeans-modules-visualweb-designtimeext.xml
org-netbeans-modules-visualweb-ejb.xml
org-netbeans-modules-visualweb-errorhandler-client.xml
org-netbeans-modules-visualweb-extension-openide-loaders.xml
org-netbeans-modules-visualweb-extension-openide.xml
org-netbeans-modules-visualweb-insync.xml
org-netbeans-modules-visualweb-j2ee14classloaderprovider.xml
org-netbeans-modules-visualweb-j2ee15classloaderprovider.xml
org-netbeans-modules-visualweb-jsfsupport-designtime.xml
org-netbeans-modules-visualweb-jsfsupport-designtime_1_1.xml
org-netbeans-modules-visualweb-jsfsupport-designtime_1_2.xml
org-netbeans-modules-visualweb-jsfsupport.xml
org-netbeans-modules-visualweb-kit.xml
org-netbeans-modules-visualweb-navigation.xml
org-netbeans-modules-visualweb-outline.xml
org-netbeans-modules-visualweb-palette.xml
org-netbeans-modules-visualweb-project-jsf.xml
org-netbeans-modules-visualweb-project-jsfloader.xml
org-netbeans-modules-visualweb-propertyeditors-api.xml
org-netbeans-modules-visualweb-propertyeditors-resolver.xml
org-netbeans-modules-visualweb-propertyeditors.xml
org-netbeans-modules-visualweb-ravehelp-rave_nbpack.xml
org-netbeans-modules-visualweb-runtime-kit.xml
org-netbeans-modules-visualweb-samples-bundled.xml
org-netbeans-modules-visualweb-web-ui-appbase.xml
org-netbeans-modules-visualweb-websvcmgr.xml
org-netbeans-modules-visualweb-webui-designtime.xml
org-netbeans-modules-visualweb-webui-jsf-defaulttheme.xml
org-netbeans-modules-visualweb-webui-themes.xml
Comment 25 Jaroslav Tulach 2009-03-02 19:12:16 UTC
My guess is that this is the faulty build step:
http://hg.netbeans.org/main/rev/8ff1683c7cc4

+
+    pack_component $DIST_DIR/zip/moduleclusters $NAME visualweb "visualweb*"
+    rm -rf visualweb*

the visualweb shall not be created at all, if it is available just on autoupdate. In case you insist on creating 
visualweb being the right thing, I can 

diff -r d19edaf83fa9 ide.ergonomics/build.xml
--- a/ide.ergonomics/build.xml  Mon Mar 02 13:46:28 2009 +0100
+++ b/ide.ergonomics/build.xml  Mon Mar 02 20:10:46 2009 +0100
@@ -41,6 +41,7 @@
             <exclude name="ide1*"/>
             <exclude name="platform*"/>
             <exclude name="ergonomics*"/>
+            <exclude name="visualweb*"/>
             <exclude name="extra*"/>
             <exclude name="nb*.*"/>
             <exclude name="bin"/>

but it would be better to make the production build closer to "ant clean build" than invent yet another place where to 
duplicate the config.
Comment 26 dlipin 2009-03-02 19:26:46 UTC
Jarda,

It does not make any sence to remove *visualweb* xml files from ergonomics. I`ve tried to do that but I`ve got the same 
FNFE thrown just with reference to another module (modules/org-netbeans-modules-php-editor.jar).
I have "Java" distribution installed in this case.
Comment 27 big_al 2009-03-02 20:13:01 UTC
Build: NetBeans IDE Dev (Build 200902231810)
VM: Java HotSpot(TM) Client VM, 1.5.0_16-133, Java(TM) 2 Runtime Environment, Standard Edition, 1.5.0_16-b06-284
OS: Mac OS X, 10.5.6, i386

User Comments: 
I was installing some plug-ins

Stacktrace: 
java.io.FileNotFoundException: modules/org-netbeans-modules-vmd-kit.jar
        at org.netbeans.core.startup.ModuleList.findJarByName(ModuleList.java:337)
        at org.netbeans.core.startup.ModuleList.access$700(ModuleList.java:112)
        at org.netbeans.core.startup.ModuleList$Listener.stepCreate(ModuleList.java:1621)
        at org.netbeans.core.startup.ModuleList$Listener.access$2100(ModuleList.java:1307)
        at org.netbeans.core.startup.ModuleList$Listener$1.run(ModuleList.java:1536)
        at org.openide.filesystems.EventControl.runAtomicAction(EventControl.java:120)
Comment 28 big_al 2009-03-02 20:13:17 UTC
Created attachment 77573 [details]
stacktrace
Comment 29 Exceptions Reporter 2009-03-03 10:45:57 UTC
This issue has already 250 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=37886
Comment 30 Jaroslav Tulach 2009-03-03 13:38:27 UTC
Possibly fixed in ergonomics#cef8a1144783 - depends on the actual behaviour of the production build scripts
Comment 31 Quality Engineering 2009-03-04 09:04:40 UTC
Integrated into 'main-golden', will be available in build *200903040201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/cef8a1144783
User: Jaroslav Tulach <jtulach@netbeans.org>
Log: #144615: RE says that the ide.ergonomics build.xml shall only include clusters from current cluster config
Comment 32 Petr Suchomel 2009-03-04 12:56:32 UTC
FYI, org-netbeans-modules-vmd-kit.jar mentioned here comes from Mobility
Comment 33 Jaroslav Tulach 2009-03-05 08:05:04 UTC
# Running following grep seems to yield just two lines result:

trunk/daily/2009-03-04_02-01-11/zip$ for i in *; do (unzip -v $i | grep visualweb >/dev/null) && echo $i; done
netbeans-trunk-nightly-200903040201-src.zip
stable-UC-l10n-200903040201.zip

# which is much less than in case of previous build:

trunk/daily/2009-02-27_03-13-21/zip$ for i in *; do (unzip -v $i | grep visualweb >/dev/null) && echo $i; done
netbeans-trunk-nightly-200902270313-java.zip
netbeans-trunk-nightly-200902270313-src.zip
netbeans-trunk-nightly-200902270313.zip
stable-UC-l10n-200902270313.zip

# I guess the problem with ergonomics cluster referencing non-existent visualweb is fixed now.
Comment 34 Jaroslav Tulach 2009-03-09 08:55:04 UTC
A note to all people on CC: Your XML reports seem to come from revision ed719f12b444 - e.g. 6.7M2. Update to recent 
trunk version of NetBeans to get rid of your problem.
Comment 35 Jesse Glick 2009-03-10 14:39:53 UTC
*** Issue 159763 has been marked as a duplicate of this issue. ***
Comment 36 Jesse Glick 2009-03-10 14:41:08 UTC
*** Issue 159984 has been marked as a duplicate of this issue. ***
Comment 37 dlipin 2009-03-18 17:50:21 UTC
*** Issue 160575 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo