Bug 144516 - No way to control editor anti-aliasing from inside the IDE
No way to control editor anti-aliasing from inside the IDE
Status: RESOLVED DUPLICATE of bug 79453
Product: editor
Classification: Unclassified
Component: Painting & Printing
6.x
PC Windows ME/2000
: P2 (vote)
: 6.x
Assigned To: issues@editor
issues@editor
: UI
: 144715 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-20 04:28 UTC by waynezhang
Modified: 2012-01-25 16:45 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments
Jedit Rendered Text (36.61 KB, text/plain)
2008-08-20 04:34 UTC, waynezhang
Details
NetBeans 6.1 Rendered text (32.53 KB, text/plain)
2008-08-20 04:34 UTC, waynezhang
Details
Netbeans 6.5 rendered text (poor quality) (52.85 KB, text/plain)
2008-08-20 04:35 UTC, waynezhang
Details
NetBeans 6.1 aa option doesn't work (167.47 KB, mime/jpg)
2008-08-22 03:33 UTC, waynezhang
Details

Note You need to log in before you can comment on or make changes to this bug.
Description waynezhang 2008-08-20 04:28:10 UTC
Editor font render in 6.5 is different with version 6.1 and doesn't use the default Java 6 font render. The effect is poor. 

See screen shot.
Comment 1 waynezhang 2008-08-20 04:34:04 UTC
Created attachment 67898 [details]
Jedit Rendered Text
Comment 2 waynezhang 2008-08-20 04:34:48 UTC
Created attachment 67899 [details]
NetBeans 6.1 Rendered text
Comment 3 waynezhang 2008-08-20 04:35:28 UTC
Created attachment 67900 [details]
Netbeans 6.5 rendered text (poor quality)
Comment 4 Lukas Hasik 2008-08-20 13:55:31 UTC
decreasing priority and leaving for evaluation of experts
anyway, not P1 - http://wiki.netbeans.org/BugPriorityGuidelines

waynezhang, is it win2000 specific? 
Comment 5 waynezhang 2008-08-21 02:15:14 UTC
Don't know if it's a Win2k only issue, I have no WinXp/Vista at hand. But I am sure it's a 6.5 ONLY issue, because I use
same JDK and same font (Courier New 14) for all these 3 applications (NetBeans 6.5 beta, NetBeans 6.1 and JEdit).

JDK:
java version "1.6.0_10-rc"
Java(TM) SE Runtime Environment (build 1.6.0_10-rc-b28)
Comment 6 Stanislav Aubrecht 2008-08-21 11:06:15 UTC
editor guys, please evaluate
Comment 7 Vitezslav Stejskal 2008-08-21 14:46:20 UTC
Netbeans obviously use java runtime to render text on screen and nothing changed in that between 6.1 and 6.5. But the
problem here is that text on the screenshot from 6.1 is not anti-aliased while the text on the other screenshot from 6.5
is anti-aliased.

Now, in 6.1 there was a checkbox that allowed you to turn anti-aliasing on/off. In 6.5 there is no such checkbox and
Netbeans do what your JDK does by default. 

In JDK5 anti-aliasing is turned off by default comparing to JDK6 where it is on. You can explicitly control this by the
JDK switch -Dswing-aatext=<true|false>. Please add -J-Dswing-aatext=false to your <nb-inst>/etc/netbeans.conf and the
anti-aliasing should be turned off.

Perhaps we should resuscitate the checkbox somehow, see also #79453.
Comment 8 Vitezslav Stejskal 2008-08-21 14:51:14 UTC
*** Issue 144715 has been marked as a duplicate of this issue. ***
Comment 9 matthies 2008-08-21 15:08:20 UTC
Add my vote for bringing the checkbox back, if only to avoid having to figure out this setting again on each upgrade.

What I do wonder is why only the editor is affected, and not all text in the NetBeans UI. Shouldn't this be the same?

The native Windows behavior using standard font smoothing I believe is to NOT use font smoothing for a range of smaller 
text sizes when the font data contains corresponding hinting information, or something along these lines. For example 
Verdana and Lucida Console are anti-aliased only for sizes of 14pt and above. (This can be tried out in Notepad for 
example.) So maybe the JDK font rendering is to blame that it doesn't adopt this behavior, but in any case it would be 
appropriate for NetBeans to do something about this some way or other.
Comment 10 waynezhang 2008-08-22 03:32:38 UTC
Hi Vstejskal,
Yes, it will be fine if we have anti-alias option, and anti-alias should be turned on for editor by default, the effect
of anti-aliased text is not perfect in most cases.

-Dswing.aatext flag works for NetBeans 6.5 (I have only test -Dawt.usingSystemFontSettings=lcd and it doesn't work).
JEdit has option of anti-alias option and it's turned off by default. Even though NetBeans 6.1 has anti-alias option in
advanced options and it's turned on by default, but it does NOT affect the editor actually (see screen shot Netbeans 6.1
Anti-alias Option.jpg).

Regards,
Wayne
Comment 11 waynezhang 2008-08-22 03:33:48 UTC
Created attachment 68080 [details]
NetBeans 6.1 aa option doesn't work
Comment 12 Jan Becicka 2008-08-28 15:16:13 UTC
Duplicate of issue 137845?
Comment 13 matthies 2008-08-28 15:24:44 UTC
IMO it would be useful to turn this issue into an RFE for anti-aliasing settings in the Options. This is different from 
whether NetBeans picks up the environmental and/or OS settings correctly, and/or what the default should be, which is 
more what issue 137845 is about.
Comment 14 Vitezslav Stejskal 2008-09-01 09:58:29 UTC
I agree. If there are objections please turn it back to P3 defect. Thanks
Comment 15 Vitezslav Stejskal 2008-09-05 13:08:45 UTC
This is in fact the same as issue #79453, which requests adding options for anti-aliasing under editor font & color
profiles.

*** This issue has been marked as a duplicate of 79453 ***
Comment 16 Petr Somol 2012-01-25 16:45:49 UTC
Wiki page on anti-aliasing in NetBeans:
http://wiki.netbeans.org/FaqFontRendering


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo