Bug 144113 - Menu Window > Debugging > Debugging is confusing
Menu Window > Debugging > Debugging is confusing
Status: RESOLVED WONTFIX
Product: debugger
Classification: Unclassified
Component: Code
6.x
All All
: P2 (vote)
: 7.3
Assigned To: issues@debugger
issues@debugger
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-15 19:29 UTC by _ krystyna
Modified: 2013-01-11 19:56 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description _ krystyna 2008-08-15 19:29:17 UTC
NetBeans IDE Dev (Build 20080814114958)

P2 because of the visibility aspect.

From the top menu, go to  Window > Debugging > Debugging .
I know what the tab in project window does for the last selection of
Debugging -- it denotes the proejct server side -- but can we please have a different name? 

This is very confusing to have two menu items of the same name.
Comment 1 Petr Cyhelsky 2008-08-18 09:40:18 UTC
This is not a bug, because the name is what it was intended to be -> changing to RFE
Comment 2 Roman Ondruska 2008-08-18 10:22:51 UTC
Looking to the main menu, I am not sure that this is a real problem for a real user. When the submenu name is the same
as one of its items, it can be interpreted that this item is the 'main' one. This is what we probably want to say.

Anyway, if we think this is a problem, we can try to find a different name for this window either only used in main menu
(this is what profiler does) or used for both main menu and window tab (if short enough). My opinion is that this is not
worth doing.
Comment 3 jrojcek 2008-08-25 14:59:15 UTC
I don't think that using the same name for menu item as the name used for the parent menu is a problem. We use it for the top level - "Debug" and "Debug 
Project", or "Run" and "Run Project". 

OTOH, looking at the menu, "Debugging" seems strange as a name for a window. Window name should refer to a _thing_, like the other windows do, e.g. 
Watches, Variables, Stack, etc.. But "Debugging" is an activity. E.g. "Debugger" or "Program Counter" or "Call Stack", or some other name that denotes the 
function of the window would be better.
Comment 4 Martin Entlicher 2013-01-11 19:56:50 UTC
This does not seem to be a problem.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo