Bug 143856 - IDE hangs while switching to another document
IDE hangs while switching to another document
Status: RESOLVED DUPLICATE of bug 133236
Product: platform
Classification: Unclassified
Component: Text
6.x
All All
: P1 (vote)
: 6.x
Assigned To: mslama
issues@platform
: THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-14 05:22 UTC by Samaresh Panda
Modified: 2008-12-22 13:47 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
hung ide (166.26 KB, image/png)
2008-08-14 05:26 UTC, Samaresh Panda
Details
thread dumps (27.92 KB, text/plain)
2008-08-14 05:27 UTC, Samaresh Panda
Details
java project (157.57 KB, application/octet-stream)
2008-08-14 06:02 UTC, Samaresh Panda
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Samaresh Panda 2008-08-14 05:22:26 UTC
I had four documents open in the editor. I wanted to switch from one to the other and IDE hangs. See attached picture
and thread dump.
Comment 1 Samaresh Panda 2008-08-14 05:26:02 UTC
Created attachment 67356 [details]
hung ide
Comment 2 Samaresh Panda 2008-08-14 05:27:33 UTC
Created attachment 67357 [details]
thread dumps
Comment 3 Samaresh Panda 2008-08-14 05:29:30 UTC
I was switching from newXMLDocument1.xml to newXMLDocument_1.xml.
Comment 4 Samaresh Panda 2008-08-14 06:00:40 UTC
I have to admit that the file newXMLDocument_1.xml is pretty big. See attached project which contains these two files.
Comment 5 Samaresh Panda 2008-08-14 06:02:42 UTC
Created attachment 67363 [details]
java project
Comment 6 Samaresh Panda 2008-08-14 06:09:07 UTC
Windows Vista/JDK1.6.0_05.
Comment 7 Jan Lahoda 2008-08-14 07:50:14 UTC
There is a NPE in the dumps.txt that is possibly the cause. The AWT is waiting (forever?) somewhere in CloneableEditor.
Comment 8 mslama 2008-08-15 12:57:49 UTC
Please attach IDE log. Is it reproducible?
Comment 9 mslama 2008-08-15 13:12:55 UTC
It is already filed as #133236. It happens during IDE start when editor contains big XML or SQL file.

*** This issue has been marked as a duplicate of 133236 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo