Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 143830 - Keyboard quits working except for arrows which then only move the scrollbars in the editor
Keyboard quits working except for arrows which then only move the scrollbars ...
Status: RESOLVED DUPLICATE of bug 89893
Product: editor
Classification: Unclassified
Component: Settings
6.x
All Windows XP
: P4 (vote)
: 7.0
Assigned To: David Strupl
issues@editor
: RANDOM
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-13 23:08 UTC by _ wadechandler
Modified: 2010-10-21 15:19 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
One of my log files (211.00 KB, text/plain)
2008-09-24 17:22 UTC, _ wadechandler
Details
Another log file (152.96 KB, text/plain)
2008-09-24 17:22 UTC, _ wadechandler
Details
Latest log file from the last time I worked on this project (105.86 KB, text/plain)
2008-09-24 17:23 UTC, _ wadechandler
Details

Note You need to log in before you can comment on or make changes to this bug.
Description _ wadechandler 2008-08-13 23:08:44 UTC
This has been happening quite a bit with the latest daily. I will be using the editor and the keyboard will quit working
for the currently edited file. The only thing that works are the arrow keys, and they only move the scrollbars instead
of the cursor. The other opened files work fine. I have to close the file which is no longer working correctly and
reopen it. Doing this allows it to repair itself. I am not 100% sure what the cause is as I can't replicate this on
demand yet, but I am using two IDEs (JDeveloper 9i and NB 6.5 dailies) together on my current project. It could be
happening when editing in the other and switching back and forth, or it may be that this is happening on CTRL+F when
trying to search. I am also using freeform projects if that makes any difference (I thought I was using automatic
projects, but apparently I setup a freeform as I have a project properties dialog). I will try to watch better as I work
and see if I can come up with a pattern which will replicate the issue. So far I have only experienced this on Windows
as my current project is requiring it as I don't have JDeveloper 9i on Linux.
Comment 1 Jan Lahoda 2008-08-14 08:35:02 UTC
I doubt this would be specific to java.editor. More info will be likely necessary. May be related to issue #119617.
Comment 2 Vitezslav Stejskal 2008-08-18 10:32:16 UTC
Sounds like a problem in settings. From what you describe I would say that the keymap for the editor pane got reset for
some reason. It would be helpful to find a way how to reproduce this problem. In the meantime could you please attach
the IDE's log file - it's in <ide-userdir>/var/log/messages.log. Also, is this a standard Netbeans distribution (no
additional modules, especially jVi)? Thanks
Comment 3 Vitezslav Stejskal 2008-08-22 14:10:11 UTC
If you find steps how to reproduce this please attach them here. Also it might be useful to attach message.log and
uigestures files right after this happens (eg. close the IDE and attach the files here). Thanks
Comment 4 pribyl 2008-09-24 14:41:30 UTC
//closing unreproducible INCOMPLETE issues older than a month

wadechandler, any progress with this? Could you please attach logs, that vstejskal suggests? Or any other info that 
could help to solve this problem.

Feel free to reopen the issue then...

Thanks a lot
 
Comment 5 _ wadechandler 2008-09-24 17:05:55 UTC
Yes I'll try. The main problem is this only occurs on one project which I have wrapped up the active development. I'll
be getting back into it soon. I had almost forgotten the issue :-(. The issue seems related to updating files from
another IDE or program and then switching back to NB and then when it reloads the files or something like this.
Comment 6 _ wadechandler 2008-09-24 17:20:29 UTC
This is a standard NB daily build of NB 6.5 in which this was occurring, but I had installed auto projects from the
update center, and this is what I thought I was using, but there is a project properties dialog, so maybe I'm using a
free-form project? I also have JasperReports installed, and there are many different errors from Jasper in the log, but
the files which were causing the issues were Java files when I would attempt to fix an issue with a hint and at times
CTRL+F, but it seems that would happen after I had either CTRL+TAB to switch between files or had edited the files in an
external editor (JDeveloper 9i in this case). 

Anyways, I'm going to attach my log files in a couple minutes from another system, so I'm going ahead and reopening in
case you guys can find anything in them. I'll be getting back into the project which seemed to cause this soon, and with
this project I'm using Windows XP SP2. Not using this project, and using NB 6.5 dailies on my Linux machine has not
seemed to cause this issue.
Comment 7 _ wadechandler 2008-09-24 17:22:02 UTC
Created attachment 70498 [details]
One of my log files
Comment 8 _ wadechandler 2008-09-24 17:22:39 UTC
Created attachment 70499 [details]
Another log file
Comment 9 _ wadechandler 2008-09-24 17:23:20 UTC
Created attachment 70500 [details]
Latest log file from the last time I worked on this project
Comment 10 _ wadechandler 2008-09-24 17:24:39 UTC
I attached 3 log files. These are the only ones I have from the time I was last working on this project. Hopefully in
the next couple weeks I'll begin working on the project again.
Comment 11 Vitezslav Stejskal 2008-09-25 08:30:03 UTC
Thanks for the log files Wade. The first one seems to be the most interesting, even though it does not show anything in
particular related to editor settings (keybindings). I'm lowering it to P4 for now, but please make it P3 or even higher
if you find a way how to reproduce it. Thanks
Comment 12 _ wadechandler 2008-09-25 14:10:21 UTC
Will do. When I restart work on the next phase of my project I'm sure I'll be switching between the two IDEs again, so I
should be able from the beginning, versus near the end, start watching for the issue.

Thanks.
Comment 13 kiyut 2008-12-12 07:11:21 UTC
On linux and ubuntu

I encounter this bug long time ago when I was still using Netbeans 5.5
and found that gnome scim have problem (stealing the focus) with my
Netbeans usage. So just remove the scim and the problem gone. And now
on Ubuntu 8.04 and Netbeans 6.5, I never use/install scim again :)

So I suspect, it is related with some application eg: Input Methods Software, etc that compete/stealing the focus from
eg: Netbeans.

And it might happend in other platform (my case is Linux and Gnome) when similar application are trying to steal focus.
Comment 14 kiyut 2008-12-12 18:45:06 UTC
It seem it is not Netbeans specific bug, but it is Java Swing and Linux bug. Please see the Sun Java bug report for this
case http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6506617
Comment 15 _ wadechandler 2008-12-12 19:17:44 UTC
It was happening to me on XP. But, the main problem for NB is that it isn't affecting JDeveloper or IntelliJ as far as I
have seen or read. Of course as Eclipse uses SWT this particular bug doesn't affect it. But, it kills NB for those
running into it. Too, as it seems to only be affecting NB we need some workaround or something. Can't wait for Java 7
for those folks who can't use it or they can't use NB...lost users and bad word of mouth. It only manifested for me when
working in another IDE, JDeveloper, and switching back and forth between NB working on the same files, having them both
opened at the same time, and I'm not 100% sure why, and not near as much as it did for some of these folks. It has never
happened to me on openSuSE 10-11.
Comment 16 _ gtzabari 2009-05-11 22:33:29 UTC
Please see issue 164712. It is reproducible 100% of the time and I believe it is identical to this issue.

Comment 17 David Strupl 2010-10-21 15:19:32 UTC

*** This bug has been marked as a duplicate of bug 89893 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo