Bug 143813 - I18N - grails shell not appear for project with non ascii in name or path
I18N - grails shell not appear for project with non ascii in name or path
Status: RESOLVED INVALID
Product: groovy
Classification: Unclassified
Component: Grails
6.x
Sun Solaris
: P2 (vote)
: 6.x
Assigned To: martin_adamek
issues@groovy
: I18N
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-13 20:53 UTC by Ken Frank
Modified: 2008-10-30 14:25 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ken Frank 2008-08-13 20:53:38 UTC
for grails project that does have non ascii like multibyte in its project name
which is really also a path, grails shell is not created - there is this message
in output window
[Fatal Error] :6:38: Invalid byte 1 of 1-byte UTF-8 sequence.
XML parsing error configuring web.xml: Invalid byte 1 of 1-byte UTF-8 sequence.

which is a common error related to encoding that has been seen in past for other projects.

since grails project does not yet have encoding property, I don't know what encoding
is being used for it -- the default utf-8 encoding of other nb projects (until user might
change it to something else) or the encoding of the locale user is in
(I am in euc-jp ja locale on solaris)

PS I can't tell if execute script is working for groovy script named with
multibyte since when choose execute script, nothing happens; same happens
in en locale with no mbyte being used -- what is supposed to happen with
execute script action ?
Comment 1 Petr Jiricka 2008-09-22 13:49:53 UTC
I believe multibyte project names are not properly supported by Grails, which makes this issue not a bug.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo