Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 143661 - IDE unresponsive in expanding packages
IDE unresponsive in expanding packages
Status: RESOLVED WORKSFORME
Product: platform
Classification: Unclassified
Component: Explorer
6.x
All All
: P2 (vote)
: TBD
Assigned To: t_h
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-12 18:56 UTC by Samaresh Panda
Modified: 2008-12-22 13:41 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
few thread dumps (70.69 KB, text/plain)
2008-08-12 19:01 UTC, Samaresh Panda
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Samaresh Panda 2008-08-12 18:56:44 UTC
Using a fresh local build, I have a very simple Java App which has few packages. I started the IDE in debug mode. When I
expand nodes in project tab, IDE becomes very unresponsive. I see traces from openide.explorer. See attached dumps.
Comment 1 Samaresh Panda 2008-08-12 19:01:29 UTC
Created attachment 67162 [details]
few thread dumps
Comment 2 Samaresh Panda 2008-08-12 19:04:19 UTC
updatePasteAction in AWT thread is perhaps the problem.
Comment 3 t_h 2008-08-18 09:25:40 UTC
Can you attach project which causes the problems?
Comment 4 Samaresh Panda 2008-08-18 15:35:37 UTC
It was just a Java App, with very few java classes and a set of xml, schemas and dtd files. I do not have it now.
Comment 5 t_h 2008-08-18 17:21:00 UTC
Cannot reproduce
Comment 6 Samaresh Panda 2008-08-18 17:52:00 UTC
It may not be reproducible and that is why I attached the dump. Please do not make it incomplete as I do not have any
more input on this issue. This is basic as well as important to Netbeans and should be looked at carefully. You may want
to look into issue 143856 and issue 143861. They may be related.
Comment 7 t_h 2008-08-19 16:37:28 UTC
It seems FolderNode needed significant time to extract PasteTypes from contents of your clipboard. Do you know what you
had in the clipboard? Anyway, passing to openide.loaders for evaluation.
Comment 8 Jaroslav Tulach 2008-08-27 13:03:06 UTC
I really do not know how to speedup clipboard operations. The only thing I can suggest is to not block AWT thread 
while dealing with the clipboard. That would mean to replan the action update from AWT to some background thread in 
one of the following places:

at org.openide.explorer.ExplorerActionsImpl.updatePasteTypes(ExplorerActionsImpl.java:339)
at org.openide.explorer.ExplorerActionsImpl.updatePasteAction(ExplorerActionsImpl.java:329)
at org.openide.explorer.ExplorerActionsImpl.updateActions(ExplorerAction

I doubt anything better can be done outside of explorer.
Comment 9 t_h 2008-09-02 15:58:18 UTC
I am not sure if it is good idea to update action (or paste type) outside AWT thread. It would result in showing context
menu with disabled actions while another context click few second later on the same node would show the action enabled.
I think it is better to find out why PasteTypes extraction took so much time. Anyway, cannot reproduce, closing as works
for me. Please reopen with additional information how to reproduce.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo