Bug 143641 - NullPointerException at org.openoffice.extensions.util.ProjectTypeHelper.getObjectFromUnoProperties
NullPointerException at org.openoffice.extensions.util.ProjectTypeHelper.getO...
Status: RESOLVED WORKSFORME
Product: third-party
Classification: Unclassified
Component: -- Other --
6.x
All All
: P1 (vote)
: TBD
Assigned To: srg
issues@third-party
http://statistics.netbeans.org/except...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-12 17:58 UTC by Lukas Hasik
Modified: 2009-04-15 12:14 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lukas Hasik 2008-08-12 17:58:23 UTC
Build: NetBeans IDE 6.1 (Build 200804211638)
VM: Java HotSpot(TM) Client VM, 1.6.0-b105, Java(TM) SE Runtime Environment, 1.6.0-b105
OS: Windows Vista, 6.0, x86
User comments: 
What is up with right clicking in the projects pane???
STACKTRACE: (first 10 lines)
java.lang.NullPointerException
        at org.openoffice.extensions.util.ProjectTypeHelper.getObjectFromUnoProperties(ProjectTypeHelper.java:77)
        at org.openoffice.extensions.util.ProjectTypeHelper.isExtensionProject(ProjectTypeHelper.java:58)
        at org.openoffice.extensions.util.ProjectTypeHelper.isExtensionProject(ProjectTypeHelper.java:53)
        at org.openoffice.extensions.projecttemplates.actions.DebugAction.enable(DebugAction.java:80)
        at org.openoffice.extensions.projecttemplates.actions.DebugAction.access$000(DebugAction.java:66)
        at org.openoffice.extensions.projecttemplates.actions.DebugAction$ContextAction.<init>(DebugAction.java:149)
        at org.openoffice.extensions.projecttemplates.actions.DebugAction.createContextAwareInstance(DebugAction.java:74)
        at org.openide.util.Utilities.actionsToPopup(Utilities.java:2662)
        at org.openide.util.Utilities.actionsToPopup(Utilities.java:2754)
        at org.openide.explorer.view.TreeView.createPopup(TreeView.java:918)



this issue has 380 duplicates!
Comment 1 juergenschmidt 2008-08-21 08:12:29 UTC
jsc: i was on vacation, we will take care of it asap. 
Comment 2 juergenschmidt 2008-08-21 09:17:18 UTC
jsc -> srg: please take care of this issue. I thought we have solved this problem with 1.1.3 because i never got it when
i have tested this version.
Comment 3 juergenschmidt 2008-08-21 09:18:43 UTC
cc me
Comment 4 srg 2008-08-22 09:34:11 UTC
Which version of the plugin was it? We cannot reproduce this on Solaris - have to test it on Windows Vista.
Comment 5 Lukas Hasik 2008-09-09 09:38:51 UTC
hard to say which version. Most of the reports is from NB 6.1 - look at the URL
http://statistics.netbeans.org/exceptions/detail.do?id=56513
Comment 6 srg 2009-04-15 12:14:42 UTC
Cannot reproduce the issue with NetBeans 6.1 and the latest available plugin for OpenOffice.org (version 2.0.0). I used
Windows Vista x86 and Java JDK 1.6.0_13.
Everything works as expected. Since this bug only occurred in earlier versions of the plugin, I assume that a simple
update of the installed Netbeans plugins should fix this.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo