Bug 143494 - Import / export editor formatting settings
Import / export editor formatting settings
Status: RESOLVED FIXED
Product: editor
Classification: Unclassified
Component: Formatting & Indentation
6.x
All All
: P3 with 2 votes (vote)
: 7.3
Assigned To: Milutin Kristofic
issues@editor
: PLAN
: 193198 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-11 16:06 UTC by lilianne_blaze
Modified: 2012-09-29 02:46 UTC (History)
4 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description lilianne_blaze 2008-08-11 16:06:07 UTC
Please add an option to import / export all editor settings (especially Tools / Options / Editor / Formatting; maybe
other tabs in Editor options too?), preferably to a single .xml file.

Rationale: 1) it would make working with multiple ide versions and/or multiple workstations much easier. 2) It would
make frequent re-installing (especially important to people developing NB and / or simply testing nightlies) clean or
semi-clean easier. 3) It would make working in a team with set code formatting conventions much easier, team leader
could simply export his/her settings and mail them to other team members.

Yes, there is Project / Properties / Formatting / Use project specific settings options, but it doesn't apply to all
possible scenarios. On the other hand, it would probably be easy to reuse most of this functionality code for full
import / export.
Comment 1 Vitezslav Stejskal 2008-08-13 16:52:54 UTC
Thanks for this RFE. Exporting/Importing formatting settings would certainly be very useful. Please see also issue
#75875, issue #99494, issue #11848.
Comment 2 alied 2012-04-25 19:34:16 UTC
Yes, and I would add to export/import formatting/style setting in checkstyle format, so (as it is my case) it is easier for a Netbeans user to share style settings with other team members that use Eclipse or InteliJ.
Comment 3 Milutin Kristofic 2012-07-17 15:25:24 UTC
*** Bug 193198 has been marked as a duplicate of this bug. ***
Comment 4 Milutin Kristofic 2012-08-22 13:43:14 UTC
alied: Is it really possible to import checkstyle config to eclipse or idea formatting? They haven't even got native checkstyle checking.
Comment 5 Milutin Kristofic 2012-08-28 15:40:22 UTC
I add Formatting/indentation and Formatting/java to export, import options.

http://hg.netbeans.org/jet-main/rev/666365fdfff9
http://hg.netbeans.org/jet-main/rev/6546c0d3cec2
Comment 6 Quality Engineering 2012-08-29 02:43:01 UTC
Integrated into 'main-golden', will be available in build *201208290001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/666365fdfff9
User: Milutin Kristofic <mkristofic@netbeans.org>
Log: #143494 - Import / export editor formatting settings
Comment 7 zachsaw 2012-09-29 02:41:28 UTC
Is this still not possible with CND? I'm trying build 20120926001 and found no options to export C/C++ and C/C++ Headers formatting settings.

This is especially annoying when upgrading IDEs. I have to change the settings to my liking every time.
Comment 8 zachsaw 2012-09-29 02:46:35 UTC
Why is this marked as resolved / fixed when it has only been resolved for Java?
What about other languages?


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo