Bug 14333 - Filesystems lost after Project Rename
Filesystems lost after Project Rename
Status: CLOSED FIXED
Product: projects
Classification: Unclassified
Component: Generic Infrastructure
3.x
PC Windows ME/2000
: P1 (vote)
: 3.x
Assigned To: Vitezslav Stejskal
issues@projects
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-10 13:34 UTC by Jan Chalupa
Modified: 2003-07-01 14:17 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Chalupa 2001-08-10 13:34:50 UTC
[200108100740; Sun JDK 1.3.1; MDI]

Steps to reproduce:

1. Start with an empty userdir
2. Mount a couple of filesystems open some files in the editor
3. Go to Project | Project Manager...
4. Select Rename... and change the name of the project
5. All filesystems are unmounted, editor window is closed
6. Go to Filesystems | Customize and Tools | Options | Filesystems to see that 
the filesystems are really lost
7. Exit the IDE -> Cannot save settings message is displayed
8. Restart -> the filesystems are back

This may be related to issue #14331.
Comment 1 Jaroslav Tulach 2001-08-16 08:43:16 UTC
You or Vita?
Comment 2 Vitezslav Stejskal 2001-08-16 09:31:06 UTC
It's mine ;-)
Comment 3 Vitezslav Stejskal 2001-08-16 12:02:59 UTC
Resolved in main trunk. Rename of active project is now supported.
Comment 4 Milan Kubec 2002-01-17 11:37:11 UTC
Verified in release33-200201170331.
Comment 5 Quality Engineering 2003-07-01 14:17:08 UTC
Resolved for 3.4.x or earlier, no new info since then -> closing.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo