Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 143214 - Mercurial, Palette etc. do not persist view position
Mercurial, Palette etc. do not persist view position
Status: RESOLVED WONTFIX
Product: platform
Classification: Unclassified
Component: Window System
6.x
All All
: P2 (vote)
: 6.x
Assigned To: David Simonek
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-07 18:40 UTC by _ alexlamsl
Modified: 2008-12-22 13:34 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description _ alexlamsl 2008-08-07 18:40:43 UTC
Steps to reproduce:
1) Open concerned panel (e.g. "Status" for a Mercurial-managed project)
2) Unpin it onto a said location (e.g. bottom bar)
3) Close IDE
4) Start IDE - the panel will resume with its default display position.

Panels which are observed with such behaviour so far:
Versioning --> Mercurial
Palette
Properties



Product Version: NetBeans IDE Dev (Build 200808021401)
Java: 1.6.0_07; Java HotSpot(TM) Client VM 10.0-b23
System: Windows XP version 5.1 running on x86; Cp1252; en_GB (nb)
Comment 1 Lukas Hasik 2008-08-08 11:29:48 UTC
afaik, it is up to the tab provider to say if the tab is persistent or not.

-Properties works for me correctly. If I change the window position, restart then it is correctly in the new position.
-Versioning --> Mercurial -> seems to be not persistent
-palette - moves itself into right after restart

Windows guys, could you comment on? This issue should be splitted into more however I'm not sure what is bug and what is
feature ;)
Comment 2 Stanislav Aubrecht 2008-08-08 11:40:59 UTC
the palette issue is a bug, mercurial window probably as well.
i suggest splitting this into two separate issues
Comment 3 David Simonek 2008-08-08 12:04:55 UTC
I agree - one issue to Mercurial to set some level of persistency (TopComponent.PERSISTENCE_ONLY_OPENED or
PERSISTENCE_ALWAYS)

Second issue I don't know if belongs directly to Palette or if it's more general winsys problem.
Comment 4 Lukas Hasik 2008-08-08 14:47:21 UTC
I filled separate issue for Mercurial and Palette - 143301 143300 

closing this one as won'tfix. The issues will be tracked separately.
Thank you

If you'll discover some other components that are not persistent fill new issue to particular component


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo