Bug 143153 - NullPointerException at org.nbheaven.sqe.core.ant.AntUtilities.sqeProperties
NullPointerException at org.nbheaven.sqe.core.ant.AntUtilities.sqeProperties
Status: RESOLVED FIXED
Product: third-party
Classification: Unclassified
Component: sqe tools
6.x
All All
: P1 with 1 vote (vote)
: 6.x
Assigned To: sreimers
sreimers
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT
:
: 150424 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-07 10:23 UTC by tkellerer
Modified: 2009-09-29 00:44 UTC (History)
16 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (3.13 KB, text/plain)
2008-08-07 10:23 UTC, tkellerer
Details
stacktrace (31 bytes, text/plain)
2008-09-03 14:39 UTC, ouertani
Details
stacktrace (31 bytes, text/plain)
2008-12-02 15:02 UTC, mohhmekk
Details
stacktrace (3.17 KB, text/plain)
2008-12-15 13:36 UTC, mohhmekk
Details
stacktrace (2.87 KB, text/plain)
2008-12-18 12:20 UTC, mohhmekk
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tkellerer 2008-08-07 10:23:11 UTC
Build: NetBeans IDE Dev (Build 200808060201)
VM: Java HotSpot(TM) Client VM, 11.0-b11, Java(TM) SE Runtime Environment, 1.6.0_10-beta-b21
OS: Windows XP, 5.1, x86

User Comments: 
Trying to use the SQE plugin with NB 6.5

Stacktrace: 
java.lang.NullPointerException
        at org.nbheaven.sqe.core.ant.AntUtilities.sqeProperties(AntUtilities.java:52)
        at org.nbheaven.sqe.core.ant.AntUtilities.getSQEProperties(AntUtilities.java:64)
        at org.nbheaven.sqe.codedefects.core.util.SQECodedefectProperties.isQualityProviderActive(SQECodedefectProperties.java:57)
        at org.nbheaven.sqe.codedefects.resultui.action.RunSQEAction.enable(RunSQEAction.java:95)
        at org.openide.util.actions.NodeAction.isEnabled(NodeAction.java:202)
        at org.openide.awt.Actions$MenuBridge.updateState(Actions.java:952)
Comment 1 tkellerer 2008-08-07 10:23:22 UTC
Created attachment 66771 [details]
stacktrace
Comment 2 Lukas Hasik 2008-08-07 10:32:02 UTC
the NPE is from 3rd party module org.nbheaven.sqe.core.ant.AntUtilities.sqeProperties(AntUtilities.java:52)
please, report directly to the module authors
Comment 3 ouertani 2008-09-03 14:39:40 UTC
Build: NetBeans IDE 6.5 Beta (Build 200808111757)
VM: Java HotSpot(TM) Client VM, 11.0-b15, Java(TM) SE Runtime Environment, 1.6.0_10-rc-b28
OS: Linux, 2.6.24-21-generic, i386

User Comments: 


Stacktrace: 
java.lang.NullPointerException
Comment 4 ouertani 2008-09-03 14:39:43 UTC
Created attachment 68951 [details]
stacktrace
Comment 5 Peter Pis 2008-10-16 19:59:24 UTC
*** Issue 150424 has been marked as a duplicate of this issue. ***
Comment 6 Lukas Hasik 2008-11-23 20:43:28 UTC
reassigning to sqe-tools subcomponent
Comment 7 mohhmekk 2008-12-02 15:02:06 UTC
Build: NetBeans IDE 6.5 (Build 200811100001)
VM: Java HotSpot(TM) Client VM, 11.0-b15, Java(TM) SE Runtime Environment, 1.6.0_10-b33
OS: Linux, 2.6.27-9-generic, i386

User Comments: 
downloading maven dependencies

Stacktrace: 
java.lang.NullPointerException
        at org.nbheaven.sqe.core.ant.AntUtilities.sqeProperties(AntUtilities.java:52)
        at org.nbheaven.sqe.core.ant.AntUtilities.getSQEProperties(AntUtilities.java:64)
        at org.nbheaven.sqe.codedefects.core.util.SQECodedefectProperties.isQualityProviderActive(SQECodedefectProperties.java:57)
        at org.nbheaven.sqe.codedefects.resultui.action.RunSQEAction.enable(RunSQEAction.java:95)
        at org.openide.util.actions.NodeAction.isEnabled(NodeAction.java:202)
        at org.openide.awt.Actions$MenuBridge.updateState(Actions.java:952)
Comment 8 mohhmekk 2008-12-02 15:02:26 UTC
Created attachment 74421 [details]
stacktrace
Comment 9 mohhmekk 2008-12-15 13:36:31 UTC
Build: NetBeans IDE 6.5 (Build 200811100001)
VM: Java HotSpot(TM) Client VM, 11.0-b16, Java(TM) SE Runtime Environment, 1.6.0_11-b03
OS: Linux, 2.6.27-9-generic, i386

User Comments: 


Stacktrace: 
java.lang.NullPointerException
        at org.nbheaven.sqe.core.ant.AntUtilities.sqeProperties(AntUtilities.java:52)
        at org.nbheaven.sqe.core.ant.AntUtilities.getSQEProperties(AntUtilities.java:64)
        at org.nbheaven.sqe.codedefects.core.util.SQECodedefectProperties.isQualityProviderAnnotateActive(SQECodedefectProperties.java:75)
        at org.nbheaven.sqe.codedefects.resultui.action.AbstractShowAnnotationsAction$ToggleButtonModel.propertyChange(AbstractShowAnnotationsAction.java:103)
        at org.nbheaven.sqe.codedefects.resultui.action.AbstractShowAnnotationsAction$ToggleButtonModel.<init>(AbstractShowAnnotationsAction.java:97)
        at org.nbheaven.sqe.codedefects.resultui.action.AbstractShowAnnotationsAction.getToolbarPresenter(AbstractShowAnnotationsAction.java:73)
Comment 10 mohhmekk 2008-12-15 13:36:35 UTC
Created attachment 74965 [details]
stacktrace
Comment 11 mohhmekk 2008-12-18 12:20:31 UTC
Build: NetBeans IDE 6.5 (Build 200811100001)
VM: Java HotSpot(TM) Client VM, 11.0-b16, Java(TM) SE Runtime Environment, 1.6.0_11-b03
OS: Linux, 2.6.27-9-generic, i386

User Comments: 


Stacktrace: 
java.lang.NullPointerException
        at org.nbheaven.sqe.core.ant.AntUtilities.sqeProperties(AntUtilities.java:52)
        at org.nbheaven.sqe.core.ant.AntUtilities.getSQEProperties(AntUtilities.java:64)
        at org.nbheaven.sqe.codedefects.core.util.SQECodedefectProperties.isQualityProviderAnnotateActive(SQECodedefectProperties.java:75)
        at org.nbheaven.sqe.codedefects.resultui.action.AbstractShowAnnotationsAction$ToggleButtonModel.propertyChange(AbstractShowAnnotationsAction.java:103)
        at org.nbheaven.sqe.codedefects.resultui.action.AbstractShowAnnotationsAction$ToggleButtonModel.<init>(AbstractShowAnnotationsAction.java:97)
        at org.nbheaven.sqe.codedefects.resultui.action.AbstractShowAnnotationsAction.getToolbarPresenter(AbstractShowAnnotationsAction.java:73)
Comment 12 mohhmekk 2008-12-18 12:20:40 UTC
Created attachment 75128 [details]
stacktrace
Comment 13 Exceptions Reporter 2009-04-06 17:35:31 UTC
This issue has already 100 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=54068
Comment 14 alanbur 2009-04-06 20:16:59 UTC
This bug has had over 100 duplicate exceptions and has been untouched for 8 months.  Added to the other SQE bugs e.g.
PMD and FindBugs settings being ignored, it makes the SQE plugin virtually useless.  Projects offered via the NetBeans
Plugin Centre should meet minimum quality standards, standards that this plugin clearly does *not* meet.  In addition,
the 8 months of silence on this issue makes it clear that this project is dead

I'm therefore requesting that it be removed from the NetBeans Update centre.  
Comment 15 sreimers 2009-04-06 20:30:25 UTC
Some comments:

1. SQE is not served via NetBeans Update Center. It is offered via its own update center.
2. This project is not DEAD, I just have to work for a living!
3. Newer binary releases are available, but they are even more experimental.
4. A new release is being prepared addressing a lot of issues that are actually filed for SQE.
5. Please be gentle. 
Comment 16 alanbur 2009-04-06 22:56:13 UTC
The SQE Update Centre appears as an install option in the standard module list, which then allows you to install the
broken SQE modules.  Until SQE is usable, it should be removed.  That's not 'forever' but until it is usable it
shouldn't be in the standard mosule list, even if indirectly.
Comment 17 Jesse Glick 2009-08-24 23:42:34 UTC
The 6.7 update will not have this code any more.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo