Bug 143001 - [65cat] Deadlock when changing project.xml by hand in freeform project
[65cat] Deadlock when changing project.xml by hand in freeform project
Status: RESOLVED FIXED
Product: projects
Classification: Unclassified
Component: Ant Freeform
6.x
PC Windows XP
: P1 (vote)
: 6.x
Assigned To: Milan Kubec
issues@projects
: RANDOM, THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-06 07:17 UTC by misterm
Modified: 2008-08-06 15:59 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Thread dump (37.58 KB, text/plain)
2008-08-06 07:19 UTC, misterm
Details

Note You need to log in before you can comment on or make changes to this bug.
Description misterm 2008-08-06 07:17:31 UTC
[ BUILD # : 200808051401 ]
[ JDK VERSION : 1.6.0_04 ]

Here is what I did:

1. A project had references to old jars (x-3.0.jar) that had been
replaced (x-3.1.jar);
2. The project had three source roots with two independent
classpaths;
3. I tried to fix it by hand, doing a replace, since it would be (in
theory) much simpler than using GUI;
4. No other changes have been accidentally made, like breaking some
schema URL due to the replace operation;
5. When I save the file, the IDE hangs.
Comment 1 misterm 2008-08-06 07:19:05 UTC
Created attachment 66642 [details]
Thread dump
Comment 2 Milos Kleint 2008-08-06 08:05:41 UTC
->freeform
Comment 3 misterm 2008-08-06 08:16:50 UTC
Changing back to P1 according to this:

http://wiki.netbeans.org/BugPriorityGuidelines

" crash or deadlock 	 Reproducible, unavoidable crash or deadlock"
Comment 4 Milan Kubec 2008-08-06 12:42:50 UTC
Fixed.

http://hg.netbeans.org/main/rev/aebc06110af3
Comment 5 Quality Engineering 2008-08-06 15:59:45 UTC
Integrated into 'main-golden', available in build *200808061401* on http://bits.netbeans.org/dev/nightly/
Changeset: http://hg.netbeans.org/main/rev/aebc06110af3
User: Milan Kubec <mkubec@netbeans.org>
Log: #143001: possible deadlock when saving freeform project.xml


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo