Bug 142775 - Carret blinking in quicksearch and editor at once
Carret blinking in quicksearch and editor at once
Status: RESOLVED DUPLICATE of bug 90371
Product: platform
Classification: Unclassified
Component: Quick Search
6.x
All Mac OS X
: P3 (vote)
: 6.x
Assigned To: David Simonek
issues@platform
: FOCUS
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-04 11:37 UTC by Jaromir Uhrik
Modified: 2009-05-11 10:49 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Screenshot attached... (116.28 KB, image/png)
2008-08-04 11:38 UTC, Jaromir Uhrik
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jaromir Uhrik 2008-08-04 11:37:42 UTC
Product Version: NetBeans IDE Dev (Build 200808040201)
Java: 1.5.0_13; Java HotSpot(TM) Client VM 1.5.0_13-119
System: Mac OS X version 10.5.4 running on i386; MacRoman; en_US (nb)

Steps to reproduce:
==================
-push Cmd+I to focus quicksearch
-type "plu" and the Actions | Plugins followed by other items is recommended by the quicksearch 
-push escape
-->> The carret is blinking in quicksearch and in editor together so that user has ambiguous information where the focus
is (see attached screenshot). In fact the focus is moved to editor so that when a user wants to delete "plu" from the
quicksearch then the change in editor is made instead.
Comment 1 Jaromir Uhrik 2008-08-04 11:38:46 UTC
Created attachment 66463 [details]
Screenshot attached...
Comment 2 David Simonek 2008-09-01 13:35:30 UTC
I don't know solution to this problem, it seems to be Apple's JDK impl speciality. On Esc handling, I just pass focus to
last selected TopComponent before. No idea what could I do further, sorry. Is it possible to get rid of this state
somehow? Does it happen always (100% reproducible)?
Comment 3 Jaromir Uhrik 2008-09-22 13:31:15 UTC
It is 100% reproducible. The only way I can get rid of blinking caret in quick search is to click there and then click
to e.g. editor pane.
Comment 4 medmunds 2009-03-18 02:45:35 UTC
This is probably related to the underlying problem in #90371, where the blinking cursor is visible in the editor even when keyboard focus is in some other 
view. Discussion in that issue (and a whole chain of duplicates) leans heavily toward a problem in the OS X JDK.
Comment 5 Jaromir Uhrik 2009-05-11 10:49:37 UTC
Yes the cause seems to be the same. I am marking this issue as duplicate of 90371.

*** This issue has been marked as a duplicate of 90371 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo