Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 142711 - Improving code folding API
Improving code folding API
Status: RESOLVED DUPLICATE of bug 127886
Product: editor
Classification: Unclassified
Component: Code folding
6.x
All All
: P3 (vote)
: TBD
Assigned To: Svata Dedic
issues@editor
: API
: 128995 (view as bug list)
Depends on: 226413
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-03 13:51 UTC by Petr Pisl
Modified: 2013-02-20 15:52 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Pisl 2008-08-03 13:51:43 UTC
1) There are not constants for group of code folding. So client has to know exact string to provide the code folding.
There are four groups of code folding in gsf: codeblocks, comments, initial-comment and imports

2) There is missing group for classes and interfaces.

3) The client should be able to overwrite the default fold template for a group.
Comment 1 Petr Pisl 2008-08-03 13:55:29 UTC
Also see issue #142425, where is not possible map fold categories to the editor option. 
Comment 2 David Strupl 2009-01-14 14:35:33 UTC
Moving from ruby/GSF to editor/CSL. Step one: assign to myself ;-)
Comment 3 David Strupl 2009-01-14 14:43:18 UTC
Step 2: trying to make the owner not myself but the owner of the subcomponent.
Comment 4 David Strupl 2009-05-04 12:06:17 UTC
This is ENH. I was tempted to close it as wontfix but let's leave it opened as ENH for now.
Comment 5 Marek Fukala 2009-11-30 10:16:31 UTC
Another quite important functionality is to be able to pass a code fold name by the CSL client. For example in HTML the fold description should contain the tag name itself, not just some "category" name like "...". The html editor folding had to regress when migrated to CSL because of this.
Comment 6 Svata Dedic 2012-06-07 07:59:53 UTC
*** Bug 128995 has been marked as a duplicate of this bug. ***
Comment 7 Svata Dedic 2012-12-11 15:34:16 UTC
Filed again, keeping the newer one

*** This bug has been marked as a duplicate of bug 127886 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo