Bug 142600 - I18N - can't import into repository if comment has multibyte
I18N - can't import into repository if comment has multibyte
Status: RESOLVED DUPLICATE of bug 117107
Product: versioncontrol
Classification: Unclassified
Component: Subversion
6.x
Sun Solaris
: P2 (vote)
: TBD
Assigned To: issues@versioncontrol
issues@versioncontrol
: I18N
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-01 16:20 UTC by Ken Frank
Modified: 2008-08-01 19:34 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ken Frank 2008-08-01 16:20:31 UTC
this happens on solaris, not windows.
in past if commit comment had multibyte there was a similar issue
but not on import

1. running in solaris ja or ja_JP.UTF-8 locales

2. project encoding is utf-8 or euc-jp, happens in both cases

3. choose to import a project into svn repos and asks for comment.

4. use asian characters in the comment.

5. the error popup appears

6. also output window shows:

==[IDE]== 2008/08/01 8:11:57 と粮Jon粮Connecting to Subversion Repository...粤ろ
info -r HEAD file:///home/kenf/mysvn@HEAD --config-dir /net/machine/export/home2/ken/cdpg/0730utfja/config/svn/config
--non-interactive

==[IDE]== 2008/08/01 8:11:57 と粮Jon粮Connecting to Subversion Repository...粤ろ と粮Jon粮finished.粤ろ
==[IDE]== 2008/08/01 8:12:03 と粮Jon粮Importing...粤ろ
import /var/tmp/svn_dummy/JavaApplication30 file:///home/user/mysvn/JavaApplication30 -N --force-log -F
/var/tmp/svn_54372 --config-dir /net/machine/export/home2/ken/cdpg/0730utfja/config/svn/config --non-interactive
svn: Non-ASCII character (code 227) detected, and unable to convert to/from UTF-8

==[IDE]== 2008/08/01 8:17:39 と粮Jon粮Importing...粤ろ と粮Jon粮finished.粤ろ


7. please provide command line statement to use about this so can see if happens
on command line also, using same project and locales.

8. svn used is one from solaris freeware, the collabnet subversion.
Comment 1 Tomas Stupka 2008-08-01 19:34:49 UTC
this sounds familiar - see issue #117107 
- it's also related to problems with importing a project on solaris
- in case you have problems with multibytes it doesn't matter if you make an import or commit from the ide. It will fail
in both cases

the following text comes from a mail sent to me on 10/9/2008 and was related to 117107
"I got somewhere a pkg called
subversion-1.4.4-sol10-sparc-local
but it did not install ok and were  unresolved ld lib paths"

so if you have dependency problems with your svn client than that could by also cause for the reported problem. Are you
sure your setup is correct this time?

> 7. please provide command line statement to use about this so can see if happens
> on command line also, using same project and locales.
its in the output you posted - see the line starting with import, just add svn before it. something like
svn import /var/tmp/svn_dummy/JavaApplication30 ...

the file /var/tmp/svn_54372 is temporarily created for each cmd so reproduce the probem, do not stop netbeans, copy the
line from output to the cli and add svn before it

> 8. svn used is one from solaris freeware, the collabnet subversion.
what version

attach messages.log to the issue in case it should work for you from cli

reproduce the issue, 



cheers

*** This issue has been marked as a duplicate of 117107 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo