Bug 142106 - [65cat] Find highlighting
[65cat] Find highlighting
Status: RESOLVED WONTFIX
Product: editor
Classification: Unclassified
Component: Search
6.x
PC Linux
: P4 (vote)
: TBD
Assigned To: Milutin Kristofic
issues@editor
: FOCUS
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-29 17:40 UTC by Unknown
Modified: 2016-07-07 07:27 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Unknown 2008-07-29 17:40:55 UTC
[ BUILD # : 200807280848 ]
[ JDK VERSION : 1.6.0_07 ]

Is this by design?
1) undock a window
2) set the focus back into the docked window
3) use ctrl+f to start a "find"
4) highlights show up in both the docked and undocked window.
Comment 1 Jan Becicka 2008-07-30 14:38:08 UTC
This is minor bug.
Comment 2 David Strupl 2010-09-24 07:42:14 UTC
The bug is still present - marking it for inclusion in the next version.
Comment 3 Milutin Kristofic 2011-09-07 08:41:56 UTC
It's still in 7.1. You open searchbar and is highlighting in two windows at once (on in dock and one in float window)
Comment 4 peterkehl 2013-11-05 23:49:36 UTC
I believe this has been resolved (I can't replicate the behaviour in 7.4 neither in today's trunk). I'm leaving the status as NEW, just so that you can verify it.

However, I have a more general question about the design of Find functionality. I have a need that is opposite to the above issue.

I would find it beneficial to be able to search in multiple editor windows at the same time (whether for the same pattern, or different - as you choose), and to have the found terms highlighted in each window (where I used Find feature). 

Basically, I'd like the 'Find' minidialog (at the bottom of the source edit window) and the highlighting to stay active, even if I switch the focus/input to a different source (or other type) window in NetBeans. I think that would increase user's navigation in source code, especially when looking at functions/variables/symbols used in
- two or several files, or
- two or more locations in the same long file

I'm not opening an issue for that yet, because I wonder whether it would fit in your overall idea of IDE.
Comment 5 peterkehl 2014-05-06 11:16:06 UTC
I've reported what I've described above as https://netbeans.org/bugzilla/show_bug.cgi?id=244329
Comment 6 Martin Balin 2016-07-07 07:27:07 UTC
This old bug may not be relevant anymore. If you can still reproduce it in 8.2 development builds please reopen this issue.

Thanks for your cooperation,
NetBeans IDE 8.2 Release Boss


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo