Bug 142014 - [65cat] Displaying the field type
[65cat] Displaying the field type
Status: RESOLVED FIXED
Product: db
Classification: Unclassified
Component: Code
6.x
PC Windows XP
: P2 (vote)
: 7.2
Assigned To: Jiri Rechtacek
issues@db
:
: 63708 134214 154169 (view as bug list)
Depends on:
Blocks: 152818
  Show dependency treegraph
 
Reported: 2008-07-29 10:15 UTC by yudiset
Modified: 2012-02-10 16:41 UTC (History)
4 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments
A sample of field info next to the fieldname (38.42 KB, image/jpeg)
2008-07-29 10:17 UTC, yudiset
Details
Patch für Column Properties (14.83 KB, patch)
2011-10-27 21:14 UTC, matthias42
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description yudiset 2008-07-29 10:15:33 UTC
[ BUILD # : 200807290015 ]
[ JDK VERSION : 1.6.0_07 ]

It would be great if in the Database Explorer, we can see the info
about field type, length, null (or not null), index of each field
when we access a table.

For example: id [char(2), not null]
This way, we can see all of the type & length of the fields of a
table straight away.

At the moment, we have to right click on each field and go to the
Properties menu.
Comment 1 yudiset 2008-07-29 10:17:16 UTC
Created attachment 65916 [details]
A sample of field info next to the fieldname
Comment 2 David Vancouvering 2008-07-29 17:13:27 UTC
Yes, I think this would be a very useful enhancement.
Comment 3 _ ahimanikya 2008-07-29 17:38:07 UTC
DataView shows column info when user hover on column header, may be we could do this similar style to be consistent. 
Comment 4 Jiri Rechtacek 2009-10-16 14:15:57 UTC
Reassigned to new owner.
Comment 5 matthias42 2011-10-27 21:14:28 UTC
Created attachment 112511 [details]
Patch für Column Properties

The attached patch implements the idea from comment #3
Comment 6 matthias42 2011-10-27 21:18:48 UTC
*** Bug 63708 has been marked as a duplicate of this bug. ***
Comment 7 matthias42 2011-10-27 21:25:24 UTC
*** Bug 154169 has been marked as a duplicate of this bug. ***
Comment 8 matthias42 2011-11-06 21:28:16 UTC
*** Bug 134214 has been marked as a duplicate of this bug. ***
Comment 9 Jiri Rechtacek 2012-02-10 16:41:46 UTC
the patch was applied in core-main/rev/65ac1f0ea1e4


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo