Bug 141610 - Schema file missed in Select Element or Type dialog
Schema file missed in Select Element or Type dialog
Status: VERIFIED FIXED
Product: xml
Classification: Unclassified
Component: WSDL Tools
6.x
All All
: P1 (vote)
: TBD
Assigned To: Shivanand Kini
issues@xml
: TEST
: 142687 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-24 21:04 UTC by Ivan Sidorkin
Modified: 2008-08-08 09:58 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
screen shot (46.30 KB, image/png)
2008-07-24 21:07 UTC, Ivan Sidorkin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ivan Sidorkin 2008-07-24 21:04:35 UTC
last two days reproduced on deadlock
rarely reproduced on manual tests run

test scenario:
- create two xml schemes with some elements
- open New WSDL Document wizard
- click next
- open Select Element or Type for Input
- select some element from created schema
- open Select Element or Type for Output
- select some element from created schema

sometime Select Element or Type dialog do not contain schema files (see attached screen shot)
Comment 1 Ivan Sidorkin 2008-07-24 21:07:22 UTC
Created attachment 65585 [details]
screen shot
Comment 2 Lukas Hasik 2008-07-25 15:32:19 UTC
P1 -> it blocks production build
Comment 3 tonybeckham 2008-07-25 18:24:35 UTC
I cannot reproduce locally either.

Product Version: NetBeans IDE Dev (Build 200807240010)
Java: 1.6.0_05; Java HotSpot(TM) 64-Bit Server VM 1.6.0_05-b13-52
System: Mac OS X version 10.5.4 running on x86_64; MacRoman; en_US (nb)
Comment 4 Shivanand Kini 2008-07-25 18:53:17 UTC
Can you attach the project? Does the schema have targetnamespace defined?
Comment 5 Shivanand Kini 2008-07-29 20:20:34 UTC
No input from reporter. Could not produce manually.
Comment 6 Ivan Sidorkin 2008-08-01 21:33:15 UTC
failed again
http://deadlock.netbeans.org/hudson/job/trunk/3189/testReport/
Comment 7 Shivanand Kini 2008-08-01 23:50:37 UTC
I am not sure how to reproduce this. 

The next build passed and tests ran fine.
Comment 8 Ivan Sidorkin 2008-08-02 00:10:32 UTC
but it reproduced time to time on deadlock
so it is problem in xml module.
test works fine. you can see that 2 schema files exists but not presented under AcceptanceTestProject
Comment 9 Shivanand Kini 2008-08-02 00:21:54 UTC
can you attach the test project to this issue?

Comment 10 Ivan Sidorkin 2008-08-02 00:29:56 UTC
unfortunately it is hard to get it from deadlock
Comment 11 Ivan Sidorkin 2008-08-04 08:58:37 UTC
*** Issue 142687 has been marked as a duplicate of this issue. ***
Comment 12 Ivan Sidorkin 2008-08-04 09:03:28 UTC
this issue often reproduced on my machine when I run c/v tests 
try to run it few times and you will get project, full messages.log etc.

ant -Dtest.config=uicommit test
in soa.kit folder
(also remove build/test folder between runs )
Comment 13 Jan Lahoda 2008-08-04 09:05:49 UTC
Sorry, but the tests failed (apparently randomly) several times during the weekend. See issue #142687 for more details.
Please either fix the code, fix the tests or disable the tests. Thanks.
Comment 14 Shivanand Kini 2008-08-04 18:55:06 UTC
thanks, I am able to reproduce with ant -Dtest.config=uicommit test
Comment 15 Shivanand Kini 2008-08-04 23:13:53 UTC
Can this test be disabled till this issue is resolved?
Comment 16 Ivan Sidorkin 2008-08-04 23:23:21 UTC
yes, I will disable it
Comment 17 Shivanand Kini 2008-08-05 01:46:25 UTC
Fixed 
Changeset:
http://hg.netbeans.org/main/rev/0ea6e0eeab13

Reenabled test cases:
http://hg.netbeans.org/main/rev/d79bfd0fa75d
Comment 18 Quality Engineering 2008-08-05 16:36:00 UTC
Integrated into 'main-golden', available in build *200808051401* on http://bits.netbeans.org/dev/nightly/
Changeset: http://hg.netbeans.org/main/rev/8b51121085d9
User: Ivan Sidorkin <ivansidorkin@netbeans.org>
Log: disable two test until #141610 will be fixed
Comment 19 Ivan Sidorkin 2008-08-08 09:58:47 UTC
not reproducible for few days
looks like fixed


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo