Bug 141578 - NullPointerException at org.netbeans.modules.j2ee.ejbcore.ui.logicalview.ejb.action.AddBusinessMethodStrategy.createDialog
NullPointerException at org.netbeans.modules.j2ee.ejbcore.ui.logicalview.ejb....
Status: VERIFIED FIXED
Product: javaee
Classification: Unclassified
Component: EJB
6.x
All All
: P2 with 1 vote (vote)
: 6.x
Assigned To: martin_adamek
issues@javaee
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT
:
: 142191 145116 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-24 16:40 UTC by aswath_t
Modified: 2009-01-16 07:30 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (2.51 KB, text/plain)
2008-07-28 09:47 UTC, rajivderas
Details
stacktrace (2.51 KB, text/plain)
2008-07-28 11:48 UTC, rajivderas
Details
stacktrace (2.51 KB, text/plain)
2008-08-02 22:16 UTC, goeh
Details
stacktrace (2.51 KB, text/plain)
2008-08-14 19:04 UTC, karmagfa
Details
stacktrace (31 bytes, text/plain)
2008-08-14 19:08 UTC, karmagfa
Details

Note You need to log in before you can comment on or make changes to this bug.
Description aswath_t 2008-07-24 16:40:12 UTC
Build: NetBeans IDE Dev (Build 200807240010)
VM: Java HotSpot(TM) Client VM, 10.0-b23, Java(TM) SE Runtime Environment, 1.6.0_07-b06
OS: Windows XP, 5.1, x86

User Comments: 
while adding Bussiness Method i got struck with this exception.... help me out...

Stacktrace: 
java.lang.NullPointerException
        at org.netbeans.modules.j2ee.ejbcore.ui.logicalview.ejb.action.AddBusinessMethodStrategy.createDialog(AddBusinessMethodStrategy.java:95)
        at org.netbeans.modules.j2ee.ejbcore.ui.logicalview.ejb.action.AbstractAddMethodStrategy.addMethod(AbstractAddMethodStrategy.java:91)
        at org.netbeans.modules.j2ee.ejbcore.ui.logicalview.ejb.action.AddMethodActions.invoke(AddMethodActions.java:158)
        at org.netbeans.modules.editor.codegen.GenerateCodePanel.invokeSelected(GenerateCodePanel.java:148)
        at org.netbeans.modules.editor.codegen.GenerateCodePanel.listMouseReleased(GenerateCodePanel.java:117)
        at org.netbeans.modules.editor.codegen.GenerateCodePanel.access$100(GenerateCodePanel.java:60)
Comment 1 David Konecny 2008-07-27 22:15:57 UTC
Martin, ejbMethodController can be null and it was never tested for it so I think this problem was there before my fix
of issue 138360.

aswath_t, more information how to reproduce this problem are appreciated.
Comment 2 rajivderas 2008-07-28 09:47:02 UTC
Build: NetBeans IDE Dev (Build 200807251401)
VM: Java HotSpot(TM) Client VM, 11.0-b11, Java(TM) SE Runtime Environment, 1.6.0_10-beta-b21
OS: Windows XP, 5.1, x86

User Comments: 


Stacktrace: 
java.lang.NullPointerException
        at org.netbeans.modules.j2ee.ejbcore.ui.logicalview.ejb.action.AddBusinessMethodStrategy.createDialog(AddBusinessMethodStrategy.java:95)
        at org.netbeans.modules.j2ee.ejbcore.ui.logicalview.ejb.action.AbstractAddMethodStrategy.addMethod(AbstractAddMethodStrategy.java:91)
        at org.netbeans.modules.j2ee.ejbcore.ui.logicalview.ejb.action.AddMethodActions.invoke(AddMethodActions.java:158)
        at org.netbeans.modules.editor.codegen.GenerateCodePanel.invokeSelected(GenerateCodePanel.java:148)
        at org.netbeans.modules.editor.codegen.GenerateCodePanel.listMouseReleased(GenerateCodePanel.java:117)
        at org.netbeans.modules.editor.codegen.GenerateCodePanel.access$100(GenerateCodePanel.java:60)
Comment 3 rajivderas 2008-07-28 09:47:06 UTC
Created attachment 65770 [details]
stacktrace
Comment 4 rajivderas 2008-07-28 11:48:09 UTC
Build: NetBeans IDE Dev (Build 200807251401)
VM: Java HotSpot(TM) Client VM, 11.0-b11, Java(TM) SE Runtime Environment, 1.6.0_10-beta-b21
OS: Windows XP, 5.1, x86

User Comments: 


Stacktrace: 
java.lang.NullPointerException
        at org.netbeans.modules.j2ee.ejbcore.ui.logicalview.ejb.action.AddBusinessMethodStrategy.createDialog(AddBusinessMethodStrategy.java:95)
        at org.netbeans.modules.j2ee.ejbcore.ui.logicalview.ejb.action.AbstractAddMethodStrategy.addMethod(AbstractAddMethodStrategy.java:91)
        at org.netbeans.modules.j2ee.ejbcore.ui.logicalview.ejb.action.AddMethodActions.invoke(AddMethodActions.java:158)
        at org.netbeans.modules.editor.codegen.GenerateCodePanel.invokeSelected(GenerateCodePanel.java:148)
        at org.netbeans.modules.editor.codegen.GenerateCodePanel.listMouseReleased(GenerateCodePanel.java:117)
        at org.netbeans.modules.editor.codegen.GenerateCodePanel.access$100(GenerateCodePanel.java:60)
Comment 5 rajivderas 2008-07-28 11:48:13 UTC
Created attachment 65779 [details]
stacktrace
Comment 6 David Konecny 2008-07-30 05:59:20 UTC
aswath_t sent me offline instruction how to reproduce but without success -works fine for me. Martin will have to look
at this issue.
Comment 7 David Konecny 2008-07-30 07:09:05 UTC
*** Issue 142191 has been marked as a duplicate of this issue. ***
Comment 8 goeh 2008-08-02 22:16:15 UTC
Build: NetBeans IDE Dev (Build 200808021401)
VM: Java HotSpot(TM) Client VM, 10.0-b22, Java(TM) SE Runtime Environment, 1.6.0_06-b02
OS: Windows XP, 5.1, x86

User Comments: 
Right-Click -> Insert Code > Add Business Method
Exception!

Stacktrace: 
java.lang.NullPointerException
        at org.netbeans.modules.j2ee.ejbcore.ui.logicalview.ejb.action.AddBusinessMethodStrategy.createDialog(AddBusinessMethodStrategy.java:95)
        at org.netbeans.modules.j2ee.ejbcore.ui.logicalview.ejb.action.AbstractAddMethodStrategy.addMethod(AbstractAddMethodStrategy.java:91)
        at org.netbeans.modules.j2ee.ejbcore.ui.logicalview.ejb.action.AddMethodActions.invoke(AddMethodActions.java:158)
        at org.netbeans.modules.editor.codegen.GenerateCodePanel.invokeSelected(GenerateCodePanel.java:148)
        at org.netbeans.modules.editor.codegen.GenerateCodePanel.listMouseReleased(GenerateCodePanel.java:117)
        at org.netbeans.modules.editor.codegen.GenerateCodePanel.access$100(GenerateCodePanel.java:60)
Comment 9 goeh 2008-08-02 22:16:24 UTC
Created attachment 66400 [details]
stacktrace
Comment 10 karmagfa 2008-08-14 19:04:24 UTC
Build: NetBeans IDE 6.5 Beta (Build 200808111757)
VM: Java HotSpot(TM) Client VM, 10.0-b19, Java(TM) SE Runtime Environment, 1.6.0_05-b13
OS: Windows XP, 5.1, x86

User Comments: 


Stacktrace: 
java.lang.NullPointerException
        at org.netbeans.modules.j2ee.ejbcore.ui.logicalview.ejb.action.AddBusinessMethodStrategy.createDialog(AddBusinessMethodStrategy.java:95)
        at org.netbeans.modules.j2ee.ejbcore.ui.logicalview.ejb.action.AbstractAddMethodStrategy.addMethod(AbstractAddMethodStrategy.java:91)
        at org.netbeans.modules.j2ee.ejbcore.ui.logicalview.ejb.action.AddMethodActions.invoke(AddMethodActions.java:158)
        at org.netbeans.modules.editor.codegen.GenerateCodePanel.invokeSelected(GenerateCodePanel.java:148)
        at org.netbeans.modules.editor.codegen.GenerateCodePanel.listMouseReleased(GenerateCodePanel.java:117)
        at org.netbeans.modules.editor.codegen.GenerateCodePanel.access$100(GenerateCodePanel.java:60)
Comment 11 karmagfa 2008-08-14 19:04:47 UTC
Created attachment 67460 [details]
stacktrace
Comment 12 karmagfa 2008-08-14 19:08:28 UTC
Build: NetBeans IDE 6.5 Beta (Build 200808111757)
VM: Java HotSpot(TM) Client VM, 10.0-b19, Java(TM) SE Runtime Environment, 1.6.0_05-b13
OS: Windows XP, 5.1, x86

User Comments: 


Stacktrace: 
java.lang.NullPointerException
Comment 13 karmagfa 2008-08-14 19:08:55 UTC
Created attachment 67461 [details]
stacktrace
Comment 14 David Konecny 2008-08-14 23:42:46 UTC
I was able to reproduce it on SessionBean which does not have Remote nor Local interface.
ddef825991e8
Comment 15 David Konecny 2008-08-27 23:01:59 UTC
*** Issue 145116 has been marked as a duplicate of this issue. ***
Comment 16 Martin Fousek 2008-10-13 12:31:48 UTC
Verified with NetBeans IDE Dev (Build 200810111401).
Comment 17 Quality Engineering 2009-01-16 07:30:15 UTC
Integrated into 'main-golden', will be available in build *200901160201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/eb904cc6959e
User: Erno Mononen <emononen@netbeans.org>
Log: #141578: [65cat] [tools] Ability to specify starting point for debugging


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo