Bug 141577 - I18N - Recent Search window doesn't resize to show its label
I18N - Recent Search window doesn't resize to show its label
Status: RESOLVED DUPLICATE of bug 139345
Product: platform
Classification: Unclassified
Component: Quick Search
6.x
All All
: P2 (vote)
: 6.x
Assigned To: David Simonek
issues@platform
: I18N
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-24 16:33 UTC by kaa
Modified: 2008-12-22 14:47 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
probably it has fixed size (52.39 KB, image/jpeg)
2008-07-24 16:34 UTC, kaa
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kaa 2008-07-24 16:33:36 UTC
Product Version: NetBeans IDE Dev (Build 20080721233246)
Java: 1.6.0_06; Java HotSpot(TM) Client VM 10.0-b22
System: Windows XP version 5.1 running on x86; MS932; ja_JP (nb)
I'm running in Japanese locale, using a pseudo localized Netbeans with font size 16 option.

1. Start IDE
2. Search for something using search bar (Ctrl+I)
3. Give a focus to the search bar again 

Recent Search window appears. It doesn't resize to show its label.

Assumption is that user does not need to manually resize most windows or dialogs to see all of the UI objects and
information in them. I'm running in pseudo localized locale in which each message/label is sometimes longer than in
English. To account for that in some locales, translations from English (and some other euro languages) could be shown
with longer strings.

Also I'm running at font size 16, which is viewed as a valid font size that might be used. Resizing issues are not just
related to i18n; they might show to user in English locale if they run at larger font size.

Often, these issues happen because the length of some label or message or size of entire window is hardcoded vs using
layout managers or other techniques or api to have the windows or the objects in them, dynamically resize.
Comment 1 kaa 2008-07-24 16:34:10 UTC
Created attachment 65559 [details]
probably it has fixed size
Comment 2 Peter Pis 2008-07-30 10:22:21 UTC
Reassigning to "core"
Comment 3 David Simonek 2008-07-31 07:37:10 UTC
Already filed, 139345

*** This issue has been marked as a duplicate of 139345 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo