Bug 141545 - Add New column into breakpoints view: Hit count
Add New column into breakpoints view: Hit count
Status: VERIFIED FIXED
Product: debugger
Classification: Unclassified
Component: Java
6.x
Sun All
: P3 with 1 vote (vote)
: 7.4
Assigned To: Martin Entlicher
issues@debugger
: PLAN
: 179802 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-24 14:15 UTC by Petr Cyhelsky
Modified: 2013-07-10 21:14 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Cyhelsky 2008-07-24 14:15:03 UTC
This would be nice addition to the now supported feature of breakpoints to stop when hit count is equal/greater
than/multiple of something - user would have better knowledge of how many times the program passed some section of code
(very useful with breakpoints set to suspend no threads) - this would also saved the work with all the tinkering with
break when hit count in properties and searching through output.
Comment 1 Martin Entlicher 2013-04-26 19:51:06 UTC
Implemented by changeset:   252051:b294b7a6ba68
http://hg.netbeans.org/core-main/rev/b294b7a6ba68
Comment 2 Quality Engineering 2013-04-28 02:16:23 UTC
Integrated into 'main-golden', will be available in build *201304272301* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/b294b7a6ba68
User: mentlicher@netbeans.org
Log: #141545: Hit Count column is added to Breakpoints view.
Comment 3 Jiri Kovalsky 2013-07-08 18:25:52 UTC
*** Bug 179802 has been marked as a duplicate of this bug. ***
Comment 4 markiewb 2013-07-10 21:14:40 UTC
Verified in 201307011244


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo