Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 141489 - [65cat] Alter "Resolve References" to be capable of resolving references.
[65cat] Alter "Resolve References" to be capable of resolving references.
Status: RESOLVED DUPLICATE of bug 123464
Product: projects
Classification: Unclassified
Component: Generic Projects UI
6.x
PC All
: P3 with 1 vote (vote)
: 6.x
Assigned To: Milan Kubec
issues@projects
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-24 09:01 UTC by esmithbss
Modified: 2008-10-16 14:43 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description esmithbss 2008-07-24 09:01:42 UTC
The current implementation of "Resolve Missing References" does not completely implement reference resolution as the
name implies.

Currently, the only capability for resolving references is to re-add missing references by name into the system which
can cause duplications within platforms, libraries, etc... instead of maintaining a clean environment.

An example would be having installed the Sun Wireless Toolkit 2.5.2 as WTK-2.5.2 under NetBeans 6.1, then upon
installing NetBeans 6.5 and opening the project, having to re-install the currently existing Sun Wireless Toolkit 2.5.2
as WTK-2.5.2 if you follow the "Resolve References" hint dialog that pops up upon opening the project.

As lhasik identifies in the referenced issue, the only way to resolve the references using existing installed
platforms/libraries/etc... is to go into the Project Properties and replace the old references with the new references.

These two separate capabilities for references resolution need to be combined into a single "Resolve Missing References"
capability accessed by the user when the "Resolve References" hint dialog is displayed and the user selects to resolve
the references.





See http://www.netbeans.org/issues/show_bug.cgi?id=140356 for more background details.
Comment 1 Petr Chytil 2008-07-24 12:24:26 UTC
reassigning to projects/ui for evaluation
Comment 2 Milan Kubec 2008-10-16 14:43:23 UTC

*** This issue has been marked as a duplicate of 123464 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo