Bug 141168 - I18N - Taking Heap Dump failed if project folder contains russian characters
I18N - Taking Heap Dump failed if project folder contains russian characters
Status: RESOLVED WONTFIX
Product: profiler
Classification: Unclassified
Component: Base
6.x
All Windows XP
: P2 (vote)
: TBD
Assigned To: issues@profiler
issues@profiler
: I18N
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-22 14:29 UTC by Rashid Urusov
Modified: 2008-07-25 15:39 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
message.log (181.67 KB, text/plain)
2008-07-22 14:45 UTC, Rashid Urusov
Details
err message (42.87 KB, image/jpeg)
2008-07-23 15:13 UTC, kaa
Details
jconsole (110.27 KB, image/jpeg)
2008-07-23 15:16 UTC, kaa
Details
messages.log (77.37 KB, text/plain)
2008-07-23 15:21 UTC, kaa
Details
Screenshot of the failure in JConsole (50.42 KB, image/png)
2008-07-23 15:38 UTC, Jiri Sedlacek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rashid Urusov 2008-07-22 14:29:44 UTC
I've got error message while taking Heap Dump for project which located in folder containing russian characters.
See message.log in attachment
Comment 1 Rashid Urusov 2008-07-22 14:45:30 UTC
Created attachment 65247 [details]
message.log
Comment 2 Rashid Urusov 2008-07-22 14:46:41 UTC
added keyword I18N
Comment 3 Ken Frank 2008-07-22 16:27:18 UTC
rashid,

what is the project encoding being used ?
if it is utf-8, could you change to cp1251
to see if problem happens there also ?


also,just want to confirm that if project is in folder or path that does not
have Russian characters, does the problem not happen ?

ken.frank@sun.com
Comment 4 Tomas Hurka 2008-07-23 08:18:43 UTC
I am not able to reproduce it on Mac OS X.
Comment 5 Jiri Sedlacek 2008-07-23 11:09:28 UTC
Reproduced on Windows using ru_RU (nb); Cp1251. The same problem happens when taking the heap dump from JConsole, it
seems more like a JDK bug.
Comment 6 Tomas Hurka 2008-07-23 11:29:45 UTC
I checked our sources and we correctly pass String with the filename to the appropriate methods so I believe that this is not bug in NetBeans Profiler. Please 
file issue against JDK using jconsole as example. Closing as wontfix.
Comment 7 Rashid Urusov 2008-07-23 14:39:16 UTC
Error message remains after project encoding changed to cp1251.
I didn't face with any problem while take Heap Dump with Jconsole for the same application.
So I didn't file issue against JDK   (also cause now I have read only permission in bugster and since tomorrow till 8
August I will be on vacation)

For Ken : I confirm that if project is in folder or path that does not
have Russian characters,  the problem does not happen
Comment 8 Tomas Hurka 2008-07-23 14:59:57 UTC
How did you took heap dump with jconsole? You have to use name containing russian characters.
Comment 9 Rashid Urusov 2008-07-23 15:10:37 UTC
I used the same project located in folder containing russian characters
Comment 10 kaa 2008-07-23 15:12:50 UTC
The issue is reproducible.
I'm running in Japanese locale, using a pseudo localized Netbeans with font size 16 option:

Product Version: NetBeans IDE Dev (Build 20080721233246)
Java: 1.6.0_06; Java HotSpot(TM) Client VM 10.0-b22
System: Windows XP version 5.1 running on x86; MS932; ja_JP (nb)

There is an err message on attempt to generate heap dump. See image.
jconsole generates the dump properly. I used mbyte chars in project location path.

If this issue is about jdk, provide a number please. Then close this one.
Comment 11 kaa 2008-07-23 15:13:54 UTC
Created attachment 65387 [details]
err message
Comment 12 kaa 2008-07-23 15:16:06 UTC
Created attachment 65388 [details]
jconsole
Comment 13 kaa 2008-07-23 15:21:35 UTC
Created attachment 65389 [details]
messages.log
Comment 14 Jiri Sedlacek 2008-07-23 15:25:55 UTC
Kaa, are you sure you are entering path to the heapdump using Japanese characters in JConsole? I can only see "heapdmp".
Comment 15 kaa 2008-07-23 15:31:03 UTC
Heap dump was generated in the project folder (8.71Mb):
C:\新規フォルダ\AnagramGame
Comment 16 Jiri Sedlacek 2008-07-23 15:31:56 UTC
 Java; VM; Vendor        = 1.6.0_07; Java HotSpot(TM) Client VM 10.0-b23; Sun Microsystems Inc.
 Runtime                 = Java(TM) SE Runtime Environment 1.6.0_07-b06
 System Locale; Encoding = cs_CZ (nb); Cp1250

Steps to reproduce the failure using JConsole:

 1/ Create new project AnagramGame on a path containing special characters. I've used "E:\Projects\ěšč\AnagramGame"
 2/ Start the project from within the IDE
 3/ Start JConsole, select the AnagramGame process and connect to it
 4/ In MBeans tab, navigate to com.sun.management.HotSpotDiagnostic | Operations | dumpHeap
 5/ Enter "E:\Projects\ěšč\AnagramGame\dump.hprof" for p0 and "true" for p1
 6/ Press the heapDump button, JConsole fails to take the dump and shows an Error dialog
Comment 17 Jiri Sedlacek 2008-07-23 15:35:45 UTC
Kaa, heapdump is probably generated to current working directory of the application when absolute path is not provided,
but that's not what this issue is about. The problem we are discussing here is caused by incorrect handling of provided
absolute path parameter for heapdump, which is likely on the JDK side.
Comment 18 Jiri Sedlacek 2008-07-23 15:37:46 UTC
Just a verification:

 - when "E:\Projects\ěšč\AnagramGame\dump.hprof" is used, dumping the heap fails
 - when "E:\Projects\dump.hprof" is used, dumping the heap works as expected
Comment 19 Jiri Sedlacek 2008-07-23 15:38:47 UTC
Created attachment 65392 [details]
Screenshot of the failure in JConsole
Comment 20 Jiri Sedlacek 2008-07-23 15:42:15 UTC
Closing as WONTFIX again.

QE please file a bug for JDK and provide a link here OR provide detailed reproducible steps for JConsole to correctly
dump the heap to a path containing special characters.
Comment 21 kaa 2008-07-25 15:39:04 UTC
Filed CR 6729929 in bugster


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo