Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 140695 - Auto Popup Completion Window should be triggered by typing any identifier part in Java
Auto Popup Completion Window should be triggered by typing any identifier par...
Status: RESOLVED FIXED
Product: editor
Classification: Unclassified
Component: Completion & Templates
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Dusan Balek
issues@editor
:
Depends on:
Blocks: 152194
  Show dependency treegraph
 
Reported: 2008-07-18 10:14 UTC by Jaromir Uhrik
Modified: 2009-05-12 10:12 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jaromir Uhrik 2008-07-18 10:14:03 UTC
Product Version: NetBeans IDE Dev (Build 200807170007)
Java: 1.5.0_13; Java HotSpot(TM) Client VM 1.5.0_13-119
System: Mac OS X version 10.5.4 running on i386; MacRoman; en_US (nb)

Go to Tools|Options > Editor > General. In Code Completion section there is the Auto Popup Completion Window checkbox.
The code completion doesn't appear automatically in java files no matter whether this checkbox is checked or unchecked.
BTW the checkbox works fine for auto popup code completion in XML files.
Comment 1 Dusan Balek 2008-07-21 09:07:38 UTC
Sorry, I cannot reproduce the issue in the current dev build. Trying to type 'System.' - code completion appears
automatically iff the checkbox is selected.
Comment 2 Jaromir Uhrik 2008-07-24 13:09:39 UTC
I agree that for methods it works, but please look at the following usecase:
Type 'Syst' and wait. I expect that the completion appears, but nothing happens. You need to push Ctrl+Space to see code
completion.
Comment 3 Dusan Balek 2008-07-24 13:38:36 UTC
Automatic code completion was always intended to be triggered by typing '.' in Java. However, some time ago, Jano Rojcek
thought about a possibility to trigger automatic code completion by typing any identifier part. Changing to ENHANCEMENT
for now.
Comment 4 jrojcek 2008-07-25 07:30:43 UTC
Yes, the completion that pop ups automatically when available would be really great iff:

- it's really fast
- it's unobtrusive (small completion popup window, with very small javadoc window)

Try visual studio to see what I mean. Automatic completion is addictive, but it really needs to be extremely fast.

Comment 5 Quality Engineering 2008-10-31 04:48:23 UTC
Integrated into 'main-golden', will be available in build *200810310201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/0fb6bb829f57
User: Dusan Balek <dbalek@netbeans.org>
Log: Couple of code completion options added as requested by issues #74724, #131037, and #140695.
Comment 6 David Strupl 2009-05-12 10:12:16 UTC
An option has been implemented by Dusan.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo