Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 140463 - Various issues with HQL syntax and grammer
Various issues with HQL syntax and grammer
Status: RESOLVED WONTFIX
Product: javaee
Classification: Unclassified
Component: Hibernate
6.x
Sun All
: P3 (vote)
: 6.x
Assigned To: Vadiraj Deshpande
issues@javaee
:
: 147838 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-17 09:07 UTC by Vadiraj Deshpande
Modified: 2009-11-02 11:16 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vadiraj Deshpande 2008-07-17 09:07:44 UTC
HQL language description file (NBS) has various issues as follows:
- From statement, where clause, join statements do not have grammers defined.
- Capitalized identifiers are flagged out as errors.
- HQL language description do not inherit the font and colors scheme.
- Strings are not defined in the description file.
- Code completion works only for few keywords.
Comment 1 Vadiraj Deshpande 2008-07-18 13:08:55 UTC
Will take this up next week.
Comment 2 Vadiraj Deshpande 2008-07-18 13:10:40 UTC
Issue Zilla thought that this issue is resolved, when I want to mark this issue to be taken up later next week.
Comment 3 Vadiraj Deshpande 2008-09-22 12:03:43 UTC
*** Issue 147838 has been marked as a duplicate of this issue. ***
Comment 4 Vadiraj Deshpande 2008-11-18 10:52:31 UTC
Will be taken up in future release.
Comment 5 Quality Engineering 2009-11-02 11:16:57 UTC
NetBeans.org Migration: changing resolution from LATER to WONTFIX


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo