Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 140390 - java.hints.analyzer.ToolsAction classes loaded on startup
java.hints.analyzer.ToolsAction classes loaded on startup
Status: RESOLVED WONTFIX
Product: java
Classification: Unclassified
Component: Hints
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Jan Lahoda
issues@java
http://wiki.netbeans.org/FitnessViaWh...
: PERFORMANCE, REGRESSION, TEST
Depends on: 180979
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-16 18:56 UTC by Alexander Kouznetsov
Modified: 2012-04-18 07:59 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Stacktraces (251.41 KB, text/xml)
2008-07-16 18:57 UTC, Alexander Kouznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Kouznetsov 2008-07-16 18:56:37 UTC
Performance whitelist test reports that the following classes are being loaded on NetBeans startup:

org.netbeans.modules.java.hints.analyzer.AnalyzeFolder
org.netbeans.modules.java.hints.analyzer.AnalyzeFolder$ToolsAction
org.netbeans.modules.java.hints.analyzer.OverridePreferences

This is considered as NetBeans performance regression. Please remove these classes from NetBeans startup.

This issue is based on jtulach's comment:
Report a bug for the module to switch to new declarative actions 
(Actions.alwaysEnabled or TopComponent.openAction)
Comment 1 Alexander Kouznetsov 2008-07-16 18:57:41 UTC
Created attachment 64742 [details]
Stacktraces
Comment 2 Jan Lahoda 2008-07-17 19:33:25 UTC
org.netbeans.modules.java.hints.analyzer.OverridePreferences is likely to be bug in the test itself - this class is
referenced only from a method body, and is likely to be loaded through the class/bytecode verifier. Given that the
verifier is disabled in release builds, this class should not be reported, IMO.

To eliminate org.netbeans.modules.java.hints.analyzer.AnalyzeFolder$ToolsAction, we would need to make this action
enabled all the time, which is not very appropriate, IMO.

We could save org.netbeans.modules.java.hints.analyzer.AnalyzeFolder why shuffling the code a bit, but I am not sure if
it is worth the effort.
Comment 3 Max Sauer 2008-07-21 14:10:31 UTC
Jardo, any opinion? Thanks.
Comment 4 pribyl 2008-09-26 15:54:08 UTC
Any progress in this one?

According to the rules, I should close issues, that are INCOMPLETE for more than 4 weeks.
But in this case, I don't feel like the person that should decide about closing... 

So please, can anyone competent decide, wheter this is going to be started, or wontfix ... or anything else :)

Thanks!
Comment 5 Jan Becicka 2008-11-14 12:40:33 UTC
Should be fixed ot wontfixed in 7.0
Comment 6 Max Sauer 2009-10-01 13:38:36 UTC
No comments from yarda, not such an import issue to load one class imho => WONTFIX, sorry.
Comment 7 Jaroslav Tulach 2009-10-07 14:34:26 UTC
Reopening to fix.
Comment 8 Jaroslav Tulach 2009-10-07 14:36:05 UTC
When fixing other class blacklist related bugs, please add the class names into ide.kit/**/blacklist.txt yourself and 
re-run the GeneralSanityTest. That will help you verify the bug is fixed. Done in ergonomics#c45e9c6c96fa
Comment 9 Quality Engineering 2009-10-15 22:23:22 UTC
Integrated into 'main-golden', will be available in build *200910151401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/c45e9c6c96fa
User: Jaroslav Tulach <jtulach@netbeans.org>
Log: #140390: Verifying no analyzer classes are loading during start
Comment 10 Jaroslav Tulach 2010-02-03 10:27:15 UTC
These classes still seem to be loaded. There is no way to avoid it, as the action is registered as ToolsAction and there is no way to register a declarative action into ToolsAction right now.

Removing the action from blacklist for now: ergonomics#f94d7604859f
Comment 11 Jan Lahoda 2010-02-15 09:13:47 UTC
No idea why this bug has been re-opened. This bug was considered to be won't fix, to my knowledge (there is no entry about any fix, only jtulach's commit that includes the classes into the blacklist, without any real fix). Jarda, please resolve somehow (or I will won't fix it myself).
Comment 12 Jaroslav Tulach 2010-02-26 22:52:39 UTC
As the action seems to be mostly enabled on java packages in projects view, consider registering it in their popup menu only. Otherwise please employ context sensitivity as enabled by bug 180979.
Comment 13 Jan Lahoda 2012-04-18 07:59:48 UTC
Unlikely I will be able to work on this in the foreseeable future.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo