Bug 140382 - [65cat] Exportable libraries
[65cat] Exportable libraries
Status: RESOLVED DUPLICATE of bug 47507
Product: projects
Classification: Unclassified
Component: Ant Project
PC Windows XP
: P2 (vote)
: 6.x
Assigned To: Milan Kubec
Depends on:
  Show dependency treegraph
Reported: 2008-07-16 18:13 UTC by dafreels
Modified: 2008-11-07 03:30 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description dafreels 2008-07-16 18:13:33 UTC
[ BUILD # : 200807101204 ]
[ JDK VERSION : 1.6.0_04 ]

When a project has defined a set of dependent libraries, there needs
to be a way to export those libraries so that other projects
dependent on that project automatically include those libraries in
addition to the project jar file. Currently, I have to go to each of
my projects and define the same dependencies to junit or log4j or
whatever over and over.
Comment 1 Milos Kleint 2008-07-16 19:18:00 UTC
I think a duplicate of another issue, libraries (or project dependencies in general) are not transitive for netbeans ant
Comment 2 Milos Kleint 2008-10-14 12:34:48 UTC
ant projects specific
Comment 3 Jesse Glick 2008-11-07 03:30:40 UTC

*** This issue has been marked as a duplicate of 47507 ***

By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo