Bug 14035 - VCS command-line support does not work under JDK1.4
VCS command-line support does not work under JDK1.4
Status: CLOSED INVALID
Product: obsolete
Classification: Unclassified
Component: vcscore
3.x
PC Windows ME/2000
: P1 (vote)
: TBD
Assigned To: issues@obsolete
issues@obsolete
: SPACE_IN_PATH
: 15134 15908 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-30 11:50 UTC by Martin Grebac
Modified: 2003-07-01 12:55 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Grebac 2001-07-30 11:50:29 UTC
Using JDK1.4 b73, and Forte 3.0 build #010727

 1. Mount CVS commandline filesystem
 2. Try to execute checkout (or checkout module list)

Command output:
---------------

Exec string: cmd /X /C "cd /D \"D:\Arena\testcvs2\"&& \"cvs\" -d 
\":pserver:mg116726@fortecvs:/forte4j\" checkout -s "

Std error: 'cd" "' is not recognized as an internal or external command, 
operable program or batch file.

This could be a bug in JDK 1.4 - under JDK1.4 it's impossible to execute e.g. 
this line of code (under 1.3 it works OK):

 Runtime.getRuntime().exec("cmd /X /C \" cd /D \"D:\\Arena\\testok\" \" ");

The process ends up with 

 java.lang.IllegalArgumentException: ": unmatched quotes.
Comment 1 Martin Entlicher 2001-07-30 16:53:58 UTC
It's probably a bug of JDK, because I was not able to find a way how
to specify an execution string, that would work on Windows NT in JDK
1.4.0 beta 73.
I've filled a bug for that on JDK (#4485848).
Comment 2 Martin Entlicher 2001-07-31 10:27:22 UTC
Resolving as invalid, because this is not a bug in NetBeans product.
It was caused by a bug in JDK (#4485848).
Comment 3 _ rkubacki 2001-09-07 09:45:17 UTC
*** Issue 15134 has been marked as a duplicate of this issue. ***
Comment 4 Jiri Kovalsky 2001-09-26 09:31:46 UTC
*** Issue 15908 has been marked as a duplicate of this issue. ***
Comment 5 Jiri Kovalsky 2001-10-10 13:34:24 UTC
I am verifying this bug as INVALID. This is really bug of JDK 1.4 and 
it is already fixed in Beta 3 release. Unfortunately no command-line 
module of NetBeans IDE can work with Beta 2 (b77) of JDK 1.4 release.
Comment 6 Marek Grummich 2002-07-19 16:02:30 UTC
Target milestone was changed from not determined to TBD
Comment 7 Quality Engineering 2003-07-01 12:55:43 UTC
Resolved for 3.4.x or earlier, no new info since then -> closing.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo