Bug 140133 - PackageViewTest.testCopyPaste failing consistently
PackageViewTest.testCopyPaste failing consistently
Status: RESOLVED WONTFIX
Product: java
Classification: Unclassified
Component: Project
6.x
All All
: P4 (vote)
: TBD
Assigned To: Tomas Zezula
issues@java
: TEST
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-15 17:03 UTC by Jesse Glick
Modified: 2016-07-07 07:18 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2008-07-15 17:03:56 UTC
Was marked @RandomlyFails, but fails for me reproducibly.

junit.framework.AssertionFailedError: Wrong # or names of nodes expected:<[File1.java, File2.java]> but was:<[]>
        at org.netbeans.spi.java.project.support.ui.PackageViewTest.assertNodes(PackageViewTest.java:840)
        at org.netbeans.spi.java.project.support.ui.PackageViewTest.assertNodes(PackageViewTest.java:822)
        at org.netbeans.spi.java.project.support.ui.PackageViewTest.testCopyPaste(PackageViewTest.java:596)

(Potentially related to recent explorer changes.)
Comment 1 Jan Becicka 2008-08-15 08:56:56 UTC
PackageView maitained by Milan.
Comment 2 Milan Kubec 2009-10-08 12:57:00 UTC
This test isn't failing for me at all.
Comment 3 Jesse Glick 2009-10-08 14:06:04 UTC
Then remove @RandomlyFails and see if the builder agrees.
Comment 4 Milan Kubec 2009-10-08 14:10:32 UTC
I though that the report was about consistently failing test. @RandomlyFails test are supposed to be fixed too?
Comment 5 Jesse Glick 2009-10-08 14:37:57 UTC
They should be reevaluated if they were previously marked @RF because thought to never pass.
Comment 6 David Strupl 2012-10-25 13:41:53 UTC
Bug prior to 7.0, not touched for the last 2 years --> P4.
Comment 7 Martin Balin 2016-07-07 07:18:24 UTC
This old bug may not be relevant anymore. If you can still reproduce it in 8.2 development builds please reopen this issue.

Thanks for your cooperation,
NetBeans IDE 8.2 Release Boss


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo