Bug 140078 - Endless loop (full hang) toolbar related
Endless loop (full hang) toolbar related
Status: RESOLVED WORKSFORME
Product: platform
Classification: Unclassified
Component: Data Systems
6.x
All Windows XP
: P1 (vote)
: 6.x
Assigned To: Jaroslav Tulach
issues@platform
: THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-15 13:11 UTC by giorgio42
Modified: 2008-12-22 13:47 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
jstack -l dump while running in endless loop (19.95 KB, text/plain)
2008-07-15 13:12 UTC, giorgio42
Details
zip archive with 10 jstack -l outputs and the truncated messages.log (30.11 KB, application/x-compressed)
2008-07-30 15:37 UTC, giorgio42
Details
Contents of Windows2Local causing the endless loop (109.13 KB, application/x-compressed)
2008-07-31 17:53 UTC, giorgio42
Details

Note You need to log in before you can comment on or make changes to this bug.
Description giorgio42 2008-07-15 13:11:00 UTC
Using NB 6.5 daily, build 200807101204 on WinXP, Java 6 update 10.

Every now and then the IDE hangs completely, writing the following message to the log file in an endless loop:

WARNING [org.openide.filesystems.Ordering]: Not all children in Toolbars/ marked with the position attribute:
[QuickSearch, Standard.xml], but some are: [Build, Debug, Edit, File, Memory, Debugging.xml]

Right now the log file is 41 MB and growing. I am attaching a jstack -l dump.

Georg
Comment 1 giorgio42 2008-07-15 13:12:18 UTC
Created attachment 64558 [details]
jstack -l dump while running in endless loop
Comment 2 giorgio42 2008-07-15 14:04:15 UTC
What makes this issue really annoying is the fact, that I have to zap my userdir to make NB start up again.
Which means, it causes data loss, there it is a P1.
Comment 3 giorgio42 2008-07-18 13:31:01 UTC
Just installed 20080717, still the same... doesn't come up.
Can you please at least tell me, which of the files or folders in the userdir may cause this (I would really appreciate
it if you could save me from starting a new userdir from scratch).

Thanks,
Georg
Comment 4 giorgio42 2008-07-23 15:48:25 UTC
NB Daily 200807221016: No change. (...nobody is listening...)

Comment 5 Lukas Hasik 2008-07-28 13:13:38 UTC
reassigning

"AWT-EventQueue-1" prio=6 tid=0x039bd000 nid=0xb9c in Object.wait() [0x2e48e000..0x2e48fc14]
   java.lang.Thread.State: WAITING (on object monitor)
	at java.lang.Object.wait(Native Method)
	at java.lang.Object.wait(Object.java:485)
	at org.openide.nodes.EntrySupport$Default.getArray(EntrySupport.java:774)
	- locked <0x073b7b28> (a java.lang.Object)
	at org.openide.nodes.EntrySupport$Default.getNodes(EntrySupport.java:140)
	at org.openide.nodes.EntrySupport$Default.getNodes(EntrySupport.java:195)
	at org.openide.nodes.Children.getNodes(Children.java:417)
	at org.openide.nodes.FilterNode$ChildrenAdapter.run(FilterNode.java:1504)
	at org.openide.nodes.FilterNode$Children.updateKeys(FilterNode.java:1455)
	at org.openide.nodes.FilterNode$Children.addNotifyImpl(FilterNode.java:1348)
	at org.openide.nodes.FilterNode$Children.addNotify(FilterNode.java:1340)
	at org.openide.nodes.Children.callAddNotify(Children.java:488)
	at org.openide.nodes.EntrySupport$Default.getArray(EntrySupport.java:688)
	at org.openide.nodes.EntrySupport$Default.getNodes(EntrySupport.java:140)
	at org.openide.nodes.EntrySupport$Default.getNodes(EntrySupport.java:195)
	at org.openide.nodes.Children.getNodes(Children.java:417)
	at org.openide.explorer.view.VisualizerNode.getChildren(VisualizerNode.java:251)
Comment 6 t_h 2008-07-28 13:38:42 UTC
I think the problem is not in node/explorer:

"Default RequestProcessor" daemon prio=2 tid=0x03ab3c00 nid=0x1e0 in Object.wait() [0x2eb5f000..0x2eb5fc14]
   java.lang.Thread.State: WAITING (on object monitor)
	at java.lang.Object.wait(Native Method)
	at java.lang.Object.wait(Object.java:485)
	at org.openide.util.Task.waitFinished(Task.java:130)
	- locked <0x1067c1b8> (a org.openide.util.RequestProcessor$Task)
	at org.openide.util.RequestProcessor$Task.waitFinished(RequestProcessor.java:756)
	at org.openide.loaders.FolderInstance.waitFinished(FolderInstance.java:316)
	at org.openide.loaders.FolderLookup$ProxyLkp.beforeLookup(FolderLookup.java:410)
	at org.openide.util.lookup.ProxyLookup$R.myBeforeLookup(ProxyLookup.java:645)
	at org.openide.util.lookup.ProxyLookup$R.beforeLookup(ProxyLookup.java:664)
	at org.openide.util.lookup.ProxyLookup$R.myBeforeLookup(ProxyLookup.java:653)
	at org.openide.util.lookup.ProxyLookup$R.computeResult(ProxyLookup.java:518)
	at org.openide.util.lookup.ProxyLookup$R.allInstances(ProxyLookup.java:489)
	at org.netbeans.spi.project.ui.support.NodeFactorySupport$DelegateChildren.addNotify(NodeFactorySupport.java:170)
	- locked <0x08dfabd8> (a org.netbeans.spi.project.ui.support.NodeFactorySupport$DelegateChildren)
	at org.openide.nodes.Children.callAddNotify(Children.java:488)
	at org.openide.nodes.EntrySupport$Default.getArray(EntrySupport.java:688)
	at org.openide.nodes.EntrySupport$Default.getNodes(EntrySupport.java:183)
	at org.openide.nodes.Children.getNodes(Children.java:448)
	at org.openide.nodes.FilterNode$Children.getNodes(FilterNode.java:1473)
	at org.openide.explorer.view.TreeView$2.run(TreeView.java:847)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:572)
	at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:997)
Comment 7 Lukas Hasik 2008-07-29 09:56:02 UTC
Yarda is not available. Tondo, who will take care about this one?

giorgio42, are you able to reproduce with latest builds? Can you provide more TDs from the last builds? Thank you
Comment 8 Stanislav Aubrecht 2008-07-29 13:59:41 UTC
giorgio42, please make some more thread dumps during startup. also pls attach your ide log file (preferrably zipped
and/or truncated to some reasonable length), thanks
you may also try removing ocnfig/Toolbars folder in your user dir.
Comment 9 giorgio42 2008-07-30 15:32:52 UTC
Just tried with 200807300201, same result. I am going to attach a bit more stuff.
Georg
Comment 10 giorgio42 2008-07-30 15:37:07 UTC
Created attachment 66072 [details]
zip archive with 10 jstack -l outputs and the truncated messages.log
Comment 11 giorgio42 2008-07-30 15:39:39 UTC
The message log in the zip archive is truncated to something useful. Originally it contained about half a million lines
exactly like this, one after another, no other messages in between:

WARNING [org.openide.filesystems.Ordering]: Not all children in Toolbars/ marked with the position attribute:
[Clipboard, QuickSearch, UndoRedo, Standard.xml], but some are: [Build, Debug, File, Management, Memory, Debugging.xml]

Cheers,
Georg
Comment 12 Stanislav Aubrecht 2008-07-30 16:50:24 UTC
thanks for the extra info, did removing 'config/Toolbars' help?
Comment 13 giorgio42 2008-07-30 21:09:16 UTC
As far as I remember removing config/Toolbars didn't help (need to check again tomorrow). That's what confused me. It
made me pull the repository to search for the error message, but then I got occupied with something else... 

BTW: Try searching Google for "WARNING [org.openide.filesystems.Ordering]: Not all children in".
Comment 14 Stanislav Aubrecht 2008-07-31 09:42:17 UTC
i still can't reproduce your issue, i have no 'ordering' warnings in my message log.

do you have any extra plugins installed? what ide distribution do you have (full ide, java se, web & java ee)?
also, can you attach your zipped user dir? thanks
Comment 15 Stanislav Aubrecht 2008-07-31 10:41:09 UTC
did QA have any luck reproducing this?
Comment 16 Lukas Hasik 2008-07-31 14:38:53 UTC
no, QA haven't seen it yet. Any steps to reproduce? When you start IDE with --userdir APATH, does it work?
Comment 17 giorgio42 2008-07-31 16:02:34 UTC
Actually config/Toolbar exists, but is empty.
Comment 18 giorgio42 2008-07-31 16:24:33 UTC
I have what has been called java + ee, and now is called java.

Additional modules installed are: usertasks,tcl,jconsole,terminal (Run Terminal). That's all.

The dailies function properly with a different userdir. This is what I am doing because the standard userdir does not
work anymore. One of these days I write a groovy script to clone the most important parts of the userdir...

I cannot give you my userdir because of company policies.



Comment 19 Stanislav Aubrecht 2008-07-31 16:47:17 UTC
hmm, i can't reproduce it so i can't fix it either...
Comment 20 giorgio42 2008-07-31 17:52:01 UTC
Ok, I started to rename folders in the userdir that causes the endless loop.
As soon as I renamed Windows2Local to Windows2Local.bak NB came up again.

Now I am copying back the contents of Windows2Local one folder after another, without being able to reproduce the
problem so far. The contents of the somehow poisonous Windows2Local folder will be attached.

Georg
Comment 21 giorgio42 2008-07-31 17:53:19 UTC
Created attachment 66204 [details]
Contents of Windows2Local causing the endless loop
Comment 22 Stanislav Aubrecht 2008-08-01 12:55:06 UTC
thanks for the new info. i still can't reproduce it though
can you pls try removing just WindowManager.wswmgr file in your <user dir>/config/Windows2Local?
Comment 23 Stanislav Aubrecht 2008-08-20 08:46:54 UTC
tomas, pls look at the attached message.log and evaluate this issue again. seems that the folder recognizer is running
in an infinite loop for some reason.
Comment 24 t_h 2008-08-20 09:09:48 UTC
openide.loaders->jtulach
Comment 25 Jaroslav Tulach 2008-08-20 15:57:53 UTC
Nice submission with the Windows2Local.zip, but it does not work, as it contains full paths to your sources which are 
not present on my disk. The IDE starts without a problem.

Try to start the IDE with some kind of logging enabled. For example: -J-Dorg.openide.loaders.FolderList.level=100
and attach the log here and reopen.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo