Bug 139742 - I18N - Progress bar overlaps with its text after pressing Finish button
I18N - Progress bar overlaps with its text after pressing Finish button
Status: RESOLVED DUPLICATE of bug 139139
Product: ide
Classification: Unclassified
Component: Code
6.x
All All
: P2 (vote)
: TBD
Assigned To: issues@ide
issues@ide
: I18N
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-11 15:15 UTC by kaa
Modified: 2008-07-31 08:00 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
image (76.12 KB, image/jpeg)
2008-07-11 15:17 UTC, kaa
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kaa 2008-07-11 15:15:45 UTC
Product Version: NetBeans IDE Dev (Build 0710)
Java: 1.6.0_06; Java HotSpot(TM) Client VM 10.0-b22
System: Windows XP version 5.1 running on x86; MS932; ja_JP (nb)
I'm running in the Japan locale, using a pseudo localized Netbeans with font size 16 option.
This seems true for any kind of project.

1. Open New WebApp wizard.
2. Press Finish button.

While the ide generating project files the progress bar overlaps with its text.
Manual resizing didn't help. See image.

Assumption is that user does not need to manually resize most windows or dialogs to see all of the UI objects and
information in them. I'm running in pseudo localized locale in which each message/label is sometimes longer than in
English. To account for that in some locales, translations from English (and some other euro languages) could be shown
with longer strings.

Also I'm running at font size 16, which is viewed as a valid font size that might be used. Resizing issues are not just
related to i18n; they might show to user in English locale if they run at larger font size.

Often, these issues happen because the length of some label or message or size of entire window is hardcoded vs using
layout managers or other techniques or api to have the windows or the objects in them, dynamically resize.
Comment 1 kaa 2008-07-11 15:17:16 UTC
Created attachment 64344 [details]
image
Comment 2 Peter Pis 2008-07-30 08:38:52 UTC
Reassigning to "web".
Comment 3 David Konecny 2008-07-31 00:40:55 UTC
Why this was moved to web? It is general problem of all wizards which may be either caused by current branding or is
problem in wizards infrastructure. Passing back to IDE to evaluate as branding related problem under the assumption that
it worked for NB6.1.
Comment 4 Jiri Prox 2008-07-31 08:00:43 UTC
Should be fixed now

*** This issue has been marked as a duplicate of 139139 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo