Bug 139542 - after renam proj wsimport generated code isn't recognize within editor
after renam proj wsimport generated code isn't recognize within editor
Status: RESOLVED FIXED
Product: webservices
Classification: Unclassified
Component: Code
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Milan Kuchtiak
issues@webservices
:
Depends on: 105645
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-10 09:20 UTC by oaspublic
Modified: 2009-02-19 23:29 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description oaspublic 2008-07-10 09:20:48 UTC
After rename a project (also rename dir) with wsimport created files the editor tools(?) don't see the generated classes.
I try to rebuild the classes with the wsimport from WebServiceReferences but the error already exits. The code run well
and also clean/ build works well. Only the editor don't know that there are genereated files.

Product Version: NetBeans IDE 6.1 (Build 200804211638)
Java: 1.6.0_04; Java HotSpot(TM) Client VM 10.0-b19
System: Windows 2000 version 5.0 running on x86; Cp1252; en (nb)
Userdir: C:\Dokumente und Einstellungen\Mueller\.netbeans\6.1

regards Dietmar
Comment 1 oaspublic 2008-07-14 11:45:04 UTC
After some (or one) restart from ide the problem is solved
Comment 2 Milos Kleint 2008-07-14 12:19:44 UTC
reassigning to webservices
Comment 3 Milan Kuchtiak 2008-09-05 14:52:31 UTC
Yes,

Another workaround is to open Project's properties window - and close it, or Close & Open the project.

Need help from Netbeans core guys - how to make sources generated in build/generated directory available for CC, after
project is renamed.
Comment 4 Milan Kuchtiak 2008-11-20 13:39:18 UTC
We expect project will be automatically aware of it's generated sources after rename.
Comment 5 Milan Kuchtiak 2009-02-04 16:53:36 UTC
Now, when task 105645 is implemented, it works.
The only step needed is to build the project again, since the Rename Project action cleans the generated sources.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo